Search found 11 matches

by bloodbat
Mon 15 Jan, 2018 6:06 pm
Forum: General
Topic: Math coprocessor funkiness/bugs?
Replies: 3
Views: 252

Re: Math coprocessor funkiness/bugs?

Ohh I see, thanks for clearing that up :)
Any chance of a fix to at least get the values displayed properly, or should I just use an SX machine for that?
by bloodbat
Mon 15 Jan, 2018 2:25 am
Forum: General
Topic: Math coprocessor funkiness/bugs?
Replies: 3
Views: 252

Math coprocessor funkiness/bugs?

Hello! I was testing some MS-DOS software using a PCem emulated 486DX2 and ran into some err...interesting bugs/quirks whenever the coprocessor is available. -Lotus 123 release 4 seems to store everything as floating point even when it's an integer if the coprocessor is available...how do I know? Wh...
by bloodbat
Thu 14 Dec, 2017 10:33 pm
Forum: General
Topic: Tandy Sound Issue
Replies: 15
Views: 396

Re: Tandy Sound Issue

Thanks, rev. 981 fixed the waves indeed :)
by bloodbat
Thu 14 Dec, 2017 9:59 pm
Forum: General
Topic: Tandy Sound Issue
Replies: 15
Views: 396

Re: Tandy Sound Issue

The fix for KQ3 fixed the music for KQ2 also; the waves in KQ2's first screen still sound off, though, here's a couple of clips one recorded using PCem, the other DosBox.
Thanks for the time taken trying to fix this :)
by bloodbat
Thu 14 Dec, 2017 9:57 am
Forum: General
Topic: Tandy Sound Issue
Replies: 15
Views: 396

Re: Tandy Sound Issue

I'm having the same issue, to be more specific: King's Quest 1 works fine for me, but King's Quest 2 and 3 exhibit the sound issue, I posted about it a while ago. The host machine is an AMD Phenom II 1090T, 8Gb. Ram, Win. 7, Nvidia Geforce GTX 750 Ti with 2 Gb. Vram and sound is output through a Sou...
by bloodbat
Sat 17 Dec, 2016 5:32 am
Forum: General
Topic: [Request] Add Roland MT-32/CM-32L/LAPC-I MIDI Emulation.
Replies: 2
Views: 1110

Re: [Request] Add Roland MT-32/CM-32L/LAPC-I MIDI Emulation.

Munt can already be used, problem is no smart MPU-401, it can...sometimes...be solved by using softmpu, but not always (Eric the Unready, for instance...doesn't work).
by bloodbat
Tue 30 Aug, 2016 6:07 pm
Forum: General
Topic: Problems with recent code commits.
Replies: 0
Views: 861

Problems with recent code commits.

Hi. I tend to keep my personal PCem build up to date with the latest developments, but I've run into a couple of issues with several of the last commits, maybe it's useful to you to be aware of them: -Floppy changing seems to be broken: I insert a disk into drive a, say I "dir" the contents...change...
by bloodbat
Tue 30 Aug, 2016 5:42 pm
Forum: General
Topic: Tandy 1000 sound problems.
Replies: 0
Views: 725

Tandy 1000 sound problems.

Hello :) A while ago I reported Tandy 1000 sound was broken with one of my builds, I was told no problems were reported, I thought it was an issue with my build and decided to live with it. PCem 11 has been released for some time and, being the curious sort, I decided to try the Tandy 1000, see if p...
by bloodbat
Mon 14 Mar, 2016 8:35 pm
Forum: General
Topic: A couple of PCem questions and a request.
Replies: 4
Views: 1389

Re: A couple of PCem questions and a request.

I just tested the stereo GUS, sounds great :D. Thanks a lot. I did further Tandy testing with that new build and some games sound fine (King's Quest 1, Space Quest 2, Space Quest 3, Police Quest 1, Leisure Suit Larry 1) while King's Quest 2 and 3 and Space Quest 1 don't. I made a couple of recording...
by bloodbat
Mon 14 Mar, 2016 6:27 pm
Forum: General
Topic: A couple of PCem questions and a request.
Replies: 4
Views: 1389

Re: A couple of PCem questions and a request.

Thanks :)
You're right...I tested Tandy with my build from the mercurial sources instead of the official one. Sorry :(.
by bloodbat
Mon 14 Mar, 2016 6:44 am
Forum: General
Topic: A couple of PCem questions and a request.
Replies: 4
Views: 1389

A couple of PCem questions and a request.

Hi! First and foremost thanks for all the work put in this wonderful emulator. :) Now a question...is the GUS emulation stereo enabled? I tried it with several games (Doom, Epic Pinball and Extreme Pinball) and they all seem to output mono audio. Did I miss some configuration point? Tandy 1000 sound...