Search found 87 matches

by jznomoney
Wed 24 Apr, 2019 10:43 pm
Forum: Development
Topic: v15 & new recompiler update
Replies: 53
Views: 7797

Re: v15 & new recompiler update

I figured out my issues. In the src folder in Makefile.am I was missing cassette.c acc2168.c i430hx.c and acc3221.c under pcem_SOURCES =
by jznomoney
Wed 24 Apr, 2019 10:25 pm
Forum: Development
Topic: v15 & new recompiler update
Replies: 53
Views: 7797

Re: v15 & new recompiler update

I have the makefile fixes commit. I deleted the whole folder and pulled it again and still doesn't work.
by jznomoney
Wed 24 Apr, 2019 10:14 pm
Forum: Development
Topic: v15 & new recompiler update
Replies: 53
Views: 7797

Re: v15 & new recompiler update

I get this: pcem-keyboard_pcjr.o:keyboard_pcjr.c:(.text+0x3fd): undefined reference to `cassette_set_motor' pcem-keyboard_pcjr.o:keyboard_pcjr.c:(.text+0x561): undefined reference to `cassette_input' pcem-keyboard_xt.o:keyboard_xt.c:(.text+0x37f): undefined reference to `cassette_set_motor' pcem-key...
by jznomoney
Tue 09 Apr, 2019 12:45 pm
Forum: Development
Topic: Packard Bell Legend 760 Supreme (PB410A)
Replies: 18
Views: 2335

Re: Packard Bell Legend 760 Supreme (PB410A)

I just build pcem for the first time in awhile. The specified rom file is named PB410A.080337.4ABF.U25.bin but you had a commit awhile ago to make all the roms in lower case. Can you commit a change to make this rom file name in lower case as well? Thanks in advanced. Edited here: There are also sev...
by jznomoney
Thu 04 Apr, 2019 11:58 pm
Forum: Development
Topic: Packard Bell Legend 760 Supreme (PB410A)
Replies: 18
Views: 2335

Re: Packard Bell Legend 760 Supreme (PB410A)

I am getting a compile error with commit 1211. pcem-acc2036.o:acc2036.c:(.text+0x1d0): multiple definition of `acc2036_init' pcem-acc2036.o:acc2036.c:(.text+0x1d0): first defined here pcem-model.o:model.c:(.text+0x14e2): undefined reference to `acc3221_init' collect2.exe: error: ld returned 1 exit s...
by jznomoney
Wed 16 Jan, 2019 12:36 am
Forum: Merged patches
Topic: Add Epox P55-VA, ASUS P/I P55TVP4 and ASUS P/I-P55T2P4 motherboards *FIXED*
Replies: 12
Views: 2471

Re: Add Epox P55-VA, ASUS P/I P55TVP4 and ASUS P/I-P55T2P4 motherboards *FIXED*

I'm getting a compile error now pcem-i430hx.o:i430hx.c:(.text+0x0): multiple definition of `i430hx_read' pcem-i430hx.o:i430hx.c:(.text+0x0): first defined here pcem-i430hx.o:i430hx.c:(.text+0x20): multiple definition of `i430hx_write' pcem-i430hx.o:i430hx.c:(.text+0x20): first defined here pcem-i430...
by jznomoney
Sun 23 Dec, 2018 12:41 pm
Forum: Development
Topic: v15 & new recompiler update
Replies: 53
Views: 7797

Re: v15 & new recompiler update

Merry Christmas
by jznomoney
Thu 07 Jun, 2018 10:39 pm
Forum: Patches
Topic: [Depreciated][Patch] VHD support
Replies: 15
Views: 2547

Re: [Patch] VHD support

Great job on this patch. Issue I have is any vhd I create larger than 2048mb is not mountable under windows. I tried different sizes because the first one I tried was 4096mb and pcem worked fine. I installed Windows ME. When I tried mounting the vhd in windows it did not work. So I created smaller o...
by jznomoney
Mon 07 May, 2018 2:09 pm
Forum: General
Topic: Sound stutters whatever the configuration
Replies: 22
Views: 3524

Re: Sound stutters whatever the configuration

Sorry for digging up that thread, but I have the same sound stuuter problem with v13 and v14. I think the problem is only with Windows. Sound in Dos works with the same emulated machine perfect. My emulated machine is 166 Mhz MMX, 16 MB Ram, SB 16, ATI Graphics Pro Turbo (Mach64 GX), Windows 95c (t...
by jznomoney
Sun 29 Apr, 2018 11:50 am
Forum: General
Topic: MacOS X
Replies: 18
Views: 4370

Re: MacOS X

also if I don't run autoreconf it builds fine as long as a chmod a+x install-sh.
by jznomoney
Sun 29 Apr, 2018 10:59 am
Forum: General
Topic: MacOS X
Replies: 18
Views: 4370

Re: MacOS X

The undef worked and pcem built fine. Unfortunately I can't use autireconf -i on mac because it messes up the configuration file and it can't locate sdl2. when I run autoreconf -i I get this Jamess-Mac:pcem jznomoney$ autoreconf -i src/Makefile.am:18: warning: shell wx-config --rescomp: non-POSIX va...
by jznomoney
Fri 27 Apr, 2018 8:17 pm
Forum: General
Topic: MacOS X
Replies: 18
Views: 4370

Re: MacOS X

@JosepMa I renamed the cycles in ibm.h to cycles1 and I still get the error /usr/include/mach/task_inspect.h:45:11: error: expected ';' at end of declaration list uint64_t cycles; ^ ./ibm.h:181:25: note: expanded from macro 'cycles' #define cycles cpu_state._cycles1 ^ I have attached task_inspect.h ...
by jznomoney
Wed 25 Apr, 2018 12:41 pm
Forum: General
Topic: MacOS X
Replies: 18
Views: 4370

Re: MacOS X

I don't think the cdrom emulation under osx works good. When I insert a cd drive it crashes out. I will attach a log and my config.

Edit: It seems like it only craps out when I have a cd mounted at boot. I will let you know If I find anything else out.
by jznomoney
Wed 25 Apr, 2018 12:28 pm
Forum: General
Topic: MacOS X
Replies: 18
Views: 4370

Re: MacOS X

I got it to compile by commenting out /* uint64_t cycles; */ in the task_inspect.h. There is no networking so maybe I missed something else?
by jznomoney
Wed 25 Apr, 2018 10:08 am
Forum: General
Topic: MacOS X
Replies: 18
Views: 4370

Re: MacOS X

I had to chmod a+x install-sh but then I got my error above.
by jznomoney
Tue 24 Apr, 2018 12:33 pm
Forum: General
Topic: MacOS X
Replies: 18
Views: 4370

Re: MacOS X

I keep getting this error when trying to build for osx. I am using high sierra 10.13.4. In file included from cdrom-ioctl-osx.c:8: In file included from /System/Library/Frameworks/IOKit.framework/Headers/IOKitLib.h:42: In file included from /usr/include/mach/mach_types.h:92: /usr/include/mach/task_i...
by jznomoney
Fri 20 Apr, 2018 7:34 pm
Forum: General
Topic: MacOS X
Replies: 18
Views: 4370

MacOS X

Is there a guide to build pcem for macos x?
by jznomoney
Mon 02 Apr, 2018 7:00 pm
Forum: General
Topic: Bug Win95 with rtl8029AS
Replies: 4
Views: 1052

Re: Bug Win95 with rtl8029AS

Here you go. Like I said it happens even when I create a new config and only when the driver is loaded in windows.
by jznomoney
Sat 31 Mar, 2018 11:10 pm
Forum: General
Topic: Bug Win95 with rtl8029AS
Replies: 4
Views: 1052

Re: Bug Win95 with rtl8029AS

It seems to be this merge
f6c46bc

Added level-sensitive IRQs on PIIX and SiS497
by jznomoney
Sat 31 Mar, 2018 10:58 pm
Forum: General
Topic: Bug Win95 with rtl8029AS
Replies: 4
Views: 1052

Bug Win95 with rtl8029AS

I don't know what happened to the rtl8029as under windows 95. Something was merged recently that has made windows 95 not boot anymore with that card. As soon as you have the driver installed under windows 95 and you restart, windows keeps going on an endless reboot. This wasn't present last month wh...
by jznomoney
Mon 05 Mar, 2018 2:05 pm
Forum: General
Topic: CDROM speen undetectable Star Trek A Final Unity Installer
Replies: 7
Views: 1830

Re: CDROM speen undetectable Star Trek A Final Unity Installer

I got it to work. I loaded smartdrv before mscdex.
by jznomoney
Mon 05 Mar, 2018 1:32 am
Forum: General
Topic: CDROM speen undetectable Star Trek A Final Unity Installer
Replies: 7
Views: 1830

Re: CDROM speen undetectable Star Trek A Final Unity Installer

I tried it with dos 6.22 and an mounting the cdrom with pcem. Still have the same issue. I also tried a different machine type and it does the same thing.
by jznomoney
Thu 01 Mar, 2018 9:55 pm
Forum: Merged patches
Topic: [Patch] Xi8088 - GPL XT system bios
Replies: 15
Views: 3346

Re: [Patch] Xi8088 - GPL XT system bios

I keep having a hard time with the keyboard with this machine. Sometime it works sometimes it doesn't. I can't really explain it.
by jznomoney
Wed 28 Feb, 2018 12:50 am
Forum: General
Topic: hiccups with 0% cpu used (host) 0% speed in PCem
Replies: 10
Views: 1945

Re: hiccups with 0% cpu used (host) 0% speed in PCem

I ran it on my i7 970 which is the same socket as your pc 6 cores 12 threads and it ran just fine. I even played a game of warcraft to on an emulated pentium 120mhz.
by jznomoney
Tue 27 Feb, 2018 9:56 pm
Forum: General
Topic: CDROM speen undetectable Star Trek A Final Unity Installer
Replies: 7
Views: 1830

CDROM speen undetectable Star Trek A Final Unity Installer

When running the installer for star trek unity it cannot detect the cdrom drive speed. I know it a vitual cdrom I am using but it should at least show some kind of transfer rate. I am unable to install the game.


Screenshot from 2018-02-27 16-56-19.png
Screenshot from 2018-02-27 16-56-19.png (34.05 KiB) Viewed 1829 times
by jznomoney
Tue 27 Feb, 2018 9:12 pm
Forum: General
Topic: hiccups with 0% cpu used (host) 0% speed in PCem
Replies: 10
Views: 1945

Re: hiccups with 0% cpu used (host) 0% speed in PCem

Are the hyper-v machines running when you use pcem? If so it will affect performance. Try running pcem with the hyper-v machines powered off.
by jznomoney
Tue 27 Feb, 2018 12:01 am
Forum: General
Topic: hiccups with 0% cpu used (host) 0% speed in PCem
Replies: 10
Views: 1945

Re: hiccups with 0% cpu used (host) 0% speed in PCem

I have a spare i7 970 machine I can try it out tomorrow. What are the other specs of your machine?
by jznomoney
Mon 26 Feb, 2018 8:50 pm
Forum: Merged patches
Topic: [Patch] Packard Bell Legend 300SX
Replies: 42
Views: 7902

Re: [Patch] Packard Bell Legend 300SX

PCem doesn't crash anymore on the pb570 thank Sarah.
by jznomoney
Mon 26 Feb, 2018 7:26 pm
Forum: Merged patches
Topic: [Patch] Packard Bell Legend 300SX
Replies: 42
Views: 7902

Re: [Patch] Packard Bell Legend 300SX

So it seems like if I have any cd image mounted in pcem it crashes at boot. I installed poweriso and mounted a cd image in a virtual drive and then had pcem use that drive it works fine. It only happens when using the packard bell pb570.
by jznomoney
Sun 25 Feb, 2018 10:19 pm
Forum: Merged patches
Topic: [Patch] Packard Bell Legend 300SX
Replies: 42
Views: 7902

Re: [Patch] Packard Bell Legend 300SX

SarahWalker wrote:
Sun 25 Feb, 2018 10:06 pm
Could you attach the NVR file?
Sure here it is. It is worth mentioning I had deleted the nvr file and then tried again and it still happened.