Search found 264 matches

by szadycbr
Fri 26 Apr, 2019 7:03 am
Forum: Development
Topic: v15 & new recompiler update
Replies: 53
Views: 7827

Re: v15 & new recompiler update

Hey gladstone, it is all different than x86_64 cpu, i thought your compiling procedure could help, but no :( anyway, it is fascinating that PCem runs on this cpu, you got better phones this days, so i guess year or two and we should see somehow Android port! thanks, and take care :)
by szadycbr
Thu 25 Apr, 2019 5:17 pm
Forum: Development
Topic: v15 & new recompiler update
Replies: 53
Views: 7827

Re: v15 & new recompiler update

hey , gladstone , what compiling tools and what version do you have on this chromebook? did you try 430vx board? EDIT: do you have intel cpu i your chromebook? the chromebook debian 9 version must be bit different. but chrome was talking about it being ready for developers. but your is probably arm6...
by szadycbr
Thu 25 Apr, 2019 4:40 pm
Forum: General
Topic: Trouble compiling latest source on OpenSUSE Tumbleweed
Replies: 9
Views: 180

Re: Trouble compiling latest source on OpenSUSE Tumbleweed

sorry for spamming but i noticed that i had few more warnings up above in terminal but i didnt see it at first : codegen_allocator.c: In function ‘codegen_allocator_allocate’: codegen_allocator.c:56:28: warning: implicit declaration of function ‘rand’ [-Wimplicit-function-declaration] block_nr = ran...
by szadycbr
Thu 25 Apr, 2019 4:11 pm
Forum: General
Topic: Trouble compiling latest source on OpenSUSE Tumbleweed
Replies: 9
Views: 180

Re: Trouble compiling latest source on OpenSUSE Tumbleweed

Hi Sarah, i did it on I5-2410m laptop using q$os (Debian 9) , and compiling tools from stretch repositories as below ii clang 1:3.8-36 amd64 C, C++ and Objective-C compiler (LLVM based) ii clang-3.8 1:3.8.1-24 amd64 C, C++ and Objective-C compiler (LLVM based) ii g++ 4:6.3.0-4 amd64 GNU C++ compiler...
by szadycbr
Thu 25 Apr, 2019 12:12 pm
Forum: General
Topic: Trouble compiling latest source on OpenSUSE Tumbleweed
Replies: 9
Views: 180

Re: Trouble compiling latest source on OpenSUSE Tumbleweed

also i get this during compile : codegen_backend_x86-64.c: In function ‘codegen_backend_init’: codegen_backend_x86-64.c:315:23: warning: passing argument 2 of ‘host_x86_CALL’ makes pointer from integer without a cast [-Wint-conversion] host_x86_CALL(block, (uintptr_t)x86gpf); ^ In file included from...
by szadycbr
Thu 25 Apr, 2019 11:25 am
Forum: General
Topic: Trouble compiling latest source on OpenSUSE Tumbleweed
Replies: 9
Views: 180

Re: Trouble compiling latest source on OpenSUSE Tumbleweed

Now i see that i can run it fine on any cpu without recompiler :( so no recompiler in my build :(
by szadycbr
Thu 25 Apr, 2019 11:00 am
Forum: General
Topic: Trouble compiling latest source on OpenSUSE Tumbleweed
Replies: 9
Views: 180

Re: Trouble compiling latest source on OpenSUSE Tumbleweed

Hi Sarah, thank you very much for this! this is great! now it compiles fine , without any error but something must be broken as i can not run any board, i did compile it on debian 9 , and any pentium, 386, 486 boards with various cpus does not work, i get boot screen sometimes , like this : Screensh...
by szadycbr
Thu 25 Apr, 2019 6:55 am
Forum: General
Topic: Trouble compiling latest source on OpenSUSE Tumbleweed
Replies: 9
Views: 180

Re: Trouble compiling latest source on OpenSUSE Tumbleweed

hey in this thread https://pcem-emulator.co.uk/phpBB3/viewtopic.php?f=3&t=3162&start=30 take the attached makefile.am and replace it in src directory. at first i just copy and rename codegen_backend.c to codegen_block.c or viceversa, anyway it go through but with erros of course. then it start compl...
by szadycbr
Wed 24 Apr, 2019 10:29 pm
Forum: Development
Topic: v15 & new recompiler update
Replies: 53
Views: 7827

Re: v15 & new recompiler update

Ps. leilei , my gcc is 4.6.3 from debian stretch repos, is it not good enough? EDIT: also with enable release i get this : .o `test -f 'codegen.c' || echo './'`codegen.c mv -f .deps/pcem-codegen.Tpo .deps/pcem-codegen.Po make[1]: *** No rule to make target 'codegen_backend.c', needed by 'pcem-codege...
by szadycbr
Wed 24 Apr, 2019 10:18 pm
Forum: Development
Topic: v15 & new recompiler update
Replies: 53
Views: 7827

Re: v15 & new recompiler update

Thanks leilei, and jznomoney , with normal procedure i get this also, exactely :(
by szadycbr
Wed 24 Apr, 2019 9:58 pm
Forum: Development
Topic: v15 & new recompiler update
Replies: 53
Views: 7827

Re: v15 & new recompiler update

Hi Everyone, i get this error : codegen_x86-64.c:16:32: fatal error: codegen_ops_x86-64.h: No such file or directory . and yeah the codegen_ops_x86-64.h is missing, is it on my side? or it is missing everywhere ?
by szadycbr
Thu 18 Apr, 2019 9:07 am
Forum: General
Topic: slow file copy from floppy, CD, and HDD
Replies: 6
Views: 357

Re: slow file copy from floppy, CD, and HDD

Hi swapjim , the answer is YES and NO . the answer isnt that straight forward. drives from that days were much much slower :) than todays drives, i just want to tell you , you are happy that PCem do it that way, it is still faster than using real old CD rom and floppy drives :) . copying files requi...
by szadycbr
Thu 21 Feb, 2019 11:54 am
Forum: General
Topic: PCem Won’t Boot Windows
Replies: 7
Views: 863

Re: PCem Won’t Boot Windows

Hi IMeganElisabeth, you must enter bios setup and set up boot from CD if you have bootable cd, if from floppy then you must set boot from floppy in bios. i assume you use 430vx board, so all that is in bios options, press Delete key to get in, it says so during memory test on 430vx.
by szadycbr
Sun 13 Jan, 2019 10:21 pm
Forum: General
Topic: Serious performance issues
Replies: 7
Views: 1610

Re: Serious performance issues

dondiego "CPU usage is very low, core 0 is below 50% and core 1 even lower" are you sure it is wrong? i think 50% or so its all you could get on 2 cores showing in windows , if you change in bios to single core cpu then you should get nearly 100% cpu utilization, so on 2 cores if you are not using v...
by szadycbr
Wed 02 Jan, 2019 8:16 pm
Forum: General
Topic: Cirrus CL-GD5429: graphics corruption in DOS after loading windows 95
Replies: 4
Views: 924

Re: Cirrus CL-GD5429: graphics corruption in DOS after loading windows 95

SA 1988 , sorry for that, the 86Box link itself did wind me up :( , and again i become a moron :(
My appologies for jumping to coclussions.
by szadycbr
Wed 02 Jan, 2019 6:57 pm
Forum: General
Topic: Cirrus CL-GD5429: graphics corruption in DOS after loading windows 95
Replies: 4
Views: 924

Re: Cirrus CL-GD5429: graphics corruption in DOS after loading windows 95

dondiego , bro , this is not PCem but pcem clone, and anything with 86box will not be discussed here, you can download PCem source from https://bitbucket.org/pcem_emulator/pcem/downloads/ and compile yourself, then if anything is wrong it will be discussed here. Please dont mention 86Box here as it ...
by szadycbr
Sat 22 Dec, 2018 9:02 am
Forum: Development
Topic: unable to compile PCem under Linux
Replies: 13
Views: 2381

Re: unable to compile PCem under Linux

Katakis , i think you allready have all you need, do ./configure once again and see whats missing , libgtk-3-dev isnt requried, i dont use it. what distro are you using ,ubuntu stable/testing ? remember , if you try download separate libs from internet you must install correct version, otherwise dep...
by szadycbr
Fri 21 Dec, 2018 7:21 am
Forum: Development
Topic: unable to compile PCem under Linux
Replies: 13
Views: 2381

Re: unable to compile PCem under Linux

Katakis, shermap said right, most of the libs should have -dev at the end , as this are libs for developers, you will get there, it is very simple, and after you have sane environment and it still causes you problems , go to src folder and execute : make -f Makefile.linux64-wx-sdl2 it should compile...
by szadycbr
Thu 20 Dec, 2018 9:09 am
Forum: Development
Topic: unable to compile PCem under Linux
Replies: 13
Views: 2381

Re: unable to compile PCem under Linux

and again, despite all problems during configure it still compiles fine from src folder by "make -f Makefile.linux64-wx-sdl2" ??? so what is it that i am missing by using this command insted of ./configure and make?
by szadycbr
Thu 20 Dec, 2018 9:01 am
Forum: Development
Topic: unable to compile PCem under Linux
Replies: 13
Views: 2381

Re: unable to compile PCem under Linux

hmm...??? and i got this pcem-wx-config.o: In function `config_dlgsave': wx-config.c:(.text+0x3252): undefined reference to `loadbios' pcem-pc.o: In function `initpc': pc.c:(.text+0x1a5f): undefined reference to `loadbios' pcem-video.o:(.data.rel+0xe28): undefined reference to `sigma_device' pcem-wx...
by szadycbr
Thu 20 Dec, 2018 7:55 am
Forum: Development
Topic: unable to compile PCem under Linux
Replies: 13
Views: 2381

Re: unable to compile PCem under Linux

isnt c++ or g++ necessary? it says "checking whether the C compiler works... no" ,open synaptic and look for it. thats what i would do, but i dont really know. PS: it should look more or less like this : checking build system type... x86_64-unknown-linux-gnu checking host system type... x86_64-unkno...
by szadycbr
Thu 06 Dec, 2018 7:16 am
Forum: Development
Topic: Using physical hard disk in PCem on UNIX/Linux systems
Replies: 10
Views: 2095

Re: Using physical hard disk in PCem on UNIX/Linux systems

Hey Martin , thank You , this is kinda cool. i guess memory stick in linux could be used to. ill try it later, but i like the idea and possibillity :)
by szadycbr
Tue 27 Nov, 2018 10:45 am
Forum: General
Topic: Is drive sound emulation possible?
Replies: 21
Views: 4270

Re: Is drive sound emulation possible?

Thank You leilei, this is very nice, maybe still need to be polished but really this drive sounds idea is very very cool and You have done great job. it all could disappear in near future, thanks to You and like minded people, hopefully it will be preserved. :)
by szadycbr
Wed 21 Nov, 2018 1:23 pm
Forum: Development
Topic: Fix Makefile.in for build
Replies: 16
Views: 2542

Re: Fix Makefile.in for build

few days ago i did same as Martin, i found same problem in debian but seeing that linux has litlle or no attention lately, i did not post about it. compiling straight from src, needed only to remove references to sigma device from video.c and ibm.h . looks as if more and more people go with linux, a...
by szadycbr
Fri 02 Nov, 2018 6:24 pm
Forum: General
Topic: Ctrl-Alt-PageDown not working
Replies: 7
Views: 1105

Re: Ctrl-Alt-PageDown not working

hmm, maybe it is just simply wrong codepage in your system? maybe do set standard english keyboard, what languadge do You use?
PS. if you have weak host CPU then stay on v12 i found it more efficient.
by szadycbr
Fri 02 Nov, 2018 2:22 pm
Forum: General
Topic: Ctrl-Alt-PageDown not working
Replies: 7
Views: 1105

Re: Ctrl-Alt-PageDown not working

soounds unfortunate, but then why You are using v12 instead of v14? and beside i had problems you describe but in linux, never on windows. and what mean the first sentence "As I said, from the version 13 of PCem....." ??? as You said what? maybe You spoke in other forum but not here. Describe Your p...
by szadycbr
Thu 01 Nov, 2018 10:06 pm
Forum: General
Topic: Ctrl-Alt-PageDown not working
Replies: 7
Views: 1105

Re: Ctrl-Alt-PageDown not working

hm, i just compiled newest src. and in native linux everythings works ok. also v14 release version for windows has no problems in wine on linux.
the shortcut seems to work ok on both, on linux and windows version.
by szadycbr
Sun 21 Oct, 2018 6:25 am
Forum: Development
Topic: compiling error
Replies: 14
Views: 3153

Re: compiling error

te_lanus , you right , something is wrong , i done ./configure then make and i get this pcem-wx-config.o: In function `config_dlgsave': wx-config.c:(.text+0x3252): undefined reference to `loadbios' pcem-pc.o: In function `initpc': pc.c:(.text+0x1bcd): undefined reference to `loadbios' pcem-wx-sdl2.o...
by szadycbr
Thu 18 Oct, 2018 4:21 pm
Forum: General
Topic: Issues on VMware Workstation
Replies: 11
Views: 1634

Re: Issues on VMware Workstation

Araripe, i was right , it is fault of mouse integration, seamless in VMware, it is not designed for gaming, etc. i run it on VMware player 15 for linux, and i installed ubuntu, then compiled PCem and you were right, no mouse at all. you must find .vmx configuration file from your mahine and add at t...
by szadycbr
Tue 16 Oct, 2018 6:33 pm
Forum: General
Topic: Issues on VMware Workstation
Replies: 11
Views: 1634

Re: Issues on VMware Workstation

Hi, dont know what you mean exactely, but i often have similar problems in Vbox when mouse integration is on, dont know about vmware but you can try to turn it off, if such option exists on vmware.