Search found 59 matches

by gen_angry
Tue 09 Jan, 2018 9:06 pm
Forum: General
Topic: Host machine survey
Replies: 97
Views: 24234

Re: Host machine survey

I tossed this on my laptop with a Pentium N3700 as a test the other day (my sister has the same laptop and she was interested in a few old DOS games). The fastest machine it seems to be able to keep at 100% emulator speed with the recompiler off is a 486DX-33. It can handle a DX2-66 if I don't play ...
by gen_angry
Tue 02 Jan, 2018 5:26 am
Forum: General
Topic: Warcraft Orcs and Humans
Replies: 8
Views: 340

Re: Warcraft Orcs and Humans

Snowman wrote:Here is what the patch 1.22h fixes: https://wow.gamepedia.com/Warcraft:_Orc ... nformation
Yea I saw that, but I cant seem to find it anywhere on the net. Latest I can find is 1.21
by gen_angry
Mon 01 Jan, 2018 7:52 pm
Forum: General
Topic: Warcraft Orcs and Humans
Replies: 8
Views: 340

Re: Warcraft Orcs and Humans

Snowman wrote:I just tested CD version 1.22h and everything works fine. I used 386DX/33 and 486DX/33-DX2/66 with and without dynamic recompiler.
I have the original retail disk, latest patch I could find was 1.21 on google for it.

Maybe your version fixes whatever's making things trip out?
by gen_angry
Mon 01 Jan, 2018 7:51 pm
Forum: General
Topic: Warcraft Orcs and Humans
Replies: 8
Views: 340

Re: Warcraft Orcs and Humans

Are you running with the dynamic recompiler enabled? There are definitely some odd issues with using that with lower speed 486s. Set it back to 66mhz with dynamic recompiler off, it works. Turned it back on... it works now? lol. I haven't a clue but if it happens again I will look at that first. Th...
by gen_angry
Mon 01 Jan, 2018 6:28 am
Forum: General
Topic: Warcraft Orcs and Humans
Replies: 8
Views: 340

Re: Warcraft Orcs and Humans

I fixed it somehow from changing the CPU speed from DX2-66 to DX4-100. All games work now, even Warcraft. Going back to 66mhz breaks them again.

Strange, guess my 'DOS machine' got an upgrade. lol

Not sure if this is a PCem bug?
by gen_angry
Mon 01 Jan, 2018 5:54 am
Forum: General
Topic: Warcraft Orcs and Humans
Replies: 8
Views: 340

Warcraft Orcs and Humans

Hello, I am trying to play Warcraft Orcs and Humans from a legally owned disk on a DOS 6.22 system. It installs fine but setup/game will freeze when I try to run it. (CPU activity drops to 0, blinking cursor forever). The docs suggested to disable smartdrive and EMM386 which did not help. I even tri...
by gen_angry
Mon 01 Jan, 2018 4:28 am
Forum: General
Topic: v13.1 released!
Replies: 17
Views: 1534

Re: v13.1 released!

I know this was only a minor release for bug fixes but I hope Sarah will make some more so those of us who don't compile between releases can get some of the fixes that'll come before v14. But either way, keep up the good work Sarah! Meh, I can see the appeal on the distant releases. It's a coding ...
by gen_angry
Fri 22 Dec, 2017 9:15 pm
Forum: General
Topic: v13 released!
Replies: 25
Views: 1520

Re: v13 released!

SarahWalker wrote:Wait and be patient - I haven't even started writing it yet?
We all just enjoy it so much that it's like candy. More! more! more!

Thank you (and all contributors) for all the work that you do. :)
by gen_angry
Mon 18 Dec, 2017 6:38 am
Forum: General
Topic: v13 - Mouse Issues
Replies: 13
Views: 455

Re: v13 - Mouse Issues

I just found out that it was a problem with Wine, not PCem. Changing Wine's screen mode to X11 instead of Mac Driver makes the mouse go fast, but it tends to jump to a random position as I move it. Also, I notice that the host mouse cursor appears out of nowhere even if I pressed CTRL-END to releas...
by gen_angry
Sun 17 Dec, 2017 5:21 pm
Forum: General
Topic: Battle Chess Enhanced CD-ROM for DOS, version 1.00
Replies: 7
Views: 320

Re: Battle Chess Enhanced CD-ROM for DOS, version 1.00

First thing I can think of: Are you using MSCDEX driver or one of the newer ones like SHSUCDX?

I had a lot of strange behavior using SHSUCDX so I switched back, with a proper config/autoexec setup you can fit it all into UMB anyways.
by gen_angry
Sun 17 Dec, 2017 4:55 pm
Forum: General
Topic: v13.1 released!
Replies: 17
Views: 1534

Re: v13.1 released!

Thank you, yet again :) update time!
by gen_angry
Fri 15 Dec, 2017 5:45 pm
Forum: General
Topic: Finishable games
Replies: 4
Views: 399

Re: Finishable games

Using Intel 486DX-66 on award sis 496/497 board, 16mb ram, Ive been using this freeware coco2 emulator without problems so far. v13

Emulator within an emulator, heh.
by gen_angry
Fri 15 Dec, 2017 5:25 pm
Forum: Development
Topic: [Bug] Hard drive type size
Replies: 3
Views: 220

Re: [Bug] Hard drive type size

erm, when I tried to close the 386 machine - it crashed. Not sure if related.

attached event viewer export in zip file
by gen_angry
Fri 15 Dec, 2017 5:06 pm
Forum: Development
Topic: [Bug] Hard drive type size
Replies: 3
Views: 220

Re: [Bug] Hard drive type size

I used type 47 and entered the details manually. But I will try type 32 in there and reformat.

edit: I deleted the disk file entirely, remade it, and now it shows correct size. Not sure what happened there. Probably user error :( I've been doing that a lot lately...

Sorry about that.
by gen_angry
Fri 15 Dec, 2017 7:56 am
Forum: Development
Topic: [Bug] Hard drive type size
Replies: 3
Views: 220

[Bug] Hard drive type size

I set up a new 386 machine, used a new type 32 hard drive from the list (17 sector, 15 heads, 1024 cylinder = 127MB) https://i.imgur.com/2cFIkjt.png Installed MS-DOS 5.00a using default options (auto format whole drive). Typed DIR, saw there was more than 300mb free. Used FDISK, get this: https://i....
by gen_angry
Thu 14 Dec, 2017 8:07 pm
Forum: General
Topic: v13 BIOS locations
Replies: 4
Views: 545

Re: v13 BIOS locations

SarahWalker wrote:They're also in readme.txt, which should be somewhat easier to look at.
Yea, I found that out after I made the post :( For some reason, it didn't extract the first time.

Not my brightest moment there, lol.
by gen_angry
Thu 14 Dec, 2017 7:07 am
Forum: General
Topic: v13 BIOS locations
Replies: 4
Views: 545

Re: v13 BIOS locations

nvm, I'm smrt. The readme.txt file didn't extract for some reason from the zip which has what I need in it.

Man I spent forever digging trying to find it and it was so simple, even finding out 5 min after posting like a goof :(

Thank you anyways, and great update :D
by gen_angry
Thu 14 Dec, 2017 7:02 am
Forum: General
Topic: v13 BIOS locations
Replies: 4
Views: 545

v13 BIOS locations

Hello,

Is there somewhere in the source or documentation where BIOS/ROM files for the newly supported machines are named/located in v13?

I tried digging through the source a bit for a while and couldn't find anything.

Thank you :)
by gen_angry
Thu 14 Dec, 2017 4:57 am
Forum: General
Topic: PCem 13 first impressions
Replies: 15
Views: 792

Re: PCem 13 first impressions

Messed with the win95 machine to add the SLI (and increased texture size), tried q3a timedemo again. Gained a bit of FPS even using a 233MMX. :)

I really do like the additions, especially the separate BIOS files. :) Thank you Sarah for the update.
by gen_angry
Thu 14 Dec, 2017 3:54 am
Forum: Development
Topic: [Bug] Cant use periods in Config Manager
Replies: 1
Views: 158

[Bug] Cant use periods in Config Manager

v13.

Made a new machine called "Win 3.1 (P75)"

it truncates after the ., so the machine ends up being called "Win 3" in the GUI.

This machine can't save any new machine details, (defaults to XT, no drives setup, etc). I can't even delete it from the GUI (can delete file itself).
by gen_angry
Tue 12 Dec, 2017 1:46 am
Forum: General
Topic: PCem 13 first impressions
Replies: 15
Views: 792

Re: PCem 13 first impressions

I especially like the new config manager, no more messing with batch files.

With this config manager, does that mean that BIOS settings are unique to the machine too? As in, I can build two completely separate machines with the 430VX chipset?
by gen_angry
Tue 12 Dec, 2017 12:47 am
Forum: General
Topic: v13 released!
Replies: 25
Views: 1520

Re: v13 released!

sweet :D thanks a bunch!

edit: note, README and NEWS files are blank. (and Im probably the only clown that actually reads those, lol)
by gen_angry
Tue 12 Dec, 2017 12:47 am
Forum: General
Topic: Hardware Donation?
Replies: 2
Views: 152

Re: Hardware Donation?

Yea I may have some old bits of hardware around, I could chip in (if I still have them). Interested as well :)
by gen_angry
Sun 03 Dec, 2017 3:20 am
Forum: Development
Topic: Spam issues!
Replies: 12
Views: 681

Re: Spam issues!

one phpbb board i've been to combats spambots by renaming php files and correcting the links (i.e. potato.php) Meh, I would advise against that just because it'd be a real hassle to update. Especially in the case of security hotfixes/patches. Unless you've got a sys admin that really does not mind ...
by gen_angry
Sat 02 Dec, 2017 10:26 pm
Forum: Development
Topic: Spam issues!
Replies: 12
Views: 681

Re: Spam issues!

I've set a limit of 20 new topics per user per day - hopefully this means that if any spammers slip through the net it should be a bit less dramatic than it was today! Which version of phpbb are you running? I haven't looked recently but last I saw, phpbb 3.1 and 3.2 had a number of anti spam exten...
by gen_angry
Mon 30 Oct, 2017 7:15 pm
Forum: Development
Topic: Patch: Toshiba T3100e
Replies: 33
Views: 2314

Re: Patch: Toshiba T3100e

Question/Feature request: if the display for this is a 'display adapter' setting for a particular type of monochrome screen adapter, any chance that someone could make a 'blue screen' option? ie: https://3.bp.blogspot.com/-Mw0I2B3iDS4/WH9aZqkp5eI/AAAAAAAAQ3w/N_D75HyBLaQK3HQaJ39jjAsSK_16zQ4JACEw/s160...
by gen_angry
Thu 26 Oct, 2017 11:37 pm
Forum: Development
Topic: [Possible Bug?] Blank CGA
Replies: 5
Views: 299

Re: [Possible Bug?] Blank CGA

You are missing the MDA video adapter font (mda.rom) hence the CGA adapter isn't working properly. This also effects the Hercules, MDA, and other CGA-based video adapters (like Plantronics ColorPlus) though it doesn't effect VGA and EGA adapters. Try to put 'mda.rom' (or if you didn't have it, try ...
by gen_angry
Thu 26 Oct, 2017 8:58 pm
Forum: Development
Topic: [Possible Bug?] Blank CGA
Replies: 5
Views: 299

[Possible Bug?] Blank CGA

Hello, I am trying to create an AMI XT with an 8088 7.16Mhz CPU + CGA graphics. Using v12 stable release. When I try to boot up, all text is blank (and the cursor moves like it is doing something). However, using an ET4000 (for testing) works and all text is displayed. PCem.cfg is attached. pcem.cfg...
by gen_angry
Thu 26 Oct, 2017 8:47 pm
Forum: General
Topic: Sharp PC-4521 in PCem?
Replies: 6
Views: 521

Re: Sharp PC-4521 in PCem?

That's unfortunate, maybe some day in the future than.

Thank you both for your responses. :)
by gen_angry
Wed 25 Oct, 2017 6:53 pm
Forum: General
Topic: Sharp PC-4521 in PCem?
Replies: 6
Views: 521

Sharp PC-4521 in PCem?

Hello, I am looking to re-create my very first PC for nostalgia, the Sharp PC-4521. I spent many days as an 8-10 yr old typing up basic "Hello World"-type programs in Qbasic and messing around with it, seeing what things did. Just have a question: Is there a supported 'setup' that emulates this mach...