Search found 16 matches

by Chilly Willy
Mon 04 Jun, 2018 6:39 pm
Forum: General
Topic: Tandy Sound Issue
Replies: 16
Views: 943

Re: Tandy Sound Issue

Still have sound issues in v14 and the mda.rom file is missing.
by Chilly Willy
Wed 20 Dec, 2017 11:37 pm
Forum: General
Topic: v13 - Mouse Issues
Replies: 13
Views: 1123

Re: v13 - Mouse Issues

Katakis wrote:...and I am the only OS X user. Which is why nobody is interested in porting PCem over to the Mac.
I use OS X too but I also have access to Windows. So it hasn't bothered me much.
by Chilly Willy
Wed 20 Dec, 2017 3:24 am
Forum: Development
Topic: Status of Assembly?
Replies: 8
Views: 934

Re: Status of Assembly?

Removing ASM code from any app would be a horrible idea. ASM helps a lot with performance. If one wants to compile on multiple operating system, then check for the OS version used at compile time. You can write code for multiple operating systems and only compile the code that is needed by doing a s...
by Chilly Willy
Mon 18 Dec, 2017 7:49 pm
Forum: General
Topic: Tandy Sound Issue
Replies: 16
Views: 943

Re: Tandy Sound Issue

Here's an audio sample of what it sounds like now.
http://www.posemotion.com/audio/KQ2_Intro.mp3
by Chilly Willy
Mon 18 Dec, 2017 6:20 pm
Forum: General
Topic: Tandy Sound Issue
Replies: 16
Views: 943

Re: Tandy Sound Issue

SarahWalker wrote:Maybe play with the sound buffer length, see if changing that has any impact?
I tried that already but thanks. I even tried making it 800 in the PCem config file. Sorry can not remember the file's name but I'm sure you know which one I'm talking about.
by Chilly Willy
Mon 18 Dec, 2017 7:20 am
Forum: General
Topic: Tandy Sound Issue
Replies: 16
Views: 943

Re: Tandy Sound Issue

Just got around to testing the new version. I can actually hear the notes now but it still has issues. Sounds like it is not being buffered enough or something. Scratching/digital sounding artifacts.

EDIT: King's Quest IV (AGI) also does it now. Maybe a timing issue?
by Chilly Willy
Thu 14 Dec, 2017 10:57 pm
Forum: General
Topic: Tandy Sound Issue
Replies: 16
Views: 943

Re: Tandy Sound Issue

SarahWalker wrote: That's the same low pitch problem I was hearing in KQ3 - your version of KQ2 must be using the same code. That's now fixed and will be in the point release I'm doing this weekend.
Thanks! ;)

That version came from the Roberta Williams Anthology.
by Chilly Willy
Thu 14 Dec, 2017 9:57 pm
Forum: General
Topic: Tandy Sound Issue
Replies: 16
Views: 943

Re: Tandy Sound Issue

Here's an audio clip of King's Quest II intro...
http://www.posemotion.com/audio/KQII_Audio.mp3
by Chilly Willy
Thu 14 Dec, 2017 12:39 pm
Forum: General
Topic: Tandy Sound Issue
Replies: 16
Views: 943

Re: Tandy Sound Issue

That's interesting. I'm having the same problems with II and III. I just played King's Quest IV last night just fine. Even a Sierra Christmas 1988 demo played fine. Hmm...
by Chilly Willy
Wed 13 Dec, 2017 10:49 pm
Forum: General
Topic: Tandy Sound Issue
Replies: 16
Views: 943

Re: Tandy Sound Issue

I will post the config files once I get back to that pc. On my Mac now. The Tandy emulation sound is fine in DOSBox and ScummVM but here's my pc specs... XP SP3 AMD 4000+ 64 (2.4 GHz) 1 GB Memory (DDR 333 MHz) Nvidia 720 GT M-Audio Revolution 5.1 (Default audio card) Yamaha YMF724 (Audio line out an...
by Chilly Willy
Wed 13 Dec, 2017 9:44 pm
Forum: General
Topic: Tandy Sound Issue
Replies: 16
Views: 943

Tandy Sound Issue

Using a Tandy 1000 HX rom. The sound is fine for games that use a "pc speaker" sound such as California Games. When you play a Sierra game like King's Quest, the sound is really slowed down to a point it sounds like a record being played backwards. Tried playing with the audio buffer but that didn't...
by Chilly Willy
Wed 13 Dec, 2017 2:50 am
Forum: General
Topic: Sound Blaster Pro v1 bug
Replies: 3
Views: 365

Re: Sound Blaster Pro v1 bug

I didn't think it allowed the audio to be passed like that. Would be cool. Also, you wouldn't need an ISA sound card for this. An OPL Yamaha PCI sound card would work on XP. That's if it allowed it though. Which is not the case as stated.
by Chilly Willy
Wed 13 Dec, 2017 12:48 am
Forum: General
Topic: Sound Blaster Pro v1 bug
Replies: 3
Views: 365

Re: Sound Blaster Pro v1 bug

Sorry but I have a question about what you are doing. If you install a driver for a vintage sound card in PCem, the sound will actually play on the vintage sound card and not use emulation? Sorry to hijack your post but was interested if this works.
by Chilly Willy
Tue 12 Dec, 2017 5:34 pm
Forum: General
Topic: V13 - Tandy 1000 HX
Replies: 4
Views: 355

Re: V13 - Tandy 1000 HX

Thanks! After playing around with it, that was my conclusion. Just needed to verify.

The only thing I could see needed is, after a hard reset, the A/B: drive should auto-eject. The Tandy boot screen didn't load all the way. I didn't realize that at first. Other than that, this is very nice!
by Chilly Willy
Tue 12 Dec, 2017 2:24 pm
Forum: General
Topic: V13 - Tandy 1000 HX
Replies: 4
Views: 355

Re: V13 - Tandy 1000 HX

Thank you!

One more question. Do you keep the sound set to "None" for the Tandy 3 Voice?
by Chilly Willy
Tue 12 Dec, 2017 12:50 pm
Forum: General
Topic: V13 - Tandy 1000 HX
Replies: 4
Views: 355

V13 - Tandy 1000 HX

Hello! I have a Tandy 1000 HX but came across this and figured I would try it out. Version 12 works fine but in v13, I'm unable to see any text after boot. I can see the cursor position and even type in and load a game. Can not see what I'm typing but can see the cursor position move. When the game ...