Search found 3 matches

by micronix
Thu 25 Jan, 2018 9:12 pm
Forum: Merged patches
Topic: [Patch] Floppy emulation on old Linux kernels
Replies: 5
Views: 832

Re: [Patch] Floppy emulation on old Linux kernels

I don't know if this helps, but I compared the floppy driver source code (drivers/block/floppy.c) of the affected kernel version 2.0.27 and the unaffected version 2.0.40. In 2.0.40 there is a variable in the floppy interrupt handler which limits the maximum number of loops. I attached the relevant c...
by micronix
Thu 25 Jan, 2018 1:07 am
Forum: Development
Topic: Floppy emulation on old versions of Linux
Replies: 5
Views: 946

Re: Floppy emulation on old versions of Linux

This problem seems to be caused by the floppy drive detection code in older linux kernels. They are caught in an endless loop and send the sense interrupt command to the FDC over and over again. I compiled two older kernels. The 2.0.27 kernel freezes and the 2.0.40 kernel boots up normally. Slackwar...
by micronix
Wed 24 Jan, 2018 8:29 am
Forum: Merged patches
Topic: [Patch] Floppy emulation on old Linux kernels
Replies: 5
Views: 832

[Patch] Floppy emulation on old Linux kernels

Hi guys, I noticed some time ago, that some old versions of the Linux kernel freeze in floppy drive detection. I know that these kernels run fine on older versions of PCem, so I tried to locate the exact change in the PCem code which causes this bug. These old Linux kernels started to freeze after t...