Search found 78 matches

by CryptidWorks
Wed 08 Apr, 2020 2:07 am
Forum: General
Topic: Macromedia/Quicktime Games Cause Slowdown
Replies: 13
Views: 4147

Re: Macromedia/Quicktime Games Cause Slowdown

I can confirm it happens on other games too. I tried 5 a Day Adventures (1995), and it's slow n skips on higher speeds. Drop it down, and it's alright. The game heavily utilizes QuickTime 2.1 I believe. At the time, I tried both PowerISO and the built-in drive. I just didn't think anything of it, u...
by CryptidWorks
Mon 09 Mar, 2020 1:02 am
Forum: General
Topic: Macromedia/Quicktime Games Cause Slowdown
Replies: 13
Views: 4147

Re: Macromedia/Quicktime Games Cause Slowdown

https://i.imgur.com/5xtK1GH.png Tested something with a problem app I was able to rip from the disc to remove the CD drive from the equation and nope. It seems like Macromedia based apps are causing some kind of runaway leak in CPU usage that doesn't happen any other time the emulated CPU is under ...
by CryptidWorks
Sun 08 Mar, 2020 11:05 pm
Forum: General
Topic: Macromedia/Quicktime Games Cause Slowdown
Replies: 13
Views: 4147

Re: Macromedia/Quicktime Games Cause Slowdown

SarahWalker wrote:
Sun 08 Mar, 2020 11:06 am
You could try using a virtual drive like Daemon Tools to see if that performs any better.
Tried both both Daemon Tools and the Windows 10 built-in function AND playing with the drive speed. Nothing worked. There's seem to just inherently a weird bottleneck caused by the disc drive emulation.
by CryptidWorks
Sun 08 Mar, 2020 9:36 am
Forum: General
Topic: Macromedia/Quicktime Games Cause Slowdown
Replies: 13
Views: 4147

Re: Macromedia/Quicktime Games Cause Slowdown

What are you using for CD support - the built-in ISO loader? A virtual CD drive? God forbid, a real CD drive? Basically your top two screenshots confirm PCem is massively slowing down, and if it's not actually using CPU time then it's probably blocked on IO, and CD emulation is a not infrequent cau...
by CryptidWorks
Sun 08 Mar, 2020 3:15 am
Forum: General
Topic: Macromedia/Quicktime Games Cause Slowdown
Replies: 13
Views: 4147

Re: Macromedia/Quicktime Games Cause Slowdown

May have gone overboard but I hope I've managed to provide some interesting data to work with
by CryptidWorks
Sun 08 Mar, 2020 3:12 am
Forum: General
Topic: Macromedia/Quicktime Games Cause Slowdown
Replies: 13
Views: 4147

Re: Macromedia/Quicktime Games Cause Slowdown

Upon further experiments chips as slow as the Pentium 90 even show this behavior for brief moments when transitioning between areas. This is bit lower quality because I had to save a Shadowplay video and screenshot from that to catch it happening

Image
by CryptidWorks
Sun 08 Mar, 2020 12:40 am
Forum: General
Topic: Colored lines along the right/bottom edge of screen
Replies: 3
Views: 1581

Re: Colored lines along the right/bottom edge of screen

I've noticed that to but it seems to go away in the majority of full-screen games so I assumed it was just a quirk with the S3 Emulation and never brought it up.
by CryptidWorks
Sat 07 Mar, 2020 10:57 pm
Forum: General
Topic: Macromedia/Quicktime Games Cause Slowdown
Replies: 13
Views: 4147

Re: Macromedia/Quicktime Games Cause Slowdown

For comparasion here's a 3D Accelerated game from 1999 hammering the system with zero slow-down

Image

Blood 2 at high detail, which is basically torture for a Pentium 233 and using even more host CPU than The Mummy but with 0 slowdown

Image
by CryptidWorks
Sat 07 Mar, 2020 10:16 pm
Forum: General
Topic: Macromedia/Quicktime Games Cause Slowdown
Replies: 13
Views: 4147

Re: Macromedia/Quicktime Games Cause Slowdown

Can you take a screenshot of the status window when the slowdown is happening? It has useful performance-related information. You mean the machine window? Sure. https://i.imgur.com/IDGNydb.png https://i.imgur.com/yhpBuJT.png As you can also see even on the point showing the highest usage I'm not ev...
by CryptidWorks
Sat 07 Mar, 2020 11:24 am
Forum: General
Topic: Macromedia/Quicktime Games Cause Slowdown
Replies: 13
Views: 4147

Re: Macromedia/Quicktime Games Cause Slowdown

I accidentally make the video private instead of unlisted, that has now been fixed and the video is viewable
by CryptidWorks
Sat 07 Mar, 2020 8:09 am
Forum: General
Topic: Macromedia/Quicktime Games Cause Slowdown
Replies: 13
Views: 4147

Macromedia/Quicktime Games Cause Slowdown

Okay, I know I'm a serial complainer I do apologize for that but I think I actually found something interesting. Games that are built with heavy use of Quicktime and/or Macromedia seem to cause horrible emulation slowdown unrelated to the actual speed of the host CPU when faster chips are emulated, ...
by CryptidWorks
Sat 07 Mar, 2020 6:26 am
Forum: Development
Topic: v15 compatibility & bug list (WIP)
Replies: 72
Views: 54324

Re: v15 compatibility & bug list (WIP)

Upon opening the PlaySchool Sampler on a Playschool game (Mr Potato Head Saves Veggie Valley) I encountered more slow-down with no apparent cause. Seems like it might be related to playing Quicktime content in Windows 98SE.

Much like the Jazz the Jackrabbit example the game itself is just fine.
by CryptidWorks
Fri 06 Mar, 2020 11:21 am
Forum: General
Topic: PCEM Doesn't Change Sound Source Without Rebooting
Replies: 2
Views: 1455

Re: PCEM Doesn't Change Sound Source Without Rebooting

Yes, that happens. I had a quick look back then and I believe that it is not easily fixable with the current audio API. (Have a similar problem: headphones and monitor speakers). Basically, programs that can switch audio like that do so because they connect to the default soundcard. I was kind of a...
by CryptidWorks
Fri 06 Mar, 2020 11:18 am
Forum: Merged patches
Topic: [Patch] Keyboard patch
Replies: 4
Views: 2075

Re: [Patch] Keyboard patch

Which machines does this fix? The issue was caused by the [url=http://pcem-emulator.co.uk/phpBB3/viewtopic.php?f=5&t=830&p=13388#p13388]Goldstar GDC-212M BIOS that add patch was uploaded today[/url]. Someone really needs to fix that broken URL embed code. I don't know how long it's been broken but ...
by CryptidWorks
Fri 06 Mar, 2020 1:45 am
Forum: General
Topic: AWE32 Won't Show Up In 9x.
Replies: 16
Views: 4767

Re: AWE32 Won't Show Up In 9x.

The PCI 128's a budget card and is pretty much a proto-SBLive, since Creative bought up Ensoniq for their PCI sound tech to create the Live (and all the later cards like Audigy, X-Fi etc), AudioPCI's a stopgap solution and a very popular common OEM card of choice. Early SBLive drivers had the same ...
by CryptidWorks
Thu 05 Mar, 2020 11:02 pm
Forum: General
Topic: AWE32 Won't Show Up In 9x.
Replies: 16
Views: 4767

Re: AWE32 Won't Show Up In 9x.

Each card is useful for the software it is intended to be used with. Oldest soundblaster or adlib cards are mostly for DOS based games that specifically use those. Newer SB16 is the all-compatible soundcard for newer DOS and Windows. AWE32 is specifically useful if the software uses it to play musi...
by CryptidWorks
Thu 05 Mar, 2020 9:32 pm
Forum: General
Topic: AWE32 Won't Show Up In 9x.
Replies: 16
Views: 4767

Re: AWE32 Won't Show Up In 9x.

It's real behavior for non-PnP ("Plug 'n play") SB cards. If you didn't have the card in at Windows setup time, you'll have to add them manually through the Add New Hardware control panel applet (Automatically or not), and PCem doesn't emulate any later (>1994) variant of ISA Sound Blasters Now I'm...
by CryptidWorks
Thu 05 Mar, 2020 9:24 am
Forum: Development
Topic: v15 compatibility & bug list (WIP)
Replies: 72
Views: 54324

Re: v15 compatibility & bug list (WIP)

Jazz the Jackrabbit 2 inexplictly has emulation slowdown during the into movies that's totally unrelated to host hardware usage. My CPU might as well be idling but emulation speed is still 90-95% while they're playing. Game itself is fine. I'm using the Shareware demo on Windows 98SE just in case th...
by CryptidWorks
Thu 05 Mar, 2020 3:07 am
Forum: General
Topic: AWE32 Won't Show Up In 9x.
Replies: 16
Views: 4767

Re: AWE32 Won't Show Up In 9x.

Update: issue isolated. Installing drivers for PC-128 keeps the system from recolonizing any other soundcards. Don't know if this real behavior for Windows 98 or a PCEM issue.
by CryptidWorks
Thu 05 Mar, 2020 2:39 am
Forum: General
Topic: Garbled/Double-Playing Audio
Replies: 5
Views: 1979

Re: Garbled/Double-Playing Audio

Okay, Update now that I've gotten other sound cards working:

Switching my system to the AWE32 with the default drivers completely fixes this issue but I still don't know if it's real behavior or a problem with PCEM's emulation of the 5th generation Soundblasters.
by CryptidWorks
Thu 05 Mar, 2020 2:10 am
Forum: General
Topic: AWE32 Won't Show Up In 9x.
Replies: 16
Views: 4767

Re: AWE32 Won't Show Up In 9x.

Update:

Fixed with a new copy of PCEM V15 and fresh install of Windows 98SE. Something is apparently not right with my old copy that was updated from V14 with a directory merge.
by CryptidWorks
Thu 05 Mar, 2020 12:34 am
Forum: General
Topic: AWE32 Won't Show Up In 9x.
Replies: 16
Views: 4767

Re: AWE32 Won't Show Up In 9x.

SB16 not showing up in Windows 95 either

Image
by CryptidWorks
Thu 05 Mar, 2020 12:11 am
Forum: General
Topic: AWE32 Won't Show Up In 9x.
Replies: 16
Views: 4767

Re: AWE32 Won't Show Up In 9x.

Upon checking I do have Awe32.raw in my rom folder
by CryptidWorks
Wed 04 Mar, 2020 11:33 pm
Forum: General
Topic: AWE32 Won't Show Up In 9x.
Replies: 16
Views: 4767

Re: AWE32 Won't Show Up In 9x.

You see, on my end I get absolutely nothing showing up under video, sound, and game controllers for the AWE32 and no detection at start-up and I've got the newest bios I could find that were updated 8 months ago https://i.imgur.com/ZfMWT35.png Soundblaster 16 is not showing up either. Only thing I g...
by CryptidWorks
Wed 04 Mar, 2020 10:20 am
Forum: General
Topic: AWE32 Won't Show Up In 9x.
Replies: 16
Views: 4767

AWE32 Won't Show Up In 9x.

I was trying to test out the Soundblaster AWE32 to see if it fairs any better than the PCI-128 in anything I'm having issues with and neither windows 95 or 98 seem to register the device being installed when I select it. There's no PCI audio device in the Hardware manager and the SB utilities don't ...
by CryptidWorks
Wed 04 Mar, 2020 8:16 am
Forum: General
Topic: Some weird things in PCem...
Replies: 14
Views: 3537

Re: Some weird things in PCem...

And one more thing: you noticed the resolution in the Machine window? Is showing the original resolution or the same I explained earlier? I'm not dead sure because I don't know if I have any games installed that use 640x480x4bit ATM. I do know the reslution reads correctly as 1024x768 at the deskto...
by CryptidWorks
Wed 04 Mar, 2020 7:43 am
Forum: General
Topic: Some weird things in PCem...
Replies: 14
Views: 3537

Re: Some weird things in PCem...

DSN wrote:
Wed 04 Mar, 2020 7:34 am
Yes, is at 100% speed when playing most DOS games, but in DOS text mode is 95-96%.
I know I've had speech glitches with some isolated games in isolated instances with a PCI-128 but not music glitching
by CryptidWorks
Wed 04 Mar, 2020 7:26 am
Forum: General
Topic: [Solved] The PFA48 LiveStream Show episode 13
Replies: 3
Views: 1460

Re: [Crash] The PFA48 LiveStream Show episode 13

MiraiMiracle wrote:
Wed 04 Mar, 2020 6:55 am
Version 15 fixes a crash bug, but can you use version 14 to reproduce this?
Whether an older version has a bug is irrelevant if it's been fixed in a new release.

Especially here because V15 made so many major improvements there's no reason to use V14 anymore.
by CryptidWorks
Wed 04 Mar, 2020 7:24 am
Forum: General
Topic: Some weird things in PCem...
Replies: 14
Views: 3537

Re: Some weird things in PCem...

As I mentioned earlier, the CD music in Earthworm Jim 2 is stuttering even with 4x CDROM speed I tested on my DOS system, 2x speed will probably have stuttering music also, I will test later. Anyway I don't know if this occurs because of the CDROM speed, probably a bug in PCem. I would like to know...
by CryptidWorks
Wed 04 Mar, 2020 6:51 am
Forum: General
Topic: [Solved] The PFA48 LiveStream Show episode 13
Replies: 3
Views: 1460

Re: [Crash] The PFA48 LiveStream Show episode 13

I just checked and it seems whatever does it has been fixed in V15