Search found 1542 matches

by SarahWalker
Sun 15 Apr, 2018 7:40 pm
Forum: Development
Topic: [BUG] Solaris x86 boot failure with AHA-1542 SCSI controller
Replies: 2
Views: 339

Re: [BUG] Solaris x86 boot failure with AHA-1542 SCSI controller

2.4 with AHA-1542C fixed in rev 1162. I think that rev may have also fixed the IDE issue.
by SarahWalker
Fri 13 Apr, 2018 8:17 pm
Forum: Development
Topic: [Request] Visual Player 2.0 SB16 support
Replies: 2
Views: 583

Re: [Request] Visual Player 2.0 SB16 support

Fixed in rev 1158.
by SarahWalker
Thu 12 Apr, 2018 8:32 pm
Forum: General
Topic: About the Trio64 win3.1 drivers
Replies: 6
Views: 450

Re: About the Trio64 win3.1 drivers

Fixed in rev 1156.
by SarahWalker
Thu 12 Apr, 2018 4:19 pm
Forum: General
Topic: About the Trio64 win3.1 drivers
Replies: 6
Views: 450

Re: About the Trio64 win3.1 drivers

Are you drunk? You sound more rambling than normal.
by SarahWalker
Wed 11 Apr, 2018 4:26 pm
Forum: General
Topic: does anyone have a guide to get CMS Creative Game Soundblaster to work.
Replies: 2
Views: 457

Re: does anyone have a guide to get CMS Creative Game Soundblaster to work.

Which drivers were you originally trying to get working? The drivers I've been using (CMS Game Blaster 720KB Driver Disk off vogonsdrivers) detect the card okay and seem to work fine.
by SarahWalker
Wed 11 Apr, 2018 4:01 pm
Forum: General
Topic: Joe Montana Football and IBM PS/1 bug
Replies: 1
Views: 199

Re: Joe Montana Football and IBM PS/1 bug

Fixed in rev 1153.
by SarahWalker
Wed 11 Apr, 2018 3:35 pm
Forum: General
Topic: Pre-v14 WIP compat list
Replies: 8
Views: 858

Re: Pre-v14 WIP compat list

leilei wrote:
Fri 06 Apr, 2018 4:41 am
- Magic Carpet 2 has 320x200 VGA issues under Windows 95 on S3 Trio64. Changing to 640x480 by hitting R or windowing and back alleviates this.
Can't reproduce. What exact configuration are you using? What drivers? What do the 'VGA issues' look like?
by SarahWalker
Wed 11 Apr, 2018 3:24 pm
Forum: Development
Topic: 8088/8086 machine bug with PC-DOS 2.x/3.0
Replies: 1
Views: 737

Re: 8088/8086 machine bug with PC-DOS 2.x/3.0

Not a PCem bug. Pictionary tries to initialise the mouse via INT 33h. Your mouse driver would normally hook this, but you don't have one loaded. DOS 3+ will install a dummy handler, as will AT BIOSes. If you use DOS 1.x/2.x with an XT machine and no mouse driver then nothing will initialise it and P...
by SarahWalker
Wed 11 Apr, 2018 2:25 pm
Forum: Development
Topic: [PATCH] Memory patch
Replies: 10
Views: 2059

Re: [PATCH] Memory patch

That looks more reasonable. Committed at rev 1152.
by SarahWalker
Tue 10 Apr, 2018 4:21 pm
Forum: General
Topic: Plantronics ColorPlus (possibly others) affected by CGA colors setting
Replies: 1
Views: 352

Re: Plantronics ColorPlus (possibly others) affected by CGA colors setting

Fixed in rev 1150, mainly by adding the monitor type configuration...
by SarahWalker
Tue 10 Apr, 2018 4:12 pm
Forum: General
Topic: Loading .iso causes PCem menus to not respond
Replies: 1
Views: 524

Re: Loading .iso causes PCem menus to not respond

A bit late responding to this, but this issue is the fault of bad UI design on my part. Once you've configured a CD-ROM drive in the configuration dialogue, it won't show up in the emulated machine until you've selected something other than 'disabled' in the CD-ROM menu in the main PCem window. This...
by SarahWalker
Tue 10 Apr, 2018 3:58 pm
Forum: General
Topic: Compilation fails.
Replies: 4
Views: 304

Re: Compilation fails.

What version of SDL do you have installed? Those errors imply that it's something prior to 2.0.4. PCem needs something more recent than that.
by SarahWalker
Tue 10 Apr, 2018 3:57 pm
Forum: General
Topic: [Bug] pcem freezes when running win95's ms-dos prompt with stealth32 set true color
Replies: 3
Views: 396

Re: [Bug] pcem freezes when running win95's ms-dos prompt with stealth32 set true color

Can't reproduce this. What version of Windows 95 are you using? What driver? Could you post the emulator configuration you're using?

Is the card showing up in Windows Device Manager as a PCI device?
by SarahWalker
Tue 10 Apr, 2018 3:29 pm
Forum: General
Topic: Floppies don't boot on PS/1 2011
Replies: 6
Views: 436

Re: Floppies don't boot on PS/1 2011

That's unhelpfully vague.
by SarahWalker
Tue 10 Apr, 2018 3:28 pm
Forum: General
Topic: Documentation?
Replies: 2
Views: 330

Re: Documentation?

readme.txt?
by SarahWalker
Tue 10 Apr, 2018 3:27 pm
Forum: Development
Topic: [PATCH] Memory patch
Replies: 10
Views: 2059

Re: [PATCH] Memory patch

What conditions are causing this crash? I'd be extremely dubious about any situation where _mem_exec was set but _mem_mapping_r was not - that would imply that memory mapping has not been set up correctly.
by SarahWalker
Tue 10 Apr, 2018 3:21 pm
Forum: General
Topic: Color issue with the trio64 on OS/2/Warp
Replies: 1
Views: 215

Re: Color issue with the trio64 on OS/2/Warp

Fixed in rev 1148/1149.
by SarahWalker
Tue 10 Apr, 2018 8:36 am
Forum: General
Topic: Floppies don't boot on PS/1 2011
Replies: 6
Views: 436

Re: Floppies don't boot on PS/1 2011

Can you provide the configuration you're using please? As I said above, this works fine for me.
by SarahWalker
Mon 09 Apr, 2018 7:44 pm
Forum: General
Topic: Floppies don't boot on PS/1 2011
Replies: 6
Views: 436

Re: Floppies don't boot on PS/1 2011

Seems to work okay here. Have you actually configured the system to boot from floppy in CUSTOMIZ.EXE? The PS/1 2011 will default to booting straight from ROM.
by SarahWalker
Sun 08 Apr, 2018 4:18 pm
Forum: Development
Topic: v14 compatibility & bug list (WIP)
Replies: 21
Views: 3053

Re: v14 compatibility & bug list (WIP)

Fixed Cirrus Logic 8-bit modes in rev 1145, and NFL Blitz 2000 in rev 1146.
by SarahWalker
Sat 07 Apr, 2018 10:09 am
Forum: General
Topic: Pre-v14 WIP compat list
Replies: 8
Views: 858

Re: Pre-v14 WIP compat list

Made an 'official' thread at viewtopic.php?f=3&t=2978 - I'll update the list there with any posts made to that thread.

Quick question - for Screamer 2, was that software or 3DFX? I had thought 3DFX mode in Screamer 2 + Rally was broken (and had never worked).
by SarahWalker
Sat 07 Apr, 2018 10:08 am
Forum: Development
Topic: v14 compatibility & bug list (WIP)
Replies: 21
Views: 3053

v14 compatibility & bug list (WIP)

I'll update this post with any results posted to this thread. (Last update - 20/04/2018 12:02 GMT+1) Working : CP/M-86 1.0 IBM PC, 8088/4.77, CGA PC-DOS 1.0 IBM PC, 8088/4.77, CGA MS-DOS 2.11 AMI XT clone, 8088/10, CGA, Xebec Fixed Disk Adapter MS-DOS 3.30 Acer 386SX25/N, i386SX/25, built-in Oak OTI...
by SarahWalker
Fri 06 Apr, 2018 7:15 pm
Forum: General
Topic: Pre-v14 WIP compat list
Replies: 8
Views: 858

Re: Pre-v14 WIP compat list

I was meaning to start a thread like this. Mind if I merge this post with my own list?

Could you also post what configurations you were using on these games? I've been using model/CPU/graphics card/sound card/OS.
by SarahWalker
Mon 02 Apr, 2018 8:08 pm
Forum: General
Topic: Bug Win95 with rtl8029AS
Replies: 4
Views: 479

Re: Bug Win95 with rtl8029AS

Fixed in rev 1136.
by SarahWalker
Mon 02 Apr, 2018 6:15 pm
Forum: General
Topic: Bug Win95 with rtl8029AS
Replies: 4
Views: 479

Re: Bug Win95 with rtl8029AS

Could you post a config that reproduces this please?
by SarahWalker
Wed 28 Mar, 2018 8:10 pm
Forum: General
Topic: AudioPCI impressions
Replies: 19
Views: 2369

Re: AudioPCI impressions

Rev 1135 should eliminate the distortion.
by SarahWalker
Wed 28 Mar, 2018 4:21 pm
Forum: General
Topic: Configuration errors on model 70 type 4
Replies: 9
Views: 956

Re: Configuration errors on model 70 type 4

Absolutely - it's mainly due to lack of any real interest + other more interesting stuff to do on my part which has prevented this from happening.
by SarahWalker
Sat 24 Mar, 2018 7:53 pm
Forum: General
Topic: Configuration errors on model 70 type 4
Replies: 9
Views: 956

Re: Configuration errors on model 70 type 4

Video error is fixed in rev 1131.
by SarahWalker
Sat 24 Mar, 2018 6:18 pm
Forum: General
Topic: Custom resolution isn't set on the next time PCem is started
Replies: 2
Views: 386

Re: Custom resolution isn't set on the next time PCem is started

Fixed problem #1 in rev 1130. I think this fixes the CGA/EGA issue as well?