Search found 1523 matches

by SarahWalker
Mon 09 Apr, 2018 7:44 pm
Forum: General
Topic: Floppies don't boot on PS/1 2011
Replies: 6
Views: 296

Re: Floppies don't boot on PS/1 2011

Seems to work okay here. Have you actually configured the system to boot from floppy in CUSTOMIZ.EXE? The PS/1 2011 will default to booting straight from ROM.
by SarahWalker
Sun 08 Apr, 2018 4:18 pm
Forum: Development
Topic: v14 compatibility & bug list (WIP)
Replies: 18
Views: 1548

Re: v14 compatibility & bug list (WIP)

Fixed Cirrus Logic 8-bit modes in rev 1145, and NFL Blitz 2000 in rev 1146.
by SarahWalker
Sat 07 Apr, 2018 10:09 am
Forum: General
Topic: Pre-v14 WIP compat list
Replies: 8
Views: 639

Re: Pre-v14 WIP compat list

Made an 'official' thread at viewtopic.php?f=3&t=2978 - I'll update the list there with any posts made to that thread.

Quick question - for Screamer 2, was that software or 3DFX? I had thought 3DFX mode in Screamer 2 + Rally was broken (and had never worked).
by SarahWalker
Sat 07 Apr, 2018 10:08 am
Forum: Development
Topic: v14 compatibility & bug list (WIP)
Replies: 18
Views: 1548

v14 compatibility & bug list (WIP)

I'll update this post with any results posted to this thread. (Last update - 20/04/2018 12:02 GMT+1) Working : CP/M-86 1.0 IBM PC, 8088/4.77, CGA PC-DOS 1.0 IBM PC, 8088/4.77, CGA MS-DOS 2.11 AMI XT clone, 8088/10, CGA, Xebec Fixed Disk Adapter MS-DOS 3.30 Acer 386SX25/N, i386SX/25, built-in Oak OTI...
by SarahWalker
Fri 06 Apr, 2018 7:15 pm
Forum: General
Topic: Pre-v14 WIP compat list
Replies: 8
Views: 639

Re: Pre-v14 WIP compat list

I was meaning to start a thread like this. Mind if I merge this post with my own list?

Could you also post what configurations you were using on these games? I've been using model/CPU/graphics card/sound card/OS.
by SarahWalker
Mon 02 Apr, 2018 8:08 pm
Forum: General
Topic: Bug Win95 with rtl8029AS
Replies: 4
Views: 356

Re: Bug Win95 with rtl8029AS

Fixed in rev 1136.
by SarahWalker
Mon 02 Apr, 2018 6:15 pm
Forum: General
Topic: Bug Win95 with rtl8029AS
Replies: 4
Views: 356

Re: Bug Win95 with rtl8029AS

Could you post a config that reproduces this please?
by SarahWalker
Wed 28 Mar, 2018 8:10 pm
Forum: General
Topic: AudioPCI impressions
Replies: 15
Views: 1655

Re: AudioPCI impressions

Rev 1135 should eliminate the distortion.
by SarahWalker
Wed 28 Mar, 2018 4:21 pm
Forum: General
Topic: Configuration errors on model 70 type 4
Replies: 9
Views: 728

Re: Configuration errors on model 70 type 4

Absolutely - it's mainly due to lack of any real interest + other more interesting stuff to do on my part which has prevented this from happening.
by SarahWalker
Sat 24 Mar, 2018 7:53 pm
Forum: General
Topic: Configuration errors on model 70 type 4
Replies: 9
Views: 728

Re: Configuration errors on model 70 type 4

Video error is fixed in rev 1131.
by SarahWalker
Sat 24 Mar, 2018 6:18 pm
Forum: General
Topic: Custom resolution isn't set on the next time PCem is started
Replies: 2
Views: 296

Re: Custom resolution isn't set on the next time PCem is started

Fixed problem #1 in rev 1130. I think this fixes the CGA/EGA issue as well?
by SarahWalker
Fri 23 Mar, 2018 8:46 pm
Forum: General
Topic: Configuration errors on model 70 type 4
Replies: 9
Views: 728

Re: Configuration errors on model 70 type 4

The other failure (the 2401 video error) is caused by changes to the VGA status register, which were required by the Oak OTI-037C. I _think_ the problem here is that Oak's VGA core is not 100% compatible, and has a different understanding of 'display enable' to everyone else, and hence the required ...
by SarahWalker
Fri 23 Mar, 2018 8:43 pm
Forum: General
Topic: Configuration errors on model 70 type 4
Replies: 9
Views: 728

Re: Configuration errors on model 70 type 4

I never mentioned any 'variants', and frankly have zero interest in what they may or may not do. Bit-accurate x87 emulation requires 80-bit floating point operations, as that's what x87 uses internally. If the host CPU's FPU was used to do this, this will destroy any chance of porting PCem to any ar...
by SarahWalker
Thu 22 Mar, 2018 9:56 pm
Forum: General
Topic: Configuration errors on model 70 type 4
Replies: 9
Views: 728

Re: Configuration errors on model 70 type 4

The IBM coprocessor tests require bit accurate FPU emulation, which PCem doesn't have and probably never will have.
by SarahWalker
Tue 20 Mar, 2018 5:55 pm
Forum: Merged patches
Topic: T1200 fix: Memory test failure
Replies: 1
Views: 488

Re: T1200 fix: Memory test failure

Committed at rev 1116.
by SarahWalker
Tue 20 Mar, 2018 5:50 pm
Forum: Development
Topic: [REQUEST] CD-ROM speed
Replies: 10
Views: 1147

Re: [REQUEST] CD-ROM speed

Added in rev 1115.
by SarahWalker
Tue 20 Mar, 2018 5:18 pm
Forum: General
Topic: [BUG] VGAPaint 386 doesn't like VESA modes and crashes!
Replies: 8
Views: 659

Re: [BUG] VGAPaint 386 doesn't like VESA modes and crashes!

All the Cirrus Logic cards, both the Mach64s, all the S3 cards, the ET4000/W32p (Diamond Stealth 32) and the Trident TGUIs. UNIVBE should be able to enable LFBs on all of them.
by SarahWalker
Tue 20 Mar, 2018 9:51 am
Forum: General
Topic: [BUG] VGAPaint 386 doesn't like VESA modes and crashes!
Replies: 8
Views: 659

Re: [BUG] VGAPaint 386 doesn't like VESA modes and crashes!

You might also have to use a newer graphics card that supports linear frame buffers.
by SarahWalker
Mon 19 Mar, 2018 8:39 pm
Forum: General
Topic: [BUG] VGAPaint 386 doesn't like VESA modes and crashes!
Replies: 8
Views: 659

Re: [BUG] VGAPaint 386 doesn't like VESA modes and crashes!

Happens on real hardware - VGAPaint looks to have buggy VESA 1.x code. It works with UNIVBE loaded, though you will have to delete the INI file so you can reconfigure the video mode.
by SarahWalker
Mon 19 Mar, 2018 5:29 pm
Forum: Development
Topic: Large (> 8GB) hard drive support
Replies: 15
Views: 1368

Re: Large (> 8GB) hard drive support

Using a large drive should cause no performance impact at all.
by SarahWalker
Sun 18 Mar, 2018 5:29 pm
Forum: General
Topic: [REQUEST] Load floppies from the command line.
Replies: 2
Views: 371

Re: [REQUEST] Load floppies from the command line.

Added in rev 1113. The new command line options are '--load_drive_a <somefile.img>' and '--load_drive_b <somefile.img>'.

These are probably only meaningful when --config is used.
by SarahWalker
Sat 17 Mar, 2018 11:41 am
Forum: Development
Topic: [REQUEST] CD-ROM speed
Replies: 10
Views: 1147

Re: [REQUEST] CD-ROM speed

I've committed a rough implementation of this to rev 1110. Seek times are a very rough model, transfer time is impacted by the existing ATAPI & SCSI emulation, but performance should be roughly correct, particularly for the lower speed drives.
by SarahWalker
Fri 16 Mar, 2018 6:22 pm
Forum: Development
Topic: ide_atapi.c missing a brace?
Replies: 3
Views: 308

Re: ide_atapi.c missing a brace?

Fixed in rev 1109.
by SarahWalker
Mon 12 Mar, 2018 8:35 pm
Forum: Development
Topic: Hercules monitor
Replies: 4
Views: 500

Re: Hercules monitor

You can change CPU speed (but not video buses - not sure what you're referring to here...) because there's specific code to handle that. Not to handle generic device configuration.
by SarahWalker
Mon 12 Mar, 2018 8:33 pm
Forum: General
Topic: [BUG] KMX-C-02 keyboard freeze
Replies: 3
Views: 328

Re: [BUG] KMX-C-02 keyboard freeze

Fixed in rev 1103.
by SarahWalker
Mon 12 Mar, 2018 5:39 pm
Forum: Development
Topic: Hercules monitor
Replies: 4
Views: 500

Re: Hercules monitor

PCem currently has no way to communicate configuration changes to currently running machines, so yes.
by SarahWalker
Sun 11 Mar, 2018 3:51 pm
Forum: Merged patches
Topic: [Patch] Fix missing tooltip
Replies: 2
Views: 413

Re: [Patch] Fix missing tooltip

Committed at rev 1100.
by SarahWalker
Sun 11 Mar, 2018 3:46 pm
Forum: Merged patches
Topic: [Patch] ATI Korean VGA
Replies: 5
Views: 995

Re: [Patch] ATI Korean VGA

Committed at rev 1099.