Search found 793 matches

by Battler
Sun 04 Jun, 2017 2:42 pm
Forum: Development
Topic: [Bug] IDE HDD stuttering emulation
Replies: 29
Views: 6956

Re: [Bug] IDE HDD stuttering emulation

Ah, I didn't know that. Then the performance idle emulation needs to be improved, unfortunately that's going to be difficult.
by Battler
Sun 04 Jun, 2017 2:25 pm
Forum: Development
Topic: [Bug] IDE HDD stuttering emulation
Replies: 29
Views: 6956

Re: [Bug] IDE HDD stuttering emulation

- SarahWalker: No, I'm talking about the slowdown that happens when disk I/O access happens. For example, on Pentium 75, I have Duke Nukem 3D (for DOS) running at solid 100% but when on the loading screen, it goes down to 70% for a while as it's reading from the hard disk. Now if James-F is not talk...
by Battler
Sun 04 Jun, 2017 1:53 pm
Forum: General
Topic: [Partially-Solved] PCem v12 and Sound Lag
Replies: 124
Views: 23940

Re: [Solved] PCem v12 and Sound Lag

Yes, because we had these discussions before, worked on getting the PCem-X changes merged, worked together on the FDC changes, then you decided it wasn't working and stopped cooperating. And didn't tell me for several weeks until I pushed the issue on IRC. Why should I try to meet you halfway if yo...
by Battler
Sun 04 Jun, 2017 1:32 pm
Forum: Development
Topic: [Bug] IDE HDD stuttering emulation
Replies: 29
Views: 6956

Re: [Bug] IDE HDD stuttering emulation

The IDE emulation needs to be moved into its own thread. For me (on a Pentium Dual-Core), hard disk access can make the difference between 100% and 70%. On a better host CPU it's going to be less severe, but still there.
by Battler
Sun 04 Jun, 2017 12:47 pm
Forum: General
Topic: [Partially-Solved] PCem v12 and Sound Lag
Replies: 124
Views: 23940

Re: [Solved] PCem v12 and Sound Lag

- SarahWalker: No, I think he just meant that PCem is more stable than 86Box, something that I told you last night already that people do say. :p Why do you keep tolerating her? Because I feel like some day she might improve, that and I do recognize the positive she does do (code contribution) despi...
by Battler
Sat 03 Jun, 2017 9:50 pm
Forum: General
Topic: [Partially-Solved] PCem v12 and Sound Lag
Replies: 124
Views: 23940

Re: [Solved] PCem v12 and Sound Lag

Mooch is *NOT* my second in command. She does not have write access to my repository, and she has been banned from my IRC channel more times than I can count for exactly this kind of attitude. And I also repeatedly told her to stop her anti-PCem bull____, but she doesn't listen. Edit: OK, I just yel...
by Battler
Sat 03 Jun, 2017 9:44 pm
Forum: General
Topic: [Partially-Solved] PCem v12 and Sound Lag
Replies: 124
Views: 23940

Re: [Solved] PCem v12 and Sound Lag

You've repeatedly said that you consider PCem and 86Box to be a competition, and that 'the market' would decide the 'winner'. And why is it that you seem to remember to the last detail everything bad I ever said while you don't remember even the patches I submitted 2 years ago? :p Yes, I did say th...
by Battler
Sat 03 Jun, 2017 9:19 pm
Forum: General
Topic: [Partially-Solved] PCem v12 and Sound Lag
Replies: 124
Views: 23940

Re: [Solved] PCem v12 and Sound Lag

- leilei: Such contributor poaching is in no way endorsed by me. I have repeatedly told people that this is not some sort of competition and everyone should be let to decide on their own where they should submit their changes. However, people don't listen.
by Battler
Sat 03 Jun, 2017 9:12 pm
Forum: General
Topic: [Partially-Solved] PCem v12 and Sound Lag
Replies: 124
Views: 23940

Re: [Solved] PCem v12 and Sound Lag

My what now? I was thinking about writing some SCSI emulation, since there was zero sign that anything would ever be contributed back. But I haven't actually done it yet. Well then I was given more false information, since the source (which is the same as for the other piece of hearsay, which I PM'...
by Battler
Sat 03 Jun, 2017 8:22 pm
Forum: General
Topic: [Partially-Solved] PCem v12 and Sound Lag
Replies: 124
Views: 23940

Re: [Solved] PCem v12 and Sound Lag

As 'another user' has said that you still want direct access to the repo, I can tell you now that I will never give you this. Pretty sure I've already told you this, though. I know this user is James-F (he told me it was him), and I never told him I want direct access, I simply told him that you to...
by Battler
Sat 03 Jun, 2017 7:45 pm
Forum: General
Topic: [Partially-Solved] PCem v12 and Sound Lag
Replies: 124
Views: 23940

Re: [Solved] PCem v12 and Sound Lag

Your last attempt to contribute was 8 months ago. Are you seriously telling me the only thing you've done since then is port someone else's OPL emulator? I did more things than that but I started with NukedOPL because it's the simplest thing for me to make a patch of. The rest would require conside...
by Battler
Sat 03 Jun, 2017 7:37 pm
Forum: Development
Topic: [Patch] Add NukedOPL
Replies: 20
Views: 4527

[Patch] Add NukedOPL

The three required files are attached. I also fixed the SB OPL volume so it uses the correct level (provided by James-F) when using both types of OPL. The nukedopl.* files go to src/dosbox . I also added the ability to not use NukedOPL which will make it fall back to DOSBox OPL3 emulation. NukedOPL ...
by Battler
Sat 03 Jun, 2017 6:54 pm
Forum: Development
Topic: [Bug] Warcraft 2 displays nothing
Replies: 35
Views: 7053

Re: [Bug] Warcraft 2 displays nothing

SarahWalker wrote:PCem does have a GPU BIOS with VBE 2.0 - the 'ATI Video Xpression (Mach64 VT2)' BIOS supports it.
Then it might be that the Mach64 VT2 BIOS you have is better than the one from VGA Museum which we use.
by Battler
Sat 03 Jun, 2017 6:41 pm
Forum: General
Topic: [Partially-Solved] PCem v12 and Sound Lag
Replies: 124
Views: 23940

Re: [Solved] PCem v12 and Sound Lag

SarahWalker wrote:Want to see Battler's changes in mainline? Convince him to start working with me again, instead of being an utter tit.
I thought I said just today in another thread that I was going to make a NukedOPL diff later today in another thread, so how am I refusing to contribute?
by Battler
Sat 03 Jun, 2017 3:37 pm
Forum: General
Topic: [Partially-Solved] PCem v12 and Sound Lag
Replies: 124
Views: 23940

Re: [Solved] PCem v12 and Sound Lag

And there are many desperately needed shortcuts included in Battler's 86Box, like Ctrl-Alt-Del shortcut and switch to full-screen shortcut, and the ability of directing MIDI to MUNT - the MT-32 Emulator, even if using any sound card lower than a SB16. (In official PCem, you can't select MIDI out if...
by Battler
Sat 03 Jun, 2017 3:29 pm
Forum: Development
Topic: [Bug] Warcraft 2 displays nothing
Replies: 35
Views: 7053

Re: [Bug] Warcraft 2 displays nothing

PCem is still in text mode while it should be in graphics mode. I have no idea why, though.
by Battler
Sat 03 Jun, 2017 3:15 pm
Forum: Development
Topic: [Bug] Warcraft 2 displays nothing
Replies: 35
Views: 7053

[Bug] Warcraft 2 displays nothing

It's probably a bug in the VBL emulation. It happens with any emulated graphics card. But it's not a black screen, I still see the line mark flickering in the upper left corner.
by Battler
Sat 03 Jun, 2017 2:01 pm
Forum: Development
Topic: [Bug] DOSIDLE.EXE crashes
Replies: 2
Views: 982

[Bug] DOSIDLE.EXE crashes

It crashes when EMM386 is loaded. This also worked fine before the flat segment commit, but now I get the following error: EMM386: Unrecoverable privileged operation error #01 - press ENTER to reboot .
by Battler
Sat 03 Jun, 2017 2:00 pm
Forum: Development
Topic: [Bug] 430VX is not setting PCI IRQ registers
Replies: 9
Views: 1948

Re: [Bug] 430VX is not setting PCI IRQ registers

Found the right PCI.EXE, and got all the slot information right. Much better! Thanks. :p
by Battler
Sat 03 Jun, 2017 1:22 pm
Forum: Development
Topic: [Bug] 430VX is not setting PCI IRQ registers
Replies: 9
Views: 1948

Re: [Bug] 430VX is not setting PCI IRQ registers

Where can I get this PCI.EXE? It looks like I'd really need it.
by Battler
Sat 03 Jun, 2017 12:42 pm
Forum: General
Topic: Timers Problem?
Replies: 1
Views: 766

Re: Timers Problem?

- James-F: I told you to get an idle driver for DOS, as the maxing out is due to EMM386 doing things that makes the dynamic recompiler go crazy and idle drivers solve that. Edit: As for the timers, I think I told Sarah in the past that improvements are needed. For one, I noticed that they seem to "s...
by Battler
Sat 03 Jun, 2017 12:39 pm
Forum: General
Topic: Sound Blaster Pro & 16
Replies: 39
Views: 8597

Re: Sound Blaster Pro & 16

- SarahWalker: Make sure though to still allow the user to select DOSBox OPL if they so desire, because at least on my Pentium Dual-Core, NukedOPL makes the emulator on average 10% slower.

- James-F: I will try to make a diff for NukedOPL later today, it should be fairly easy.
by Battler
Fri 02 Jun, 2017 9:44 pm
Forum: Development
Topic: [Bug] 430VX is not setting PCI IRQ registers
Replies: 9
Views: 1948

Re: [Bug] 430VX is not setting PCI IRQ registers

I am. And I confirmed above that with the regular 430VX BIOS, I indeed see the writes. However, with other BIOS'es I don't, at all. Maybe some register is returning a value some BIOS'es don't like?
by Battler
Fri 02 Jun, 2017 9:41 pm
Forum: Development
Topic: [Bug] 430VX is not setting PCI IRQ registers
Replies: 9
Views: 1948

Re: [Bug] 430VX is not setting PCI IRQ registers

OK, I just tried another BIOS and it works correctly. Howeveer, the fact some BIOS'es do not set those registers still means soemthing is wrong IMHO.
by Battler
Fri 02 Jun, 2017 9:31 pm
Forum: Development
Topic: [Bug] 430VX is not setting PCI IRQ registers
Replies: 9
Views: 1948

Re: [Bug] 430VX is not setting PCI IRQ registers

- SarahWalker: I commented out the pclog's, and I don't see anything. What BIOS are you using?
by Battler
Fri 02 Jun, 2017 9:13 pm
Forum: Development
Topic: [Bug] 430VX is not setting PCI IRQ registers
Replies: 9
Views: 1948

[Bug] 430VX is not setting PCI IRQ registers

Basically, it never updates the registers so they always stay at 0x80, ie. disabled.
by Battler
Fri 02 Jun, 2017 3:59 pm
Forum: General
Topic: Standard 8-button joystick driver for W9x
Replies: 4
Views: 1505

Re: Standard 8-button joystick driver for W9x

I second omarsis81's request.
by Battler
Thu 01 Jun, 2017 4:20 pm
Forum: Development
Topic: [Bug] LBA 2 for DOS causes an EMM386 fatal exception
Replies: 1
Views: 749

[Bug] LBA 2 for DOS causes an EMM386 fatal exception

Basically, start the game normally, play for a bit, suddenly it will do that and halt the PC. My EMM386 is loaded with parameters I=B000-B7FF I=E000-EFFF NOEMS . This used to work fine and the problems started appearing since that flat segment optimization commit.
by Battler
Tue 30 May, 2017 2:34 pm
Forum: Development
Topic: [Patch] CGA monochrome & selectable mono display
Replies: 46
Views: 10512

Re: [Patch] CGA monochrome & selectable mono display

- ecksemess: I took the table of colors from VileRancour's DOSBox patch, but the code to make it work on 86Box was mine (I just added these as options to the existing palettized renderer code).
by Battler
Mon 29 May, 2017 12:05 am
Forum: Development
Topic: [Bug] MIDI Out device problem
Replies: 12
Views: 3343

Re: [Bug] MIDI Out device problem

- basic2004: I think SarahWalker moved the reading of the relevent variable from the configuration file elsewhere, but forgot to comment out the code in midi_reset() that reset MIDI out device to 0. Incidentally, I made the exact same mess up in 86Box, and I found and fixed it about an hour ago.