[SOLVED] Navratil Software System Information locks up; errors on reboot

Support and general discussion.
Post Reply
User avatar
ppgrainbow
Posts: 460
Joined: Thu 04 Sep, 2014 7:03 am
Contact:

[SOLVED] Navratil Software System Information locks up; errors on reboot

Post by ppgrainbow » Mon 02 Sep, 2019 9:33 pm

I'm currently testing the utility called Naratil Software System Information on the emulated IBM PS/2 Model 80 and when this utility attempts to detect the two ESDI formatted hard drives, the emulated machine locks up hard.

Here's the emulated screenshot of what the machine is trying to detect:
Screenshot from 2019-09-02 14-17-18.png
Screenshot from 2019-09-02 14-17-18.png (153.44 KiB) Viewed 1029 times
Upon doing a hard reset, a 305 keyboard fuse error occurs:
Screenshot from 2019-09-02 14-18-30.png
Screenshot from 2019-09-02 14-18-30.png (6.74 KiB) Viewed 1029 times
Upon doing a second hard reset, a 301 keyboard erorr and a 8602 mouse error occurs as well:
Screenshot from 2019-09-02 14-19-34.png
Screenshot from 2019-09-02 14-19-34.png (8.48 KiB) Viewed 1029 times
Here are the current PCem configuration that was used:

Code: Select all

Emulated machine: IBM PS/2 Model 80
Processor: Intel 80386, 20 MHz
Video: Integrated VGA adapter
Sound: Adlib MCA
Floppy drives: 2 x 1.44 MB
Hard disk controller: IBM PS/2 ESDI controller
Hard disk drives: 2 x 296 MB
Memory: 12 MB (4 MB on mainboard, 8 MB using memory expansion adapter)
Mouse: Two-button PS/2 mouse
Operating System: IBM DOS 5.02 Revision 0
Please look into this issue to see if this is a bug in the CPU or it happens on real hardware although I can't test it on real hardware.

Thank you for your time. :)

INFO: 305 deals with the keyboard fuse, 301 is a keyboard error and 8602 is a user indicated mouse error. I don't know why this happens, but these issues must be investigated.
Last edited by ppgrainbow on Sun 08 Sep, 2019 5:48 pm, edited 1 time in total.

User avatar
ppgrainbow
Posts: 460
Joined: Thu 04 Sep, 2014 7:03 am
Contact:

Re: [SOLVED] Navratil Software System Information locks up; errors on reboot

Post by ppgrainbow » Sun 08 Sep, 2019 5:48 pm

Okay, problem has been solved I had to use the EMM386 driver to exclude regions C000 to DFFF where the ESDI hard disk controller is installed. Here's a screenshot:
Screenshot from 2019-09-08 10-44-36.png
Screenshot from 2019-09-08 10-44-36.png (81.41 KiB) Viewed 876 times
As for the 305, 301 and 8602 errors, this needs to be investigated on what could be causing this issue.

Post Reply