Can't open emulator

Support and general discussion.
Post Reply
User avatar
mforan89
Posts: 13
Joined: Sat 10 May, 2014 3:30 pm

Can't open emulator

Post by mforan89 »

Just as the title says. When I double click to open, it flashes on screen for a second and then immediately closes.
The error log has the following message:

Code: Select all

CreateSurface back failed
I am running Windows 7 x64 Edition

Any ideas as to what's causing this?
Thanks.
User avatar
SarahWalker
Site Admin
Posts: 1886
Joined: Thu 24 Apr, 2014 4:18 pm

Re: Can't open emulator

Post by SarahWalker »

That's a DirectDraw issue, indicating that the emulator couldn't create the required back buffers. What graphics card and drivers are you using?
User avatar
mforan89
Posts: 13
Joined: Sat 10 May, 2014 3:30 pm

Re: Can't open emulator

Post by mforan89 »

My Graphics card is an AMD Radeon Sapphire R9 290 and I am using the latest driver which is version 14.1 released on April 14th this year.
I hope there's a way to get this working.
User avatar
SarahWalker
Site Admin
Posts: 1886
Joined: Thu 24 Apr, 2014 4:18 pm

Re: Can't open emulator

Post by SarahWalker »

I don't have a Radeon so this may be difficult to reproduce and fix. As a temporary workaround, try the attached config - it should allow the emulator to start in Direct3D mode.
Attachments
cfg_direct3d.zip
(325 Bytes) Downloaded 729 times
User avatar
mforan89
Posts: 13
Joined: Sat 10 May, 2014 3:30 pm

Re: Can't open emulator

Post by mforan89 »

Thanks man, worked perfectly!
Post Reply