PC Speaker

Support and general discussion.
Bugman
Posts: 7
Joined: Thu 05 Jun, 2014 8:14 pm

PC Speaker

Postby Bugman » Thu 05 Jun, 2014 8:19 pm

Hello,
I seem to be experiencing an issue with the PC Speaker working for some games. The two I have tried that do not work are Castle Wolfenstein, and Starfleet II (Krellan).
All other normal PC "beeps" through the speaker work fine. I used Qbasic to create some basic notes, also worked fine.
I tried every combination of PC's, souncards, etc. Used MSDOS 6.22 and WIn98. All the same. Regular soundblaster for other games is fine.
I went back and tried the same programs on PCem 0.4 Same issue.
Also, playing these games using DosBox emulator work fine. I am making an assumption they use the speaker because when working in DosBOX emulator, the sound stops when I disable the "PC Speaker" in the config.
Are these games just using a different method to address the speaker that is not supported?
Thanks....
SarahWalker
Site Admin
Posts: 1328
Joined: Thu 24 Apr, 2014 4:18 pm

Re: PC Speaker

Postby SarahWalker » Wed 16 Jul, 2014 7:51 pm

This should (hopefully!) be fixed in rev 132 - I don't actually have either of the games you mention, but I did fix Beyond Castle Wolfenstein which I'd guess probably uses the same sound code as its predecessor.
Bugman
Posts: 7
Joined: Thu 05 Jun, 2014 8:14 pm

Re: PC Speaker

Postby Bugman » Fri 18 Jul, 2014 2:18 am

Yep, that did the trick.
Speaker in DOS games seems to work fine now.
Thanks for your Efforts!

Return to “General”

Who is online

Users browsing this forum: No registered users and 2 guests