Issue with NFS III Hot Pursuit on Linux Host

Support and general discussion.
Post Reply
andr25352
Posts: 6
Joined: Sun 12 Feb, 2017 9:50 am

Issue with NFS III Hot Pursuit on Linux Host

Post by andr25352 » Wed 13 Dec, 2017 10:29 pm

When running Need for Speed III Hot Pursuit on a Linux host(I used Linux Mint Mate 18.2),
a strange issue occurs where suddenly in a race, the screen turns blue and the game acts odd in general.
I have uploaded a video showing the issue here:
https://www.youtube.com/watch?v=jTZqhHdZzrQ(Be cautioned that the bug causes some loud noises)

The issue seems independent of guest operating system,
it is present on both Windows 98 and Windows 2000 guests.

The issue does not happen, when the emulator is run under a Windows 7 host.

szadycbr
Posts: 230
Joined: Mon 21 Nov, 2016 6:23 pm

Re: Issue with NFS III Hot Pursuit on Linux Host

Post by szadycbr » Thu 14 Dec, 2017 1:21 pm

Hm.. i was testing a 64 bit Linux version, and it is fault on the recompiler, there are known problems to it and 3d mark 99 does not work either. if you want to have it running, you must turn off recompiler on CPU and GPU as well, but sometimes its fine with only GPU off. Lower the CPU to 120mmx and you should be good to go, the lack of recompiler will make voodoo slower a bit and cpu will eat some cos depend on your rig, it could be as low as p75 to get 100%.

andr25352
Posts: 6
Joined: Sun 12 Feb, 2017 9:50 am

Re: Issue with NFS III Hot Pursuit on Linux Host

Post by andr25352 » Thu 14 Dec, 2017 4:35 pm

Ah, thank you, it works now, though I could have sworn that I had already tested the interpreter.

There is still the graphical issue on the loading screen and the countdown,
this happens only when using the games software rendering mode and not when using the voodoo.
The graphical glitch also happens on a Windows host.

Post Reply