Ensoniq AudioPCI Sound Issue

Support and general discussion.
Post Reply
grommit2007
Posts: 17
Joined: Sat 22 Apr, 2017 3:26 pm

Ensoniq AudioPCI Sound Issue

Post by grommit2007 » Wed 13 Dec, 2017 11:40 pm

I have noticed that with this soundcard, there is a lot of annoying crackling that should not occur on the real card.

This occurs in both Windows and DOS. Is there any fix for this?

User avatar
leilei
Posts: 556
Joined: Fri 25 Apr, 2014 4:47 pm

Re: Ensoniq AudioPCI Sound Issue

Post by leilei » Thu 14 Dec, 2017 12:24 am

I've noticed and mentioned the crackling since it was committed. It's more obvious on OpenAL Soft than Creative's OpenAL driver.

There are some cases where the crackling should be real though (Epic dos games)

grommit2007
Posts: 17
Joined: Sat 22 Apr, 2017 3:26 pm

Re: Ensoniq AudioPCI Sound Issue

Post by grommit2007 » Thu 14 Dec, 2017 12:27 am

I have tested it with both Epic and non-Epic games, and the problem is similar, in fact the crackling even shows up during normal Windows and DOS MIDI playback.

grommit2007
Posts: 17
Joined: Sat 22 Apr, 2017 3:26 pm

Re: Ensoniq AudioPCI Sound Issue

Post by grommit2007 » Thu 14 Dec, 2017 2:35 am

After changing the OpenAL32.dll to the latest version from openal.org , the problem appears to be partially solved.

Edit: I have also tried the latest version of OpenAL Soft, and it also appears to partially solve the problem as well.

Edit 2: The issue now manifests itself as clicking, static and crackling, and I have tried various settings in OpenAL Soft, which do not seem to help anything at all.

The specs of my emulated PC are:

Award 430VX PCI

Intel Pentium 75

64MB RAM

6GB HDD

S3 Virge/DX 2MB

Ensoniq AudioPCI (ES1371)

Windows 95 OSR2

The specs of my host PC are:

Intel Pentium Dual-Core T4300 2.10 GHz

2GB RAM

500GB HDD

Intel GMA 4500MHD

Windows 10 Home 64-bit

grommit2007
Posts: 17
Joined: Sat 22 Apr, 2017 3:26 pm

Re: Ensoniq AudioPCI Sound Issue

Post by grommit2007 » Fri 15 Dec, 2017 1:28 am

I have attached a copy of my pcem.cfg file if this helps to diagnose and fix this issue as well.
Attachments
pcem.cfg
(1.39 KiB) Downloaded 19 times

Post Reply