Problem with Recompiler

Support and general discussion.
Post Reply
donkeyulli
Posts: 8
Joined: Sat 19 Jul, 2014 2:11 pm

Problem with Recompiler

Post by donkeyulli »

Hallo :)

I am a big Fan of Pcem, but the Recompiler crashes the emulator directly after Starting the emulator. My specs:
CPU: I5-2500k
OS: Windows 7 Ultimate 64Bit
Ram: 8 GB
Graphic: Nvidia

I am using a x86 Build of the Emulator. (Revision 313)

The Crash occurs directly after starting the Emulator or choosing a Configuration, which involves the Recompiler.

The Interpreter works in all cases and I am very thankful for this great Emulator. Is there any Chance to get the Recompiler running? The Recompiler also crashes on my Notebook in the same way. Specs: i5-3210M, Windows 7 Home 64 Bit and AMD HD7670M.

Thanks in Advance for your help.

Best Regards, donkeyulli
nerd73
Posts: 116
Joined: Wed 24 Sep, 2014 11:16 pm

Re: Problem with Recompiler

Post by nerd73 »

donkeyulli wrote:Hallo :)

I am a big Fan of Pcem, but the Recompiler crashes the emulator directly after Starting the emulator. My specs:
CPU: I5-2500k
OS: Windows 7 Ultimate 64Bit
Ram: 8 GB
Graphic: Nvidia

I am using a x86 Build of the Emulator. (Revision 313)

The Crash occurs directly after starting the Emulator or choosing a Configuration, which involves the Recompiler.

The Interpreter works in all cases and I am very thankful for this great Emulator. Is there any Chance to get the Recompiler running? The Recompiler also crashes on my Notebook in the same way. Specs: i5-3210M, Windows 7 Home 64 Bit and AMD HD7670M.

Thanks in Advance for your help.

Best Regards, donkeyulli
Odd. Works for me on a much slower CPU (Athlon II X2 255). Did you compile with arch set to i686? If not, try that.
donkeyulli
Posts: 8
Joined: Sat 19 Jul, 2014 2:11 pm

Re: Problem with Recompiler

Post by donkeyulli »

Hallo :)

Thanks for your answer, but I compiled it successfully with machine set to i686. Using core2 fails with an error regarding sound.o: undefinend reference to convolve_sse.

Also my Attempt to produce a 64 Bit Build of the Emulator failed. How can I create a 64 Bit Build of the Emulator? The latest version of mingw64 doesnt work for me.

Thanks in Advance for any further help.

donkeyulli
Alegend45
Posts: 85
Joined: Sat 26 Apr, 2014 4:33 am

Re: Problem with Recompiler

Post by Alegend45 »

donkeyulli wrote:Hallo :)

I am a big Fan of Pcem, but the Recompiler crashes the emulator directly after Starting the emulator. My specs:
CPU: I5-2500k
OS: Windows 7 Ultimate 64Bit
Ram: 8 GB
Graphic: Nvidia

I am using a x86 Build of the Emulator. (Revision 313)

The Crash occurs directly after starting the Emulator or choosing a Configuration, which involves the Recompiler.

The Interpreter works in all cases and I am very thankful for this great Emulator. Is there any Chance to get the Recompiler running? The Recompiler also crashes on my Notebook in the same way. Specs: i5-3210M, Windows 7 Home 64 Bit and AMD HD7670M.

Thanks in Advance for your help.

Best Regards, donkeyulli
My Core i3-3210 can run it just fine, so you probably just compiled it wrong. Also, try using msys2 to compile PCem's 64-bit version. It works really well.
donkeyulli
Posts: 8
Joined: Sat 19 Jul, 2014 2:11 pm

Re: Problem with Recompiler

Post by donkeyulli »

Hello :)

I have found the reason for my problems with PCem:
I have deactivated the Data Execution Prevention for PCem in Windows and now it works :)

Thanks Good for giving me that idea :)
User avatar
ender
Posts: 51
Joined: Tue 14 Oct, 2014 12:51 pm

Re: Problem with Recompiler

Post by ender »

That certainly explains why I could never get recompiler versions to work.
Post Reply