Page 2 of 2

Re: Problems with some Origin games

Posted: Fri 23 Feb, 2018 9:06 am
by ForBarterOnly
That's good news.
Thanks for letting me know.
Looking forward to the next release.

Re: Problems with some Origin games

Posted: Thu 19 Jul, 2018 2:07 pm
by Snowman
I found another one that has problems. Cybermage: Darklight Awakening is missing sound and music in intro movie. After the intro sound and music are working fine. I tested this with PCem v14. I would appreciate if someone could test and confirm this.

@SarahWalker: Thank you for fixing WC, Armada, Privateer and WOG.

Re: Problems with some Origin games

Posted: Fri 20 Jul, 2018 5:02 am
by leilei
I get sound and music in Cybermage just fine including the intro. 430VX, Pentium 100, AWE32, Win95B. Cybermage configured to (as read in the setup program)

Code: Select all

SOUND CARD (DIGITAL)   SOUND BLASTER 16/AWE32
SOUND CARD PORT        0x220  DMA: 1  IRQ: 7
MIDI DEVICE (MUSIC)    SOUND BLASTER (FM)
MIDI PORT              0x388

Re: Problems with some Origin games

Posted: Fri 20 Jul, 2018 11:23 am
by Snowman
leilei wrote:
Fri 20 Jul, 2018 5:02 am
I get sound and music in Cybermage just fine including the intro. 430VX, Pentium 100, AWE32, Win95B. Cybermage configured to (as read in the setup program)

Code: Select all

SOUND CARD (DIGITAL)   SOUND BLASTER 16/AWE32
SOUND CARD PORT        0x220  DMA: 1  IRQ: 7
MIDI DEVICE (MUSIC)    SOUND BLASTER (FM)
MIDI PORT              0x388
You tested Cybermage on Win95. Could you test it on DOS 6.22 with my attached configuration?

Re: Problems with some Origin games

Posted: Fri 20 Jul, 2018 8:07 pm
by leilei
Just tried your config with a DOS 6.22 + SB16 drivers + OAK CD HDD image and the intro+game sound works there too.

Re: Problems with some Origin games

Posted: Fri 20 Jul, 2018 9:39 pm
by Snowman
leilei wrote:
Fri 20 Jul, 2018 8:07 pm
Just tried your config with a DOS 6.22 + SB16 drivers + OAK CD HDD image and the intro+game sound works there too.
Thanks. I tested the game in Win98SE and I have sound and music in intro and in game. In DOS 6.22 I tried all possible combinations and I can't get sound and music for intro but in game everything works. For DOS 6.22 I am using this Starter Pack: https://www.philscomputerlab.com/ms-dos ... -pack.html so I don't have to mess around with autoexec.bat and config.sys

Did you installed any special drivers for SB16 in DOS 6.22?

Re: Problems with some Origin games

Posted: Fri 20 Jul, 2018 10:11 pm
by leilei
I don't use a starter pack; just a stock 6.22 install + the official Creative Sound Blaster 16 floppies from 1993, which install a bunch of devices and TSRs to initialize the card and mixer. It's a little more involved than a simple SET BLASTER line.

Re: Problems with some Origin games

Posted: Fri 20 Jul, 2018 10:47 pm
by Snowman
leilei wrote:
Fri 20 Jul, 2018 10:11 pm
I don't use a starter pack; just a stock 6.22 install + the official Creative Sound Blaster 16 floppies from 1993, which install a bunch of devices and TSRs to initialize the card and mixer. It's a little more involved than a simple SET BLASTER line.
I didn't installed any drivers for SB16 in DOS 6.22 cause there is no need. Since game intro have no sound nor music but in game sound and music are working then this is a bug with PCem. Do you agree with me?

Re: Problems with some Origin games

Posted: Sat 28 Jul, 2018 12:42 pm
by Katakis
I will add that no matter which chipset/video card you use, the mouse cursor in Crusader: No Remorse goes as far as the middle of the screen and does not move further down.

Re: Problems with some Origin games

Posted: Sun 29 Jul, 2018 3:59 pm
by Snowman
Katakis wrote:
Sat 28 Jul, 2018 12:42 pm
I will add that no matter which chipset/video card you use, the mouse cursor in Crusader: No Remorse goes as far as the middle of the screen and does not move further down.
I tested the game with S3VirgeDX, P75 and patch v1.21. Mouse works fine. I can rotate character normally.