Takes over 20 seconds to open the configurator

Support and general discussion.
Post Reply
User avatar
kode54
Posts: 7
Joined: Thu 16 Aug, 2018 7:32 am

Takes over 20 seconds to open the configurator

Post by kode54 » Fri 17 Aug, 2018 1:07 am

* What the effect of the bug was (ie more than "doesn't work")

The application, when run from a Terminal or from a launcher, takes between 20 and 30 seconds to actually open the configurator dialog. Opening it from the terminal with a --config switch pointing at a configuration starts immediately.

* Description of the error, if any

There is no error to describe, really, as it doesn't even output anything to the terminal other than:

Code: Select all

Set fullspeed - 0 0 0
Until it actually starts running the dialog.

* What software was running on the emulator at the time

This is before the emulator even starts.

* What OS was running on the emulator at the time

I'm running a freshly built copy of v14 on Ubuntu 18.04.1, running Cinnamon desktop 3.6.7, with the NVidia proprietary drivers v390.48. My system is:

Core i7 3770
32GB DDR3 1600
Geforce GTX 960 4GB
Samsung 950 Pro 512GB SSD

* What configuration was being used in the emulator

No configuration has been launched at this point.

* Whether the dynamic recompiler was being used

Again, no configuration has been launched at this point.

* A screenshot of the issue, if possible

Here is a video of the issue:

https://youtu.be/FhzuG9eOT8c

* Any additional information that seems relevant

I configured the binary with:

Code: Select all

./configure --enable-networking
Which produced the following config.log:

Code: Select all

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by PCem configure v14, which was
generated by GNU Autoconf 2.69.  Invocation command line was

  $ ./configure --enable-release-build --enable-networking

## --------- ##
## Platform. ##
## --------- ##

hostname = dorktower
uname -m = x86_64
uname -r = 4.15.0-30-generic
uname -s = Linux
uname -v = #32-Ubuntu SMP Thu Jul 26 17:42:43 UTC 2018

/usr/bin/uname -p = unknown
/bin/uname -X     = unknown

/bin/arch              = unknown
/usr/bin/arch -k       = unknown
/usr/convex/getsysinfo = unknown
/usr/bin/hostinfo      = unknown
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH: /home/chris/.local/bin
PATH: /usr/local/sbin
PATH: /usr/local/bin
PATH: /usr/sbin
PATH: /usr/bin
PATH: /sbin
PATH: /bin
PATH: /usr/games
PATH: /usr/local/games
PATH: /snap/bin


## ----------- ##
## Core tests. ##
## ----------- ##

configure:2065: checking build system type
configure:2079: result: x86_64-unknown-linux-gnu
configure:2099: checking host system type
configure:2112: result: x86_64-unknown-linux-gnu
configure:2149: checking for a BSD-compatible install
configure:2217: result: /usr/bin/install -c
configure:2228: checking whether build environment is sane
configure:2283: result: yes
configure:2434: checking for a thread-safe mkdir -p
configure:2473: result: /bin/mkdir -p
configure:2480: checking for gawk
configure:2496: found /usr/bin/gawk
configure:2507: result: gawk
configure:2518: checking whether make sets $(MAKE)
configure:2540: result: yes
configure:2569: checking whether make supports nested variables
configure:2586: result: yes
configure:2760: checking for gcc
configure:2776: found /usr/bin/gcc
configure:2787: result: gcc
configure:3016: checking for C compiler version
configure:3025: gcc --version >&5
gcc (Ubuntu 7.3.0-16ubuntu3) 7.3.0
Copyright (C) 2017 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:3036: $? = 0
configure:3025: gcc -v >&5
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/7/lto-wrapper
OFFLOAD_TARGET_NAMES=nvptx-none
OFFLOAD_TARGET_DEFAULT=1
Target: x86_64-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu 7.3.0-16ubuntu3' --with-bugurl=file:///usr/share/doc/gcc-7/README.Bugs --enable-languages=c,ada,c++,go,brig,d,fortran,objc,obj-c++ --prefix=/usr --with-gcc-major-version-only --with-as=/usr/bin/x86_64-linux-gnu-as --with-ld=/usr/bin/x86_64-linux-gnu-ld --program-suffix=-7 --program-prefix=x86_64-linux-gnu- --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --with-default-libstdcxx-abi=new --enable-gnu-unique-object --disable-vtable-verify --enable-libmpx --enable-plugin --enable-default-pie --with-system-zlib --with-target-system-zlib --enable-objc-gc=auto --enable-multiarch --disable-werror --with-arch-32=i686 --with-abi=m64 --with-multilib-list=m32,m64,mx32 --enable-multilib --with-tune=generic --enable-offload-targets=nvptx-none --without-cuda-driver --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu
Thread model: posix
gcc version 7.3.0 (Ubuntu 7.3.0-16ubuntu3) 
configure:3036: $? = 0
configure:3025: gcc -V >&5
gcc: error: unrecognized command line option '-V'
gcc: fatal error: no input files
compilation terminated.
configure:3036: $? = 1
configure:3025: gcc -qversion >&5
gcc: error: unrecognized command line option '-qversion'; did you mean '--version'?
gcc: fatal error: no input files
compilation terminated.
configure:3036: $? = 1
configure:3056: checking whether the C compiler works
configure:3078: gcc    conftest.c  >&5
configure:3082: $? = 0
configure:3130: result: yes
configure:3133: checking for C compiler default output file name
configure:3135: result: a.out
configure:3141: checking for suffix of executables
configure:3148: gcc -o conftest    conftest.c  >&5
configure:3152: $? = 0
configure:3174: result: 
configure:3196: checking whether we are cross compiling
configure:3204: gcc -o conftest    conftest.c  >&5
configure:3208: $? = 0
configure:3215: ./conftest
configure:3219: $? = 0
configure:3234: result: no
configure:3239: checking for suffix of object files
configure:3261: gcc -c   conftest.c >&5
configure:3265: $? = 0
configure:3286: result: o
configure:3290: checking whether we are using the GNU C compiler
configure:3309: gcc -c   conftest.c >&5
configure:3309: $? = 0
configure:3318: result: yes
configure:3327: checking whether gcc accepts -g
configure:3347: gcc -c -g  conftest.c >&5
configure:3347: $? = 0
configure:3388: result: yes
configure:3405: checking for gcc option to accept ISO C89
configure:3468: gcc  -c -g -O2  conftest.c >&5
configure:3468: $? = 0
configure:3481: result: none needed
configure:3506: checking whether gcc understands -c and -o together
configure:3528: gcc -c conftest.c -o conftest2.o
configure:3531: $? = 0
configure:3528: gcc -c conftest.c -o conftest2.o
configure:3531: $? = 0
configure:3543: result: yes
configure:3571: checking for style of include used by make
configure:3599: result: GNU
configure:3625: checking dependency style of gcc
configure:3736: result: gcc3
configure:3809: checking for g++
configure:3825: found /usr/bin/g++
configure:3836: result: g++
configure:3863: checking for C++ compiler version
configure:3872: g++ --version >&5
g++ (Ubuntu 7.3.0-16ubuntu3) 7.3.0
Copyright (C) 2017 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:3883: $? = 0
configure:3872: g++ -v >&5
Using built-in specs.
COLLECT_GCC=g++
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/7/lto-wrapper
OFFLOAD_TARGET_NAMES=nvptx-none
OFFLOAD_TARGET_DEFAULT=1
Target: x86_64-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu 7.3.0-16ubuntu3' --with-bugurl=file:///usr/share/doc/gcc-7/README.Bugs --enable-languages=c,ada,c++,go,brig,d,fortran,objc,obj-c++ --prefix=/usr --with-gcc-major-version-only --with-as=/usr/bin/x86_64-linux-gnu-as --with-ld=/usr/bin/x86_64-linux-gnu-ld --program-suffix=-7 --program-prefix=x86_64-linux-gnu- --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --with-default-libstdcxx-abi=new --enable-gnu-unique-object --disable-vtable-verify --enable-libmpx --enable-plugin --enable-default-pie --with-system-zlib --with-target-system-zlib --enable-objc-gc=auto --enable-multiarch --disable-werror --with-arch-32=i686 --with-abi=m64 --with-multilib-list=m32,m64,mx32 --enable-multilib --with-tune=generic --enable-offload-targets=nvptx-none --without-cuda-driver --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu
Thread model: posix
gcc version 7.3.0 (Ubuntu 7.3.0-16ubuntu3) 
configure:3883: $? = 0
configure:3872: g++ -V >&5
g++: error: unrecognized command line option '-V'
g++: fatal error: no input files
compilation terminated.
configure:3883: $? = 1
configure:3872: g++ -qversion >&5
g++: error: unrecognized command line option '-qversion'; did you mean '--version'?
g++: fatal error: no input files
compilation terminated.
configure:3883: $? = 1
configure:3887: checking whether we are using the GNU C++ compiler
configure:3906: g++ -c   conftest.cpp >&5
configure:3906: $? = 0
configure:3915: result: yes
configure:3924: checking whether g++ accepts -g
configure:3944: g++ -c -g  conftest.cpp >&5
configure:3944: $? = 0
configure:3985: result: yes
configure:4010: checking dependency style of g++
configure:4121: result: gcc3
configure:4140: checking whether to build for release
configure:4148: result: yes
configure:4163: checking whether to enable debugging
configure:4178: result: no
configure:4182: checking whether to enable networking
configure:4190: result: yes
configure:4197: checking whether to use ALSA for MIDI output
configure:4208: result: no
configure:4212: checking for cpu
configure:4222: result: x86_64
configure:4247: checking for off64_t
configure:4261: gcc -o conftest -O3   conftest.c  >&5
conftest.c: In function 'main':
conftest.c:15:1: error: unknown type name 'off64_t'; did you mean 'off_t'?
 off64_t n=0;
 ^~~~~~~
 off_t
configure:4261: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "PCem"
| #define PACKAGE_TARNAME "pcem"
| #define PACKAGE_VERSION "v14"
| #define PACKAGE_STRING "PCem v14"
| #define PACKAGE_BUGREPORT "Sarah Walker <pcem@pcem-emulator.co.uk>"
| #define PACKAGE_URL ""
| #define PACKAGE "pcem"
| #define VERSION "v14"
| /* end confdefs.h.  */
| #include <sys/types.h>
| int
| main ()
| {
| off64_t n=0;
|   ;
|   return 0;
| }
configure:4268: result: no
configure:4363: checking for pkg-config
configure:4381: found /usr/bin/pkg-config
configure:4393: result: /usr/bin/pkg-config
configure:4418: checking pkg-config is at least version 0.9.0
configure:4421: result: yes
configure:4467: checking for SDL
configure:4474: $PKG_CONFIG --exists --print-errors "sdl2 >= $min_sdl_version"
configure:4477: $? = 0
configure:4491: $PKG_CONFIG --exists --print-errors "sdl2 >= $min_sdl_version"
configure:4494: $? = 0
configure:4532: result: yes
configure:4870: checking for wx-config
configure:4889: found /usr/bin/wx-config
configure:4902: result: /usr/bin/wx-config
configure:4917: checking for wxWidgets version >= 3.0.0
configure:4963: result: yes (version 3.0.4)
configure:4967: checking for wxWidgets static library
configure:4971: result: no
configure:5167: checking for pthread_create in -lpthread
configure:5192: gcc -o conftest -O3   conftest.c -lpthread   >&5
configure:5192: $? = 0
configure:5201: result: yes
configure:5321: checking for glGetError in -lGL
configure:5346: gcc -o conftest -O3   conftest.c -lGL  -lpthread  >&5
configure:5346: $? = 0
configure:5355: result: yes
configure:5370: checking for alGetError in -lopenal
configure:5395: gcc -o conftest -O3   conftest.c -lopenal  -lGL -lpthread  >&5
configure:5395: $? = 0
configure:5404: result: yes
configure:5597: checking that generated files are newer than configure
configure:5603: result: done
configure:5670: creating ./config.status

## ---------------------- ##
## Running config.status. ##
## ---------------------- ##

This file was extended by PCem config.status v14, which was
generated by GNU Autoconf 2.69.  Invocation command line was

  CONFIG_FILES    = 
  CONFIG_HEADERS  = 
  CONFIG_LINKS    = 
  CONFIG_COMMANDS = 
  $ ./config.status 

on dorktower

config.status:830: creating Makefile
config.status:830: creating src/Makefile
config.status:1002: executing depfiles commands

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_build=x86_64-unknown-linux-gnu
ac_cv_c_compiler_gnu=yes
ac_cv_cxx_compiler_gnu=yes
ac_cv_env_CCC_set=
ac_cv_env_CCC_value=
ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=
ac_cv_env_CFLAGS_value=
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CXXFLAGS_set=
ac_cv_env_CXXFLAGS_value=
ac_cv_env_CXX_set=
ac_cv_env_CXX_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_LIBS_set=
ac_cv_env_LIBS_value=
ac_cv_env_PKG_CONFIG_LIBDIR_set=
ac_cv_env_PKG_CONFIG_LIBDIR_value=
ac_cv_env_PKG_CONFIG_PATH_set=
ac_cv_env_PKG_CONFIG_PATH_value=
ac_cv_env_PKG_CONFIG_set=
ac_cv_env_PKG_CONFIG_value=
ac_cv_env_SDL2_FRAMEWORK_set=
ac_cv_env_SDL2_FRAMEWORK_value=
ac_cv_env_SDL_CFLAGS_set=
ac_cv_env_SDL_CFLAGS_value=
ac_cv_env_SDL_LIBS_set=
ac_cv_env_SDL_LIBS_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_host=x86_64-unknown-linux-gnu
ac_cv_lib_GL_glGetError=yes
ac_cv_lib_openal_alGetError=yes
ac_cv_lib_pthread_pthread_create=yes
ac_cv_objext=o
ac_cv_path_WX_CONFIG_PATH=/usr/bin/wx-config
ac_cv_path_ac_pt_PKG_CONFIG=/usr/bin/pkg-config
ac_cv_path_install='/usr/bin/install -c'
ac_cv_path_mkdir=/bin/mkdir
ac_cv_prog_AWK=gawk
ac_cv_prog_ac_ct_CC=gcc
ac_cv_prog_ac_ct_CXX=g++
ac_cv_prog_cc_c89=
ac_cv_prog_cc_g=yes
ac_cv_prog_cxx_g=yes
ac_cv_prog_make_make_set=yes
am_cv_CC_dependencies_compiler_type=gcc3
am_cv_CXX_dependencies_compiler_type=gcc3
am_cv_make_support_nested_variables=yes
am_cv_prog_cc_c_o=yes
pkg_cv_SDL_CFLAGS='-D_REENTRANT -I/usr/include/SDL2'
pkg_cv_SDL_LIBS=-lSDL2

## ----------------- ##
## Output variables. ##
## ----------------- ##

ACLOCAL='${SHELL} /home/chris/Source/PCem/missing aclocal-1.15'
AMDEPBACKSLASH='\'
AMDEP_FALSE='#'
AMDEP_TRUE=''
AMTAR='$${TAR-tar}'
AM_BACKSLASH='\'
AM_DEFAULT_V='$(AM_DEFAULT_VERBOSITY)'
AM_DEFAULT_VERBOSITY='1'
AM_V='$(V)'
AUTOCONF='${SHELL} /home/chris/Source/PCem/missing autoconf'
AUTOHEADER='${SHELL} /home/chris/Source/PCem/missing autoheader'
AUTOMAKE='${SHELL} /home/chris/Source/PCem/missing automake-1.15'
AWK='gawk'
CC='gcc'
CCDEPMODE='depmode=gcc3'
CFLAGS='-O3'
CPPFLAGS=''
CPU_I386_FALSE=''
CPU_I386_TRUE='#'
CPU_X86_64_FALSE='#'
CPU_X86_64_TRUE=''
CXX='g++'
CXXDEPMODE='depmode=gcc3'
CXXFLAGS='-O3'
CYGPATH_W='echo'
DEFS='-DPACKAGE_NAME=\"PCem\" -DPACKAGE_TARNAME=\"pcem\" -DPACKAGE_VERSION=\"v14\" -DPACKAGE_STRING=\"PCem\ v14\" -DPACKAGE_BUGREPORT=\"Sarah\ Walker\ \<pcem@pcem-emulator.co.uk\>\" -DPACKAGE_URL=\"\" -DPACKAGE=\"pcem\" -DVERSION=\"v14\" -DHAVE_LIBPTHREAD=1 -DHAVE_LIBGL=1 -DHAVE_LIBOPENAL=1'
DEPDIR='.deps'
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EXEEXT=''
HAS_OFF64T_FALSE=''
HAS_OFF64T_TRUE='#'
INSTALL_DATA='${INSTALL} -m 644'
INSTALL_PROGRAM='${INSTALL}'
INSTALL_SCRIPT='${INSTALL}'
INSTALL_STRIP_PROGRAM='$(install_sh) -c -s'
LDFLAGS=''
LIBOBJS=''
LIBS='-lopenal -lGL -lpthread  -L/usr/lib/x86_64-linux-gnu -pthread   -lwx_gtk2u_xrc-3.0 -lwx_gtk2u_html-3.0 -lwx_gtk2u_qa-3.0 -lwx_gtk2u_adv-3.0 -lwx_gtk2u_core-3.0 -lwx_baseu_xml-3.0 -lwx_baseu_net-3.0 -lwx_baseu-3.0  -lSDL2'
LTLIBOBJS=''
MAKEINFO='${SHELL} /home/chris/Source/PCem/missing makeinfo'
MKDIR_P='/bin/mkdir -p'
OBJEXT='o'
OS_LINUX_FALSE='#'
OS_LINUX_TRUE=''
OS_MACOSX_FALSE=''
OS_MACOSX_TRUE='#'
OS_WINDOWS_FALSE=''
OS_WINDOWS_TRUE='#'
PACKAGE='pcem'
PACKAGE_BUGREPORT='Sarah Walker <pcem@pcem-emulator.co.uk>'
PACKAGE_NAME='PCem'
PACKAGE_STRING='PCem v14'
PACKAGE_TARNAME='pcem'
PACKAGE_URL=''
PACKAGE_VERSION='v14'
PATH_SEPARATOR=':'
PKG_CONFIG='/usr/bin/pkg-config'
PKG_CONFIG_LIBDIR=''
PKG_CONFIG_PATH=''
RELEASE_BUILD_FALSE='#'
RELEASE_BUILD_TRUE=''
SDL2_CONFIG='pkg-config sdl2'
SDL2_FRAMEWORK=''
SDL_CFLAGS='-D_REENTRANT -I/usr/include/SDL2'
SDL_LIBS='-lSDL2'
SET_MAKE=''
SHELL='/bin/bash'
STRIP=''
USE_ALSA_FALSE=''
USE_ALSA_TRUE='#'
USE_NETWORKING_FALSE='#'
USE_NETWORKING_TRUE=''
USE_WX_FALSE=''
USE_WX_TRUE='#'
VERSION='v14'
WX_CFLAGS='-I/usr/lib/x86_64-linux-gnu/wx/include/gtk2-unicode-3.0 -I/usr/include/wx-3.0 -D_FILE_OFFSET_BITS=64 -DWXUSINGDLL -D__WXGTK__ -pthread'
WX_CFLAGS_ONLY='-pthread'
WX_CONFIG_PATH='/usr/bin/wx-config'
WX_CPPFLAGS='-I/usr/lib/x86_64-linux-gnu/wx/include/gtk2-unicode-3.0 -I/usr/include/wx-3.0 -D_FILE_OFFSET_BITS=64 -DWXUSINGDLL -D__WXGTK__'
WX_CXXFLAGS='-I/usr/lib/x86_64-linux-gnu/wx/include/gtk2-unicode-3.0 -I/usr/include/wx-3.0 -D_FILE_OFFSET_BITS=64 -DWXUSINGDLL -D__WXGTK__ -pthread'
WX_CXXFLAGS_ONLY=''
WX_LIBS='-L/usr/lib/x86_64-linux-gnu -pthread   -lwx_gtk2u_xrc-3.0 -lwx_gtk2u_html-3.0 -lwx_gtk2u_qa-3.0 -lwx_gtk2u_adv-3.0 -lwx_gtk2u_core-3.0 -lwx_baseu_xml-3.0 -lwx_baseu_net-3.0 -lwx_baseu-3.0 '
WX_LIBS_STATIC=''
WX_RESCOMP=''
WX_VERSION='3.0.4'
WX_VERSION_MAJOR='3'
WX_VERSION_MICRO='4'
WX_VERSION_MINOR='0'
ac_ct_CC='gcc'
ac_ct_CXX='g++'
am__EXEEXT_FALSE=''
am__EXEEXT_TRUE='#'
am__fastdepCC_FALSE='#'
am__fastdepCC_TRUE=''
am__fastdepCXX_FALSE='#'
am__fastdepCXX_TRUE=''
am__include='include'
am__isrc=''
am__leading_dot='.'
am__nodep='_no'
am__quote=''
am__tar='$${TAR-tar} chof - "$$tardir"'
am__untar='$${TAR-tar} xf -'
bindir='${exec_prefix}/bin'
build='x86_64-unknown-linux-gnu'
build_alias=''
build_cpu='x86_64'
build_os='linux-gnu'
build_vendor='unknown'
datadir='${datarootdir}'
datarootdir='${prefix}/share'
docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'
dvidir='${docdir}'
exec_prefix='${prefix}'
host='x86_64-unknown-linux-gnu'
host_alias=''
host_cpu='x86_64'
host_os='linux-gnu'
host_vendor='unknown'
htmldir='${docdir}'
includedir='${prefix}/include'
infodir='${datarootdir}/info'
install_sh='${SHELL} /home/chris/Source/PCem/install-sh'
libdir='${exec_prefix}/lib'
libexecdir='${exec_prefix}/libexec'
localedir='${datarootdir}/locale'
localstatedir='${prefix}/var'
mandir='${datarootdir}/man'
mkdir_p='$(MKDIR_P)'
oldincludedir='/usr/include'
pdfdir='${docdir}'
prefix='/usr/local'
program_transform_name='s,x,x,'
psdir='${docdir}'
runstatedir='${localstatedir}/run'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
sysconfdir='${prefix}/etc'
target_alias=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

/* confdefs.h */
#define PACKAGE_NAME "PCem"
#define PACKAGE_TARNAME "pcem"
#define PACKAGE_VERSION "v14"
#define PACKAGE_STRING "PCem v14"
#define PACKAGE_BUGREPORT "Sarah Walker <pcem@pcem-emulator.co.uk>"
#define PACKAGE_URL ""
#define PACKAGE "pcem"
#define VERSION "v14"
#define HAVE_LIBPTHREAD 1
#define HAVE_LIBGL 1
#define HAVE_LIBOPENAL 1

configure: exit 0
The dependencies:

Code: Select all

Package: libwxbase3.0-dev
Version: 3.0.4+dfsg-3
Priority: optional
Section: universe/libdevel
Source: wxwidgets3.0
Origin: Ubuntu
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: wxWidgets Maintainers <freewx-maint@lists.alioth.debian.org>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 227 kB
Depends: wx3.0-headers (= 3.0.4+dfsg-3), libwxbase3.0-0v5 (= 3.0.4+dfsg-3), libc6-dev | libc-dev
Suggests: wx3.0-doc, gettext
Homepage: https://www.wxwidgets.org/
Supported: 3y
Download-Size: 29.5 kB
APT-Manual-Installed: yes
APT-Sources: http://us.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
Description: wxBase library (development) - non-GUI support classes of wxWidgets toolkit
 wxBase is a collection of C++ classes providing basic data structures
 (strings, lists, arrays), powerful wxDateTime class for date manipulations,
 portable wrappers around many OS-specific functions allowing the same
 program to work for all supported platforms, wxThread class for writing
 multithreaded programs, and much more.
 .
 wxBase currently supports the following platforms: Generic Unix (Linux,
 FreeBSD, Solaris, HP-UX, ...), Microsoft Windows, and Mac OS X.
 .
 This package provides the files needed to compile apps using the wxBase
 library.

Code: Select all

Package: libwxgtk3.0-dev
Version: 3.0.4+dfsg-3
Priority: optional
Section: universe/libdevel
Source: wxwidgets3.0
Origin: Ubuntu
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: wxWidgets Maintainers <freewx-maint@lists.alioth.debian.org>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 236 kB
Depends: wx-common, wx3.0-headers (= 3.0.4+dfsg-3), libwxgtk3.0-0v5 (= 3.0.4+dfsg-3), libwxbase3.0-dev (= 3.0.4+dfsg-3), libgl1-mesa-dev | libgl-dev, xlibmesa-glu-dev | libglu-dev
Suggests: wx3.0-doc, gettext
Homepage: https://www.wxwidgets.org/
Supported: 3y
Download-Size: 29.6 kB
APT-Manual-Installed: yes
APT-Sources: http://us.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
Description: wxWidgets Cross-platform C++ GUI toolkit (GTK+ development)
 wxWidgets (formerly known as wxWindows) is a class library for C++ providing
 GUI components and other facilities on several popular platforms (and some
 unpopular ones as well).
 .
 This package provides files needed to compile wxWidgets programs.  If you
 want to compile apps using the (optional) glcanvas library you will need
 to have Mesa or OpenGL installed too.
 .
 This package also provides the wx-config script.

Code: Select all

Package: libsdl2-dev
Version: 2.0.8+dfsg1-1ubuntu1.18.04.1
Priority: optional
Section: universe/libdevel
Source: libsdl2
Origin: Ubuntu
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Debian SDL packages maintainers <pkg-sdl-maintainers@lists.alioth.debian.org>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 4,298 kB
Depends: libasound2-dev, libdbus-1-dev, libegl1-mesa-dev, libgl1-mesa-dev, libgles2-mesa-dev, libglu1-mesa-dev, libibus-1.0-dev, libmirclient-dev, libpulse-dev, libsdl2-2.0-0 (= 2.0.8+dfsg1-1ubuntu1.18.04.1), libsndio-dev, libudev-dev, libwayland-dev, libx11-dev, libxcursor-dev, libxext-dev, libxi-dev, libxinerama-dev, libxkbcommon-dev, libxrandr-dev, libxss-dev, libxt-dev, libxv-dev, libxxf86vm-dev
Conflicts: libsdl-1.3-dev
Replaces: libsdl-1.3-dev
Homepage: https://www.libsdl.org/
Supported: 3y
Download-Size: 680 kB
APT-Manual-Installed: yes
APT-Sources: http://us.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages
Description: Simple DirectMedia Layer development files
 SDL is a library that allows programs portable low level access to a video
 framebuffer, audio output, mouse, and keyboard.
 .
 This package contains the files needed to compile and link programs which
 use SDL.

Package: libsdl2-dev
Version: 2.0.8+dfsg1-1ubuntu1
Priority: optional
Section: universe/libdevel
Source: libsdl2
Origin: Ubuntu
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Debian SDL packages maintainers <pkg-sdl-maintainers@lists.alioth.debian.org>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 4,298 kB
Depends: libasound2-dev, libdbus-1-dev, libegl1-mesa-dev, libgl1-mesa-dev, libgles2-mesa-dev, libglu1-mesa-dev, libibus-1.0-dev, libmirclient-dev, libpulse-dev, libsdl2-2.0-0 (= 2.0.8+dfsg1-1ubuntu1), libsndio-dev, libudev-dev, libwayland-dev, libx11-dev, libxcursor-dev, libxext-dev, libxi-dev, libxinerama-dev, libxkbcommon-dev, libxrandr-dev, libxss-dev, libxt-dev, libxv-dev, libxxf86vm-dev
Conflicts: libsdl-1.3-dev
Replaces: libsdl-1.3-dev
Homepage: https://www.libsdl.org/
Supported: 3y
Download-Size: 681 kB
APT-Sources: http://us.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
Description: Simple DirectMedia Layer development files
 SDL is a library that allows programs portable low level access to a video
 framebuffer, audio output, mouse, and keyboard.
 .
 This package contains the files needed to compile and link programs which
 use SDL.

Code: Select all

Package: libopenal-dev
Version: 1:1.18.2-2
Priority: optional
Section: universe/libdevel
Source: openal-soft
Origin: Ubuntu
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Debian Games Team <pkg-games-devel@lists.alioth.debian.org>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 159 kB
Depends: libopenal1 (= 1:1.18.2-2)
Homepage: http://kcat.strangesoft.net/openal.html
Supported: 3y
Download-Size: 20.9 kB
APT-Manual-Installed: yes
APT-Sources: http://us.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
Description: Software implementation of the OpenAL audio API (development files)
 OpenAL, the Open Audio Library, is a joint effort to create an open,
 vendor-neutral, cross-platform API for interactive, primarily spatialized
 audio. OpenAL's primary audience are application developers and desktop
 users that rely on portable standards like OpenGL, for games and other
 multimedia applications.
 .
 This package contains the files necessary for development with OpenAL .

User avatar
Vaporeon
Posts: 8
Joined: Tue 24 Jun, 2014 11:37 am
Contact:

Re: Takes over 20 seconds to open the configurator

Post by Vaporeon » Fri 17 Aug, 2018 1:54 am

I know I'm being unhelpful to say this, but it works as expected on my Arch Linux box with KDE running an RX580 With OSS drivers.
Hmm.

User avatar
kode54
Posts: 7
Joined: Thu 16 Aug, 2018 7:32 am

Re: Takes over 20 seconds to open the configurator

Post by kode54 » Fri 17 Aug, 2018 3:14 am

I figured it out, through debugging. It was reading the TOC of a CDR that was in my optical drive, repeatedly, and each TOC read was taking about 10 seconds.

Post Reply