v11 released!

Support and general discussion.
Post Reply
User avatar
SarahWalker
Site Admin
Posts: 1546
Joined: Thu 24 Apr, 2014 4:18 pm

v11 released!

Post by SarahWalker » Sun 05 Jun, 2016 8:34 pm

v11 is now out. Changes since v10.1 :
  • New machines added - Tandy 1000HX, Tandy 1000SL/2, Award 286 clone, IBM PS/1 model 2121
  • New graphics card - Hercules InColor
  • 3DFX recompiler - 2-4x speedup over previous emulation
  • Added Cyrix 6x86 emulation
  • Some optimisations to dynamic recompiler - typically around 10-15% improvement over v10, more when MMX used
  • Fixed broken 8088/8086 timing
  • Fixes to Mach64 and ViRGE 2D blitters
  • XT machines can now have less than 640kb RAM
  • Added IBM PS/1 audio card emulation
  • Added Adlib Gold surround module emulation
  • Fixes to PCjr/Tandy PSG emulation
  • GUS now in stereo
  • Numerous FDC changes - more drive types, FIFO emulation, better support of XDF images, better FDI support
  • CD-ROM changes - CD-ROM IDE channel now configurable, improved disc change handling, better volume control support
  • Now directly supports .ISO format for CD-ROM emulation
  • Fixed crash when using Direct3D output on Intel HD graphics
  • Various other fixes
Thanks to everyone who contributed to this release, whether it be through patches, bug reports, or any other kind of support.

User avatar
omarsis81
Posts: 623
Joined: Thu 17 Dec, 2015 6:20 pm

Re: v11 released!

Post by omarsis81 » Sun 05 Jun, 2016 9:35 pm

Thank you very much for this long awaited release! I will get my hands on it right away!
PS: Long live PCem! Best emulator ever!

Lekendri
Posts: 17
Joined: Wed 27 Apr, 2016 11:06 pm

Re: v11 released!

Post by Lekendri » Mon 06 Jun, 2016 9:49 am

Thank you SarahWalker. Thank you.

jznomoney
Posts: 80
Joined: Sat 06 Dec, 2014 9:11 pm

Re: v11 released!

Post by jznomoney » Mon 06 Jun, 2016 3:56 pm

On the main page you posted a release date of may 5th 2016 when you released it on June 5th 2016. I figure I'd point that out. Great job on the release though. Keep up the great work.

UPerschke
Posts: 33
Joined: Wed 25 May, 2016 7:43 pm

Re: v11 released!

Post by UPerschke » Mon 06 Jun, 2016 8:51 pm

Yay, awesome work! Keep it up!

User avatar
leilei
Posts: 565
Joined: Fri 25 Apr, 2014 4:47 pm

Re: v11 released!

Post by leilei » Tue 07 Jun, 2016 11:09 pm

Reddit finally gets the point

also here's a quake2 video

Katakis
Posts: 79
Joined: Thu 05 Mar, 2015 6:42 am

Re: v11 released!

Post by Katakis » Mon 13 Jun, 2016 11:13 am

Thank you, Sarah.

Hopefully, I will not have to run Parallels for this reason as the sound lags a bit whenever I use it.
I am using the emulator via Wine, but I am sure that Wine will not handle it as more and more features get implemented.

Solstar82
Posts: 49
Joined: Thu 12 May, 2016 9:19 am

Re: v11 released!

Post by Solstar82 » Wed 15 Jun, 2016 10:01 am

leilei wrote:Reddit finally gets the point

also here's a quake2 video
wow,now that's fast!may i ask your pcem config that you're using?

RomanOn
Posts: 10
Joined: Sat 07 Nov, 2015 6:29 am

Re: v11 released!

Post by RomanOn » Thu 14 Jul, 2016 4:17 pm

Nice work but...
- 8088 is still faster than should be
- EGA still dont work on my W10 x64 PC
- still without coprocessor choice on 8088/80286/80386 machines

Battler
Posts: 793
Joined: Sun 06 Jul, 2014 7:05 pm

Re: v11 released!

Post by Battler » Thu 14 Jul, 2016 5:36 pm

RomanOn wrote:EGA still dont work on my W10 x64 PC
Then the problem is on your end, because it works perfectly fine for me on Windows 10 Enterprise x64 Build 10586 (November 2015 update final).

User avatar
omarsis81
Posts: 623
Joined: Thu 17 Dec, 2015 6:20 pm

Re: v11 released!

Post by omarsis81 » Thu 14 Jul, 2016 5:59 pm

Agreed, I'm running Windows 8.1 64 and and EGA works fine, Windows 10 should work too.
Try switching video output between Direct3D and DirectDraw

This is generic EGA, I would love to see more branded EGA cards like this VEGA's Video 7
http://www.recycledgoods.com/vega-isa-e ... -card.html
http://minuszerodegrees.net/manuals/Vid ... 201985.pdf

Battler
Posts: 793
Joined: Sun 06 Jul, 2014 7:05 pm

Re: v11 released!

Post by Battler » Thu 14 Jul, 2016 9:48 pm

- omarsis81: I have the emulation of Chips & Technologies SuperEGA in the works. I'll submit it as a patch when it's finished.

User avatar
omarsis81
Posts: 623
Joined: Thu 17 Dec, 2015 6:20 pm

Re: v11 released!

Post by omarsis81 » Thu 14 Jul, 2016 11:58 pm

Battler wrote:- omarsis81: I have the emulation of Chips & Technologies SuperEGA in the works. I'll submit it as a patch when it's finished.
Great! Thank you! I know coding it's difficult and lots of work

RomanOn
Posts: 10
Joined: Sat 07 Nov, 2015 6:29 am

Re: v11 released!

Post by RomanOn » Sun 17 Jul, 2016 6:08 am

omarsis81 wrote:Agreed, I'm running Windows 8.1 64 and and EGA works fine, Windows 10 should work too.
Try switching video output between Direct3D and DirectDraw

This is generic EGA, I would love to see more branded EGA cards like this VEGA's Video 7
http://www.recycledgoods.com/vega-isa-e ... -card.html
http://minuszerodegrees.net/manuals/Vid ... 201985.pdf
Ok, problem solved, i must choose Direct3D not Directdraw

RomanOn
Posts: 10
Joined: Sat 07 Nov, 2015 6:29 am

Re: v11 released!

Post by RomanOn » Sun 17 Jul, 2016 6:26 am

how difference is between hercules and hercules incolor? I have B&W both of them

User avatar
ender
Posts: 51
Joined: Tue 14 Oct, 2014 12:51 pm

Re: v11 released!

Post by ender » Sun 17 Jul, 2016 10:05 am

You'll need a program that supports InColor - there weren't that many of them.

vorob
Posts: 41
Joined: Wed 03 Aug, 2016 7:28 am

Re: v11 released!

Post by vorob » Thu 04 Aug, 2016 2:27 pm

Any explanation for % in titel bar? What does it mean?
https://pp.vk.me/c631929/v631929184/454 ... KNrBPI.jpg

I'm asking since it's always showing 98-101%, but if this means that my current CPU is fully emulated, its wrong since performance is far from good sometimes.

SA1988
Posts: 223
Joined: Wed 30 Apr, 2014 9:38 am

Re: v11 released!

Post by SA1988 » Thu 04 Aug, 2016 6:21 pm

That's the percentage speed of your guest.

vorob
Posts: 41
Joined: Wed 03 Aug, 2016 7:28 am

Re: v11 released!

Post by vorob » Thu 04 Aug, 2016 9:27 pm

Mmm and 100% means what? That emulator works at 100% or that i'm having real pentium 166?)

inukaze
Posts: 7
Joined: Sat 06 Aug, 2016 12:48 am

Re: v11 released!

Post by inukaze » Tue 01 Nov, 2016 3:36 pm

Hi there, i am under Debian Jessie Stable, i am trying to manual compile pcem v11. but i dont understand the follow :

Code: Select all

$ ./configure --prefix=/media/Compartido/Videojuegos/Emuroms/PC/PCEm/V11/Linux CFLAGS=-m32 CXXFLAGS=-m32 --build=x86_64-pc-linux-gnu --host=i686-pc-linux-gnu

$ make
Making all in src
make[1]: Entering directory '/media/Compartido/Linux/src/Videojuegos/Emuladores/PCEm/src'
source='386.c' object='pcem-386.o' libtool=no \
DEPDIR=.deps depmode=none /bin/bash ../depcomp \
gcc -DPACKAGE_NAME=\"PCem\" -DPACKAGE_TARNAME=\"pcem\" -DPACKAGE_VERSION=\"v10.1\" -DPACKAGE_STRING=\"PCem\ v10.1\" -DPACKAGE_BUGREPORT=\"Tom\ Walker\ \<tommowalker@tommowalker.co.uk\>\" -DPACKAGE_URL=\"\" -DPACKAGE=\"pcem\" -DVERSION=\"v10.1\" -DHAVE_LIBOPENAL=1 -DHAVE_LIBALUT=1 -DHAVE_LIBPTHREAD=1 -I.    -I/usr/include -msse2 -O3 -c -o pcem-386.o `test -f '386.c' || echo './'`386.c
/usr/share/automake-1.11/depcomp: No command.  Try '/usr/share/automake-1.11/depcomp --help' for more information.
Makefile:613: recipe for target 'pcem-386.o' failed
make[1]: *** [pcem-386.o] Error 1
make[1]: Leaving directory '/media/Compartido/Linux/src/Videojuegos/Emuladores/PCEm/src'
Makefile:247: recipe for target 'all-recursive' failed
make: *** [all-recursive] Error 1
I dont know if the problem it with automake or i need another option to force the compilation of 32 Bits under 64 Bits.
What i should do to compile it ???

inukaze
Posts: 7
Joined: Sat 06 Aug, 2016 12:48 am

Re: v11 released!

Post by inukaze » Tue 01 Nov, 2016 3:53 pm

inukaze wrote:Hi there, i am under Debian Jessie Stable, i am trying to manual compile pcem v11. but i dont understand the follow :

Code: Select all

$ ./configure --prefix=/media/Compartido/Videojuegos/Emuroms/PC/PCEm/V11/Linux CFLAGS=-m32 CXXFLAGS=-m32 --build=x86_64-pc-linux-gnu --host=i686-pc-linux-gnu

$ make
Making all in src
make[1]: Entering directory '/media/Compartido/Linux/src/Videojuegos/Emuladores/PCEm/src'
source='386.c' object='pcem-386.o' libtool=no \
DEPDIR=.deps depmode=none /bin/bash ../depcomp \
gcc -DPACKAGE_NAME=\"PCem\" -DPACKAGE_TARNAME=\"pcem\" -DPACKAGE_VERSION=\"v10.1\" -DPACKAGE_STRING=\"PCem\ v10.1\" -DPACKAGE_BUGREPORT=\"Tom\ Walker\ \<tommowalker@tommowalker.co.uk\>\" -DPACKAGE_URL=\"\" -DPACKAGE=\"pcem\" -DVERSION=\"v10.1\" -DHAVE_LIBOPENAL=1 -DHAVE_LIBALUT=1 -DHAVE_LIBPTHREAD=1 -I.    -I/usr/include -msse2 -O3 -c -o pcem-386.o `test -f '386.c' || echo './'`386.c
/usr/share/automake-1.11/depcomp: No command.  Try '/usr/share/automake-1.11/depcomp --help' for more information.
Makefile:613: recipe for target 'pcem-386.o' failed
make[1]: *** [pcem-386.o] Error 1
make[1]: Leaving directory '/media/Compartido/Linux/src/Videojuegos/Emuladores/PCEm/src'
Makefile:247: recipe for target 'all-recursive' failed
make: *** [all-recursive] Error 1
I dont know if the problem it with automake or i need another option to force the compilation of 32 Bits under 64 Bits.
What i should do to compile it ???
Forgot it, i see, the problem was, i extracted first with Peazip gtk , and after i use "chmod 777 -R *" in the src folder. and some files like depcomp and missing, not was a symbolic link , i extract it again from terminal . and now compile it :D xD

Some Tool for Modify the Configuration of PCEm v11 ? i need change it
Imagesubir imagenes

User avatar
SarahWalker
Site Admin
Posts: 1546
Joined: Thu 24 Apr, 2014 4:18 pm

Re: v11 released!

Post by SarahWalker » Tue 01 Nov, 2016 6:15 pm

CTRL-ALT-PAGE DOWN will show the menu, from which you can configure the emulator.

inukaze
Posts: 7
Joined: Sat 06 Aug, 2016 12:48 am

Re: v11 released!

Post by inukaze » Tue 01 Nov, 2016 7:38 pm

SarahWalker : Thank you very much, its was hard try to find a manually combination for configuration file, which not say "Configured romset not available." With that i hope configure properly much more faster.

vorob
Posts: 41
Joined: Wed 03 Aug, 2016 7:28 am

Re: v11 released!

Post by vorob » Wed 21 Dec, 2016 1:09 pm

Guys, im missing something? Any new versions since june? I saw SarahWalker is posting about new voodoo emulation, where can i get it?

User avatar
omarsis81
Posts: 623
Joined: Thu 17 Dec, 2015 6:20 pm

Re: v11 released!

Post by omarsis81 » Wed 21 Dec, 2016 1:26 pm

No new versions since June, but a v12 is due on Jan or Feb.
Maybe the new voodoo emulation you are talking about is Voodoo2. You can get it by compiling the latest build or, if you lack the knowledge to compile (like me) wait for the version 12 to get it

Post Reply