GUS and PCem 11 (BUG and/Or Feature request)

Support and general discussion.
Post Reply
Slother3x
Posts: 3
Joined: Thu 15 Oct, 2015 7:05 pm

GUS and PCem 11 (BUG and/Or Feature request)

Post by Slother3x » Fri 24 Jun, 2016 11:08 am

has anyone ever got past this part in the Gravis Ultrasound setup.

any other cpu setup the NMI procedure fails

is this a known issue?

i would love to be able to hear the words "SBOS installed" one last time before i die.

and this is the closest i ever got to it working.
Attachments
screenshot.gif
screenshot.gif (118.66 KiB) Viewed 1391 times

ndavis82
Posts: 46
Joined: Sun 25 Dec, 2016 5:54 am

Re: GUS and PCem 11 (BUG and/Or Feature request)

Post by ndavis82 » Sat 22 Jul, 2017 6:15 pm

I'm having the same issue even in version 12. Is there a workaround?

Fenix77
Posts: 69
Joined: Fri 01 Sep, 2017 11:59 am

Re: GUS and PCem 11 (BUG and/Or Feature request)

Post by Fenix77 » Thu 21 Dec, 2017 2:10 am

Hello

Sorry for reviving this old thread. I tested it in the released v13.

I recently found that the Lock up of the emulator is produced in the setup utility when test the Roland/Sound Blaster emulation and is EMM386 loaded In Memory.


MegaEM 2.07 included the Gravis v4.11 drivers will work, SBOS will lock up the emulator too when EMM386 is loaded. but Mega-EM 3.x ( which embeds MegaEM 2.x, SBOS and UltraMID) which requires both EMS memory (provided by EMM386/QEMM/386MAX) and NMI support will lock up PCEM too.

Games and compatibility

I know that SBOS and MegaEm where buggy back in the day, and they will not work in 32 bit protected mode anyway, and some games will not sound like in the real SB/Roland hardware, but strangely enought some games from 1993-94 era (The Incredible Machine II) work perfectly with MegaEM in PCEM v12 (not tested v13) and the sound is very close to the original except in some notes in the other hand the TIM 1 will lock up with either SBOS or MegaEM.
Tetris Classic from 1992 will not sound right with MegaEm, however it works.
It thinks the programmers, back in its day, knew that their game was going to be played by GUS users, so some of them were more compatible and accurate.

Prince of Persia v1.3 (v13 and older) work perfectly with SBOS until Prince open the door to Level 2 the door opening can be heard and the game locks up, additionally I have specified the emulated BLASTER port environment as 240 (the same as Gravis) in autoexec.bat to hear the same sound effects as SB 1.0 ad the music is very close to the original SB 1.0. Otherwise it sounds like MT-32 but without Control and CM rom files.(ugly)

I don't know for sure but It think there is a problem might be with EMM386 or SBOS because:

a. It enables the Virtual 8086 mode or
b. There is a conflict inthe use of UMB memory regions. or
C. The SBOS itself and PCEM, because in PoP i run the game whitout EMS or EMM386 loaded in memory but using the the the Same port 240 for GUS and BLASTER emulation.

Post Reply