IBM PS/2 Model 55SX can't boot from ESDI hard disk

Support and general discussion.
User avatar
ppgrainbow
Posts: 402
Joined: Thu 04 Sep, 2014 7:03 am
Contact:

IBM PS/2 Model 55SX can't boot from ESDI hard disk

Postby ppgrainbow » Mon 15 May, 2017 3:43 am

I'm having a problem with the emulated IBM PS/2 Model 55SX is that I can't boot from the ESDI hard disk. Instead, the emulated machine goes to ROM BASIC:

PS2M55SX_ROM_BASIC.png
PS2M55SX_ROM_BASIC.png (9.13 KiB) Viewed 578 times

I have the IBM ESDI Fixed Disk Adapter enabled and the hard disk geometry for the boot drive is 615 cylinders, 8 heads and 34 sectors per track for a total of 81 MB. ESDI hard disk that have 34 sectors per track are common.

I configured the PS/2 Model 55SX with Reference Diskette and the machine booted without any errors. I even included the English language version of the ESDI Fixed Disk Adapter by commenting in the memory locations of the adapter itself prior to setting up MS-DOS 4.01, partitioning/formatting the OS and then installing the OS.

I'm wondering if the 55SX is screwed up or I mis-configured the machine itself.

Are you able to reproduce the issue on the emulated PS/2 Model 55SX? I honestly can't find any PS/2 Model 55SX floppy disk boot images anywhere.

I bet that the inability to boot from the ESDI hard disk also affects the emulated IBM PS/2 Model 50 and IBM PS/2 Model 80 as well, but those machines have not been tested at this time.
vbdasc
Posts: 25
Joined: Tue 21 Mar, 2017 10:53 am

Re: IBM PS/2 Model 55SX can't boot from ESDI hard disk

Postby vbdasc » Mon 15 May, 2017 6:59 am

> I bet that the inability to boot from the ESDI hard disk also affects the emulated IBM PS/2 Model 50 and IBM PS/2 Model 80 as well, but those machines have not been tested at this time.

Note that the ESDI controller in model 80 is very different and incompatible with that in models 50 and 55.
User avatar
ppgrainbow
Posts: 402
Joined: Thu 04 Sep, 2014 7:03 am
Contact:

Re: IBM PS/2 Model 55SX can't boot from ESDI hard disk

Postby ppgrainbow » Mon 15 May, 2017 7:26 am

vbdasc wrote:> I bet that the inability to boot from the ESDI hard disk also affects the emulated IBM PS/2 Model 50 and IBM PS/2 Model 80 as well, but those machines have not been tested at this time.

Note that the ESDI controller in model 80 is very different and incompatible with that in models 50 and 55.

Eep! I didn't know that the ESDI controller is incompatible with the Model 50 and Model 55! :(

In PCem, the only options available for the Mode 50 and Model 55SX are the IBM ESDI Fixed Disk Controller or none. This issue needs to be addressed somehow.

The Wikipedia article on the PS/2 states that the Model 55SX has support for the ESDI controller while the Model 50 doesn't. The Model 50 has to rely on HDD controllers other than ESDI.
vbdasc
Posts: 25
Joined: Tue 21 Mar, 2017 10:53 am

Re: IBM PS/2 Model 55SX can't boot from ESDI hard disk

Postby vbdasc » Mon 15 May, 2017 9:38 am

ppgrainbow wrote:The Wikipedia article on the PS/2 states that the Model 55SX has support for the ESDI controller while the Model 50 doesn't. The Model 50 has to rely on HDD controllers other than ESDI.


IMHO, if Wikipedia says that, then it's wrong on this one. AFAIK, both model 50 and 55 (and 70) can support "IBM ESDI" DBA disks which are not really ESDI at all, but have ESDI-like integrated controllers communicating directly with the MCA bus. By the way, these disks came later; that's the reason why model 50 came originally with a MFM disk (unfortunately, not documented enough to support it in any emulator).

P.S. Models 60/65/80 support a true ESDI controller for the 16-bit MCA bus.
User avatar
ppgrainbow
Posts: 402
Joined: Thu 04 Sep, 2014 7:03 am
Contact:

Re: IBM PS/2 Model 55SX can't boot from ESDI hard disk

Postby ppgrainbow » Mon 15 May, 2017 4:06 pm

vbdasc wrote:
ppgrainbow wrote:The Wikipedia article on the PS/2 states that the Model 55SX has support for the ESDI controller while the Model 50 doesn't. The Model 50 has to rely on HDD controllers other than ESDI.


IMHO, if Wikipedia says that, then it's wrong on this one. AFAIK, both model 50 and 55 (and 70) can support "IBM ESDI" DBA disks which are not really ESDI at all, but have ESDI-like integrated controllers communicating directly with the MCA bus. By the way, these disks came later; that's the reason why model 50 came originally with a MFM disk (unfortunately, not documented enough to support it in any emulator).

P.S. Models 60/65/80 support a true ESDI controller for the 16-bit MCA bus.

It looks like that the Model 55SX is gonna either have to rely on the ESDI-like integrated controllers communicating directly with the MCA bus or rely on XTIDE. As for the Model 50, it somehow needs support for either the MFM controller or XTIDE.
SarahWalker
Site Admin
Posts: 1311
Joined: Thu 24 Apr, 2014 4:18 pm

Re: IBM PS/2 Model 55SX can't boot from ESDI hard disk

Postby SarahWalker » Mon 15 May, 2017 5:00 pm

Have you tried configuring with the @ddff.adf file in the PS/2 resources thread, with no changes?
SarahWalker
Site Admin
Posts: 1311
Joined: Thu 24 Apr, 2014 4:18 pm

Re: IBM PS/2 Model 55SX can't boot from ESDI hard disk

Postby SarahWalker » Mon 15 May, 2017 5:26 pm

Hang on, I remember this now. There's a bit in the CMOS RAM of the 55SX that prevents it from booting from hard disc, and isn't exposed through the reference disc. I've committed default NVR files for all of the PS/2 models in rev 718 - use the file in that commit as a starting point and it should work.
User avatar
ppgrainbow
Posts: 402
Joined: Thu 04 Sep, 2014 7:03 am
Contact:

Re: IBM PS/2 Model 55SX can't boot from ESDI hard disk

Postby ppgrainbow » Mon 15 May, 2017 6:08 pm

SarahWalker wrote:Hang on, I remember this now. There's a bit in the CMOS RAM of the 55SX that prevents it from booting from hard disc, and isn't exposed through the reference disc. I've committed default NVR files for all of the PS/2 models in rev 718 - use the file in that commit as a starting point and it should work.

Thank you so much for the help! :)

By the way, do you have any idea which bit in the CMOS RAM of the Model 55SX that prevents it from booting from the hard disk?

Update: Problem solved! I used the Reference Disk for the Model 55SX to configure and the emulated machine can finally boot from the hard disk! :)

Return to “General”

Who is online

Users browsing this forum: Bing [Bot] and 6 guests