Awards do not detect floppies

Support and general discussion.
Katakis
Posts: 67
Joined: Thu 05 Mar, 2015 6:42 am

Awards do not detect floppies

Postby Katakis » Tue 16 May, 2017 1:10 pm

On the Award 430VX PCI and Award SiS 496/497 machines, the floppy drives are not detected. I have tested five other machines (WinBIOS 486, AMI 486 clone, Mr. 386DX, Acer 386SX25/N, and Amstrad MegaPC) so I assume that non-Award ones are fine. I have no idea what's cause this, but I think that it was triggered when I switched between CPU types on the same machine.

https://www.youtube.com/watch?v=BUY5mEEUyoA
User avatar
omarsis81
Posts: 545
Joined: Thu 17 Dec, 2015 6:20 pm

Re: Awards do not detect floppies

Postby omarsis81 » Tue 16 May, 2017 3:19 pm

Try with only 1.44 MB
I described similar bug not long ago
viewtopic.php?p=4983#p4983
Battler
Posts: 793
Joined: Sun 06 Jul, 2014 7:05 pm

Re: Awards do not detect floppies

Postby Battler » Tue 16 May, 2017 3:19 pm

Known bug with the SiS 496/497 BIOS used by PCem, which is revision 1, as well as a few other Award BIOS'es. For some reason, it expects a 720k drive to be 40-track instead of the correct 80. For the SiS 496/497, revision 3 of the BIOS fixes the problem.
User avatar
omarsis81
Posts: 545
Joined: Thu 17 Dec, 2015 6:20 pm

Re: Awards do not detect floppies

Postby omarsis81 » Tue 16 May, 2017 3:22 pm

So is a BIOS bug? Nice discovery Battler!
Katakis
Posts: 67
Joined: Thu 05 Mar, 2015 6:42 am

Re: Awards do not detect floppies

Postby Katakis » Wed 17 May, 2017 1:19 pm

omarsis81 wrote:Try with only 1.44 MB
I described similar bug not long ago
http://pcem-emulator.co.uk/phpBB3/viewt ... 4983#p4983


Both of them worked again, thanks!

Return to “General”

Who is online

Users browsing this forum: No registered users and 2 guests