PCem crash PS/2 model 55SX ESDI drive

Support and general discussion.
altheos
Posts: 37
Joined: Wed 24 Feb, 2016 7:27 pm

PCem crash PS/2 model 55SX ESDI drive

Postby altheos » Mon 12 Jun, 2017 10:11 am

Hello,

It seems that PCem (latest version compiled) crashes on 55SX model. PClog content is : "Write sector buffer count 0036"
I know that pgrainbow could boot on ESDI drive with the right nvr file but I can't. Config I use : PS/2 Model 55SX, I386SX 16, 4 Mb RAM, IBM ESDI fixed disk adapter MCA, Drive A 3.5 1.44, Mouse 2 button PS/2, HDD RLL/ESDI (34 sectors, 5 heads, 1024 cylinders).

Also, the reference disk prompt for a conflict with ESDI adapter : it's probably because 55SX use "IBM integrated harddisk adapter" card ID DF9F (http://ps-2.kev009.com/ohland-old/misc/ESDI.html).

Can someone confirm this ?
SarahWalker
Site Admin
Posts: 1314
Joined: Thu 24 Apr, 2014 4:18 pm

Re: PCem crash PS/2 model 55SX ESDI drive

Postby SarahWalker » Mon 12 Jun, 2017 5:31 pm

I can't reproduce this. Maybe you're using a different BIOS to me?

In any case, in rev 763 I've increased the ESDI sector buffer size, so this error shouldn't happen anymore. Can you give that a try?
altheos
Posts: 37
Joined: Wed 24 Feb, 2016 7:27 pm

Re: PCem crash PS/2 model 55SX ESDI drive

Postby altheos » Tue 13 Jun, 2017 8:58 am

Ok, thanks Sarah.
PCem is no more crashing in rev763.
But, conflict is still there and RLL/ESDI is unbootable even with the right nvr file.

I use BIOS PN 33F8152 (11/02/88), model F8, Submodel C, Revision Level 0, Ref Disc 1.05. Which version do you have ?
Attachments
Cap1.PNG
Cap1.PNG (11.82 KiB) Viewed 482 times
SarahWalker
Site Admin
Posts: 1314
Joined: Thu 24 Apr, 2014 4:18 pm

Re: PCem crash PS/2 model 55SX ESDI drive

Postby SarahWalker » Tue 13 Jun, 2017 4:50 pm

Please try with the @DDFF.ADF file attached in http://pcem-emulator.co.uk/phpBB3/viewtopic.php?f=3&t=676. The default one is known not to work.
altheos
Posts: 37
Joined: Wed 24 Feb, 2016 7:27 pm

Re: PCem crash PS/2 model 55SX ESDI drive

Postby altheos » Wed 14 Jun, 2017 11:24 am

Sorry, i forgot that ;) It works flawlessly now with the right ADF and NVR files. Thanks !

Return to “General”

Who is online

Users browsing this forum: Bing [Bot] and 3 guests