Compile error (sound.c)

Support and general discussion.
BoisterousSleet75
Posts: 32
Joined: Fri 11 Aug, 2017 3:06 am
Contact:

Compile error (sound.c)

Postby BoisterousSleet75 » Sat 14 Oct, 2017 12:44 am

Hi,

I've trying to compile PCem rev 887 (with wxWidgets and Networking) using MSYS2, but it gaves me an error:

Code: Select all

gcc 386.o 386_dynarec.o 386_dynarec_ops.o 808x.o acer386sx.o ali1429.o amstrad.o cbm_io.o cdrom-ioctl.o cdrom-image.o codegen.o codegen_ops.o codegen_timing_486.o codegen_timing_686.o codegen_timing_common.o codegen_timing_pentium.o codegen_timing_winchip.o codegen_x86.o compaq.o config.o cpu.o device.o dells200.o disc.o disc_fdi.o disc_img.o disc_sector.o dma.o esdi_at.o fdc.o fdc37c665.o fdd.o fdi2raw.o gameport.o hdd.o hdd_esdi.o hdd_file.o headland.o i430lx.o i430fx.o i430vx.o ide.o intel.o intel_flash.o io.o jim.o joystick_ch_flightstick_pro.o joystick_standard.o joystick_sw_pad.o joystick_tm_fcs.o keyboard.o keyboard_amstrad.o keyboard_at.o keyboard_olim24.o keyboard_pcjr.o keyboard_xt.o laserxt.o lpt.o lpt_dac.o lpt_dss.o mca.o mcr.o mem.o mfm_at.o mfm_xebec.o model.o mouse.o mouse_msystems.o mouse_ps2.o mouse_serial.o neat.o nmi.o nvr.o olivetti_m24.o opti495.o paths.o pc.o pci.o pic.o piix.o pit.o ppi.o ps1.o ps2.o ps2_mca.o ps2_nvr.o rom.o rtc.o scat.o scsi.o scsi_53c400.o scsi_aha1540.o scsi_cd.o scsi_hd.o serial.o sio.o sis496.o sound.o sound_ad1848.o sound_adlib.o sound_adlibgold.o sound_cms.o sound_dbopl.o sound_emu8k.o sound_gus.o sound_mpu401_uart.o sound_opl.o sound_pas16.o sound_ps1.o sound_pssj.o sound_resid.o sound_sb.o sound_sb_dsp.o sound_sn76489.o sound_speaker.o sound_ssi2001.o sound_wss.o sound_ym7128.o soundopenal.o tandy_eeprom.o tandy_rom.o timer.o um8881f.o um8669f.o vid_ati_eeprom.o vid_ati_mach64.o vid_ati18800.o vid_ati28800.o vid_ati68860_ramdac.o vid_cga.o vid_cl5429.o vid_colorplus.o vid_ega.o vid_et4000.o vid_et4000w32.o vid_et4000w32i.o vid_genius.o vid_hercules.o vid_icd2061.o vid_ics2595.o vid_incolor.o vid_mda.o vid_olivetti_m24.o vid_oti067.o vid_paradise.o vid_pc1512.o vid_pc1640.o vid_pc200.o vid_pcjr.o vid_ps1_svga.o vid_s3.o vid_s3_virge.o vid_sdac_ramdac.o vid_stg_ramdac.o vid_svga.o vid_svga_render.o vid_tandy.o vid_tandysl.o vid_tgui9440.o vid_tkd8001_ramdac.o vid_tvga.o vid_unk_ramdac.o vid_vga.o vid_voodoo.o vid_wy700.o video.o wd76c10.o x86seg.o x87.o xtide.o win-midi.o wx-main.o wx-config_sel.o wx-dialogbox.o wx-utils.o wx-app.o wx-sdl2-joystick.o wx-sdl2-mouse.o wx-sdl2-keyboard.o wx-sdl2-video.o wx-sdl2.o wx-config.o wx-deviceconfig.o wx-hostconfig.o wx-status.o wx-sdl2-status.o wx-resources.o wx-thread.o wx-common.o wx-sdl2-display-win.o wx-sdl2-video-renderer.o wx-sdl2-video-gl3.o wx-glslp-parser.o wx-shader_man.o wx-shaderconfig.o wx-joystickconfig.o wx.res cdrom_image.o dbopl.o nukedopl.o vid_cga_comp.o convolve.o convolve-sse.o envelope.o extfilt.o filter.o pot.o sid.o voice.o wave6581__ST.o wave6581_P_T.o wave6581_PS_.o wave6581_PST.o wave8580__ST.o wave8580_P_T.o wave8580_PS_.o wave8580_PST.o wave.o ne2000.o nethandler.o slirp/libslirp.a -o "PCem-wx-SDL2.exe" -LD:/msys64/mingw32/lib   -pipe -Wl,--subsystem,windows -mwindows -lwx_mswu_xrc-3.0 -lwx_mswu_webview-3.0 -lwx_mswu_html-3.0 -lwx_mswu_qa-3.0 -lwx_mswu_adv-3.0 -lwx_mswu_core-3.0 -lwx_baseu_xml-3.0 -lwx_baseu_net-3.0 -lwx_baseu-3.0  -mthreads -ltiff -ljpeg -lpng -lz -lregex -lexpat -lkernel32 -lcomdlg32 -lwinspool -lcomctl32 -lole32 -loleaut32 -luuid -lrpcrt4 -ladvapi32 -lmingw32 -lopengl32 -lopenal -lstdc++ -lSDL2main -lSDL2 -lm -ldinput8 -ldxguid -ldxerr8 -luser32 -lgdi32 -lwinmm -limm32 -lole32 -loleaut32 -lshell32 -lversion -luuid -static-libgcc -lwsock32 -liphlpapi
sound.o:sound.c:(.data+0x5dc): undefined reference to `es1371_device'
sound.o:sound.c:(.data+0x638): undefined reference to `es1371_device'
collect2.exe: error: ld returned 1 exit status
make: *** [Makefile.msys2-wx-sdl2-network:34: PCem-wx-SDL2.exe] Error 1


Is this Typo or something else?

Thanks.
aka "bsleet75"
shermanp
Posts: 14
Joined: Sat 18 Feb, 2017 2:09 am

Re: Compile error (sound.c)

Postby shermanp » Sat 14 Oct, 2017 2:10 am

Sarah just added a new sound device, and the MSYS2 makefiles have not been changed (as Sarah doesn't (yet) have anything to do with those.

In the OBJ portion of the makefile, add 'sound_audiopci.o' after 'sound_adlibgold.o'. That should work, judging by what Sarah added to the mingw makefiles.

I will update the MSYS2 makefile and edit my original post.

EDIT: Made a mistake, need to add '.o' file, not '.c'
BoisterousSleet75
Posts: 32
Joined: Fri 11 Aug, 2017 3:06 am
Contact:

Re: Compile error (sound.c)

Postby BoisterousSleet75 » Sat 14 Oct, 2017 2:39 am

shermanp wrote:Sarah just added a new sound device, and the MSYS2 makefiles have not been changed (as Sarah doesn't (yet) have anything to do with those.

In the OBJ portion of the makefile, add 'sound_audiopci.o' after 'sound_adlibgold.o'. That should work, judging by what Sarah added to the mingw makefiles.

I will update the MSYS2 makefile and edit my original post.

EDIT: Made a mistake, need to add '.o' file, not '.c'

Okay. Thanks.
aka "bsleet75"

Return to “General”

Who is online

Users browsing this forum: Bing [Bot] and 3 guests