AudioPCI impressions

Support and general discussion.
User avatar
leilei
Posts: 436
Joined: Fri 25 Apr, 2014 4:47 pm

AudioPCI impressions

Postby leilei » Sat 14 Oct, 2017 3:10 am

Just checking the new AudioPCI and it's impressive so far. Testing SB PCI 128

-Windows ME's WDM drivers makes PCem quit after a reboot and doesn't have any sound
-Creative's WDM driver has no sound either
- VXD drivers work in Win98SE
-With Creative's SB 128 drivers (dated to 2000) SBLEGACY causes a freeze and prevents bootup for the rest of the running PCem session
- Noticeable crackling in the sound, under both dos and Windows
- EAX works in Half-Life!

AudioPCI bugs that are not emulation bugs:

- The FM->ECW OPL2 emulation of the dos/legacy drivers seems to work properly (this is a guilty pleasure and i'm happy pcem preserves this). I'm listing this here because it's supposed to sound wrong (as it doesn't have a OPL2/3 chip or even a clone of said chip)
- Duke Nukem 3D crashes appropriately in echo areas (there's old patches for the affected games to turn this effect off for this card and the related SB Live series). To immediately test this, run duke3d.exe /l5
SarahWalker
Site Admin
Posts: 1333
Joined: Thu 24 Apr, 2014 4:18 pm

Re: AudioPCI impressions

Postby SarahWalker » Sat 14 Oct, 2017 10:55 am

Rev 888 fixes the Windows ME issues.
User avatar
leilei
Posts: 436
Joined: Fri 25 Apr, 2014 4:47 pm

Re: AudioPCI impressions

Postby leilei » Sat 14 Oct, 2017 11:33 pm

Thanks, it works now. :)


also out of curiosity I tried to install June 97 Ensoniq AudioPCI drivers on 1371 and it failed to detect. That's 1370 it wants i'm guessing.

EDIT: Boredom had lead to hacking in ES1370 and had no sound and the dos driver gets upset over the revision id being out of date (despite being the 0x00 it's looking for. Qemu's ES1370 also has this behavior). heh. 1370's wildly different anyway (44khz, no ac'97 compliance, etc)

EDIT2: Another bug that isn't an emulation bug but should be mentioned anyway are Epic's games (the ones with the mod soundtracks - Jazz, OMF2097, Extreme Pinball, etc. ) all have speed issues with the sound. This is actual behavior, and a partial remedy is to use a newer WDM driver.

Return to “General”

Who is online

Users browsing this forum: Bing [Bot], SarahWalker and 3 guests