Adlib Gold Midi not working

Support and general discussion.
Fenix77
Posts: 30
Joined: Fri 01 Sep, 2017 11:59 am

Adlib Gold Midi not working

Postby Fenix77 » Wed 18 Oct, 2017 2:11 am

Hello!

Firs i must say it's great to have the Adlib Gold emulation for historic reasons and to hear Dune II with the Surround Module and also play music and some games in Win 3.x.

I found a bug with the Adlib Gold emulation. (I know very few games support this card).
In the released PCEM v12 the Adlib gold works ok, with Dune II and The Lost Vikings (the only games i know that support the Adlib Gold), and the JukeBox works perfectly.
But the problem is when i try to play a midi file in both the Adlib Gold test program and when i select "Gold Midi" in the MIDI mapper in Win 3.1 ( i found the drivers).
It does not play any music when i open a midi file and in some cases can lock-up the emulated machine.
If i select "Gold Synth" it works but when i play a midi file it sound choppy.

In the last SVN the Jukebox cannot be heard

PD: I used the same hard disk image, with both PCEM versions, last SVN and v12. The hard disk has DOS and Windows 3.1 drivers installed.
The Windows is in spanish but i added it to clarify the issue.


Thanks in advence!
Attachments
Adlib Gold.png
If i select "Gold MIDI" in will not play any music if i try to play a midi file.
Adlib Gold.png (85.02 KiB) Viewed 151 times
SarahWalker
Site Admin
Posts: 1317
Joined: Thu 24 Apr, 2014 4:18 pm

Re: Adlib Gold Midi not working

Postby SarahWalker » Wed 18 Oct, 2017 5:06 pm

External MIDI on the Adlib Gold isn't implemented currently I'm afraid - only the internal synth.

Return to “General”

Who is online

Users browsing this forum: andr25352, Bing [Bot] and 4 guests