CD Audio re-activated.

Discussion of development and patch submission.
SA1988
Posts: 204
Joined: Wed 30 Apr, 2014 9:38 am

CD Audio re-activated.

Postby SA1988 » Tue 02 Dec, 2014 7:36 pm

Here's the patch.

https://mega.co.nz/#!ARFXHQKa!XdnpkVcVYa489jSRYJdL5lqun0QT1jt6g3Ha6aS-93A

Note: ignore the network adapter stuff I put, the important ones are in the following sections of the patch:

Code: Select all

@@ -238,6 +240,19 @@ void initpc()


Code: Select all

@@ -542,7 +546,6 @@ int WINAPI WinMain (HINSTANCE hThisInsta
SarahWalker
Site Admin
Posts: 1325
Joined: Thu 24 Apr, 2014 4:18 pm

Re: CD Audio re-activated.

Postby SarahWalker » Tue 02 Dec, 2014 9:28 pm

I'm pretty certain that patch will break the Advanced/EV system - have you tested that? It will most likely be complaining of NVRAM checksum issues.

Incidentally, there is a lot to be said for having your changes in separate checkouts. Mainly that it means that other people don't have to edit your patches to get to the changes they want.

Also, you should be able to attach patches to your posts instead of relying on those download sites.
SA1988
Posts: 204
Joined: Wed 30 Apr, 2014 9:38 am

Re: CD Audio re-activated.

Postby SA1988 » Tue 02 Dec, 2014 9:53 pm

well yes, I forgot, I have tested it on the Award 430VX, AMI 486 clones as well as the Award 486 one (Award 496/497), IBM AT (interpreter), AMI 286 and others (including AMI 386) and cdaudio is re-enabled.

With this patch, I don't encounter any checksum errors in the Advanced/EV machine.

Return to “Development”

Who is online

Users browsing this forum: No registered users and 3 guests