PCem v15: 8086 running at the same speed as 8088

Discussion of development and patch submission.
Post Reply
Mills
Posts: 14
Joined: Thu 28 Sep, 2017 9:29 pm

PCem v15: 8086 running at the same speed as 8088

Post by Mills » Wed 31 Jul, 2019 3:38 pm

Hi!.

First of all thanks for improving PCem :).

I was testing PCem v15 and noticed 8088 and 8086 machines are running at the same speed (lm20 benchmark showed 4.7 MHz on an 8086 8Mhz).

Hope this is a mistake I made.

Thanks!

EDIT: I tested several roms for 8086 machines, VTech Laser XT3 seems to fail, other 8086 machines are running as expected.

User avatar
omarsis81
Posts: 718
Joined: Thu 17 Dec, 2015 6:20 pm

Re: PCem v15: 8086 running at the same speed as 8088

Post by omarsis81 » Wed 31 Jul, 2019 7:21 pm

You mean this? I bet is real behavior... I don't own a real Laser computer to test it though
Attachments
laser.jpg
laser.jpg (89.36 KiB) Viewed 2076 times

Mills
Posts: 14
Joined: Thu 28 Sep, 2017 9:29 pm

Re: PCem v15: 8086 running at the same speed as 8088

Post by Mills » Thu 01 Aug, 2019 9:12 am

Yes... But It was also very slow in other programs and games, then I checked other 8086 machines and it worked faster.

User avatar
SarahWalker
Site Admin
Posts: 1722
Joined: Thu 24 Apr, 2014 4:18 pm

Re: PCem v15: 8086 running at the same speed as 8088

Post by SarahWalker » Sat 03 Aug, 2019 8:31 am

The VTech machines boot with turbo off. Press CTRL+8 after boot to speed them up.

Mills
Posts: 14
Joined: Thu 28 Sep, 2017 9:29 pm

Re: PCem v15: 8086 running at the same speed as 8088

Post by Mills » Mon 05 Aug, 2019 12:40 am

SarahWalker wrote:
Sat 03 Aug, 2019 8:31 am
The VTech machines boot with turbo off. Press CTRL+8 after boot to speed them up.
I was testing some homebrew I'm making to work on 8088 8086 and I was confused.

Thanks a lot. :D

Post Reply