Regression of PCem 12 - 430vx does not boot

Discussion of development and patch submission.
Jeditobe
Posts: 26
Joined: Thu 19 May, 2016 10:47 am

Regression of PCem 12 - 430vx does not boot

Postby Jeditobe » Sun 09 Apr, 2017 9:21 pm

Regression of PCem 12 - 430vx does not boot. Only two beeps and black screen.

On PCem 11 430vx boots ok with the same bios file.
User avatar
ppgrainbow
Posts: 402
Joined: Thu 04 Sep, 2014 7:03 am
Contact:

Re: Regression of PCem 12 - 430vx does not boot

Postby ppgrainbow » Sun 09 Apr, 2017 10:34 pm

Do you have any idea what revision of PCem v12 you are using? The Award 430VX does work on the original release of PCem v12.

Since I don't have the later revision, I can't reproduce this issue.
Jeditobe
Posts: 26
Joined: Thu 19 May, 2016 10:47 am

Re: Regression of PCem 12 - 430vx does not boot

Postby Jeditobe » Mon 10 Apr, 2017 12:16 pm

PCem v12 from pcem-emulator.co.uk. I downloaded it yesterday.
User avatar
omarsis81
Posts: 543
Joined: Thu 17 Dec, 2015 6:20 pm

Re: Regression of PCem 12 - 430vx does not boot

Postby omarsis81 » Mon 10 Apr, 2017 12:32 pm

Jeditobe wrote:PCem v12 from pcem-emulator.co.uk. I downloaded it yesterday.


I can assure you, stock PCem 12 does boot 430vx.
Hmm, are you using the same video card as PCem11?
Jeditobe
Posts: 26
Joined: Thu 19 May, 2016 10:47 am

Re: Regression of PCem 12 - 430vx does not boot

Postby Jeditobe » Mon 10 Apr, 2017 2:04 pm

All configs were 100% the same
Jeditobe
Posts: 26
Joined: Thu 19 May, 2016 10:47 am

Re: Regression of PCem 12 - 430vx does not boot

Postby Jeditobe » Mon 10 Apr, 2017 2:05 pm

omarsis81 wrote:
Jeditobe wrote:PCem v12 from pcem-emulator.co.uk. I downloaded it yesterday.


I can assure you, stock PCem 12 does boot 430vx.


Maybe for you but not for all ppl.
User avatar
omarsis81
Posts: 543
Joined: Thu 17 Dec, 2015 6:20 pm

Re: Regression of PCem 12 - 430vx does not boot

Postby omarsis81 » Mon 10 Apr, 2017 2:14 pm

Do the rest of the motherboards work?
Jeditobe
Posts: 26
Joined: Thu 19 May, 2016 10:47 am

Re: Regression of PCem 12 - 430vx does not boot

Postby Jeditobe » Mon 10 Apr, 2017 2:21 pm

yes. Problem only with 430vx.
SarahWalker
Site Admin
Posts: 1326
Joined: Thu 24 Apr, 2014 4:18 pm

Re: Regression of PCem 12 - 430vx does not boot

Postby SarahWalker » Mon 10 Apr, 2017 5:19 pm

Please post your pcem.cfg.
Jeditobe
Posts: 26
Joined: Thu 19 May, 2016 10:47 am

Re: Regression of PCem 12 - 430vx does not boot

Postby Jeditobe » Mon 10 Apr, 2017 8:55 pm

Code: Select all

gameblaster = 0
gus = 0
ssi2001 = 0
voodoo = 0
model = 39
cpu_manufacturer = 0
cpu = 17
cpu_use_dynarec = 1
cpu_waitstates = 0
gfxcard = 17
video_speed = 5
sndcard = 0
cpu_speed = 24
has_fpu = 1
disc_a =
disc_b =
mem_size = 262144
cdrom_drive = 200
cdrom_enabled = 1
cdrom_channel = 0
cdrom_path = C:\reactos\output-MinGW-i386\livecd.iso
vid_resize = 0
vid_api = 1
video_fullscreen_scale = 0
video_fullscreen_first = 1
hdc_sectors = 0
hdc_heads = 0
hdc_cylinders = 0
hdc_fn =
hdd_sectors = 63
hdd_heads = 16
hdd_cylinders = 1204
hdd_fn = D:\downloads\PCemV12Win\21
hde_sectors = 0
hde_heads = 0
hde_cylinders = 0
hde_fn =
hdf_sectors = 0
hdf_heads = 0
hdf_cylinders = 0
hdf_fn =
drive_a_type = 0
drive_b_type = 0
window_w = 0
window_h = 0
window_x = 0
window_y = 0
window_remember = 0
joystick_type = 0
mouse_type = 1
enable_sync = 0

[Joysticks]
joystick_0_nr = 0
joystick_1_nr = 0

[CGA]
display_type = 0
composite_type = 1
snow_enabled = 1

[Diamond Stealth 3D 2000 (S3 ViRGE)]
memory = 2
bilinear = 1
dithering = 1

[S3 ViRGE/DX]
memory = 2
bilinear = 1
dithering = 1
ZoltanTheHun
Posts: 3
Joined: Sun 19 Feb, 2017 9:57 pm

Re: Regression of PCem 12 - 430vx does not boot

Postby ZoltanTheHun » Mon 10 Apr, 2017 10:41 pm

I had similar issues the other day.

First I deleted the flash.bin file, but this did not work. Then I removed all HDDs, removed sound card, Voodoo, and I used a very basic VGA card and tried to select sensible defaults wherever possible.
After this I readded everything and it works flawlessly. I seemed to start working when I removed the SB16, but I am not 100% percent sure, and it works now with SB16.
User avatar
leilei
Posts: 432
Joined: Fri 25 Apr, 2014 4:47 pm

Re: Regression of PCem 12 - 430vx does not boot

Postby leilei » Mon 10 Apr, 2017 11:05 pm

model = 39
gfxcard = 17


As PCem switched to strings it doesn't parse these numbers anymore.
Change the 39 to 430vx
User avatar
omarsis81
Posts: 543
Joined: Thu 17 Dec, 2015 6:20 pm

Re: Regression of PCem 12 - 430vx does not boot

Postby omarsis81 » Tue 11 Apr, 2017 1:14 am

But that changed after the v12 was released...
Battler
Posts: 793
Joined: Sun 06 Jul, 2014 7:05 pm

Re: Regression of PCem 12 - 430vx does not boot

Postby Battler » Tue 11 Apr, 2017 10:51 pm

But model numbers did get shifted in v12 because some models were added and some removed/commented out, so the Award 430VX PCI's number is most probably not 39 anymore.
SarahWalker
Site Admin
Posts: 1326
Joined: Thu 24 Apr, 2014 4:18 pm

Re: Regression of PCem 12 - 430vx does not boot

Postby SarahWalker » Wed 12 Apr, 2017 5:14 pm

Indeed. This is what Jeditobe's config specifies under v12 :
badconfig.png
badconfig.png (33.08 KiB) Viewed 1033 times

Notice the lack of a CPU...
Jeditobe
Posts: 26
Joined: Thu 19 May, 2016 10:47 am

Re: Regression of PCem 12 - 430vx does not boot

Postby Jeditobe » Thu 13 Apr, 2017 11:19 am

but for mee it looks like
Image

No empty processor.
Jeditobe
Posts: 26
Joined: Thu 19 May, 2016 10:47 am

Re: Regression of PCem 12 - 430vx does not boot

Postby Jeditobe » Fri 28 Apr, 2017 10:05 am

ping

Return to “Development”

Who is online

Users browsing this forum: jznomoney and 3 guests