[Bug] Voodoo recompiler on Linux 64-bit

Discussion of development and patch submission.
bit
Posts: 98
Joined: Sun 19 Mar, 2017 7:04 pm

[Bug] Voodoo recompiler on Linux 64-bit

Postby bit » Tue 11 Apr, 2017 6:22 pm

There seems to be an issue with the Voodoo recompiler that is related to texturing.
When testing glQuake the emulator crashes with a Segmentation fault at line 1263 in vid_voodoo.c. Looking at the code lod_min and lod_max are set to 15 which is outside of range of texture_offset, so base is pointing to invalid memory.
Quake2 appears to be working but after loading for a bit it crashes with the message "glTexDownloadMipMap: mipmap cannot span 2 Mbyte boundary".
Monster3D Settings-test displays only a black screen.

I've tried the same configuration on Linux 32-bit (with the patch I provided in the Linux patches-thread) and Windows 32- and 64-bit and glQuake and the Monster3D Settings-test works great without issues.

Return to “Development”

Who is online

Users browsing this forum: No registered users and 3 guests