486/33MHz with dynarec can't boot

Discussion of development and patch submission.
basic2004
Posts: 118
Joined: Sun 08 Jan, 2017 5:59 pm

486/33MHz with dynarec can't boot

Postby basic2004 » Sat 29 Apr, 2017 4:22 am

PCem can't boot with 486/33MHz (SX/DX both) and checked Dynamic Recompiler
because this is stuck from POST screen in PCem v12 stable and current development version.
25/40/50/66MHz can boot but 33MHz (33MHz boot only without Dynamic Recompiler)

I didn't know this problem because my desktop used PCem with 486DX2/66 or Pentium 120MHz always.
but I lent GPD WIN from my acquaintance because I help to upgrade Windows from this device.
this uses Cherrytrail(Silvermont) CPU, frame drops above 40MHz.

But 25MHz is low performance for me and some DOS applications can't execute.
I think 33MHz is moderate performance with GPD WIN, and I didn't test 33MHz without dynarec from this device.

Can anyone solve this problem?
Battler
Posts: 793
Joined: Sun 06 Jul, 2014 7:05 pm

Re: 486/33MHz with dynarec can't boot

Postby Battler » Sat 29 Apr, 2017 12:50 pm

Don't use the Dynamic Recompiler for the 486's - the Interpreter should be enough.
User avatar
omarsis81
Posts: 537
Joined: Thu 17 Dec, 2015 6:20 pm

Re: 486/33MHz with dynarec can't boot

Postby omarsis81 » Sat 29 Apr, 2017 5:40 pm

I reported the same bug almost a year ago and received the same answer.
I still think it is weird and odd the bug only works at 33, not more, not less

viewtopic.php?p=3282
User avatar
leilei
Posts: 423
Joined: Fri 25 Apr, 2014 4:47 pm

Re: 486/33MHz with dynarec can't boot

Postby leilei » Sat 29 Apr, 2017 10:39 pm

Also occurs on AMD and Cyrix processors at the same speed. AMI486, AMI WinBIOS486 and SiS 497 also exhibit the same behavior

Return to “Development”

Who is online

Users browsing this forum: No registered users and 1 guest