v15 compatibility & bug list (WIP)

Discussion of development and patch submission.
ChronicEel93
Posts: 20
Joined: Thu 29 Sep, 2016 7:17 pm

Re: v15 compatibility & bug list (WIP)

Post by ChronicEel93 » Sat 07 Sep, 2019 4:21 am

This is a bit late, but I've had a long standing issue I've never actually bothered to report :D

Anyways, using the ATI Graphics Pro Turbo card, I get pretty colors and screen corruption from certain actions., notably, any time an image is transformed, or whenever a window is closed (when in win3.1 and up)... screenshots to illustrate.
Uhh, searched the forums a little bit, and no luck so...

This happens on distributed and compiled versions of pcemv15 on linux and windows.

This has only been happening in high color modes.

Sometimes it doesn't happen at all.
Attachments
Screenshot from 2019-09-06 23-18-00.png
Screenshot from 2019-09-06 23-18-00.png (191.26 KiB) Viewed 2700 times
Screenshot from 2019-09-06 23-17-49.png
Screenshot from 2019-09-06 23-17-49.png (107.57 KiB) Viewed 2700 times
Screenshot from 2019-09-06 23-17-17.png
Screenshot from 2019-09-06 23-17-17.png (226.56 KiB) Viewed 2700 times

ChronicEel93
Posts: 20
Joined: Thu 29 Sep, 2016 7:17 pm

Re: v15 compatibility & bug list (WIP)

Post by ChronicEel93 » Mon 09 Sep, 2019 12:57 am

It seems I was mistaken when I asserted that the graphical issues persisted across both windows and linux. There are a few smaller oddities that are shared, such as discoloration of images in all versions of internet explorer on windows 98 when using the generic S3 VIRGE DX driver, but the major issues that are present in my screenshots seem present only on a linux build of pcem (under arch, x64) while using the mentioned ATI card. Sorry, I was rather tired when I wrote the preceding post.

tk421
Posts: 59
Joined: Sat 18 Jun, 2016 6:57 am

Re: v15 compatibility & bug list (WIP)

Post by tk421 » Mon 07 Oct, 2019 1:25 am

Has anyone had any issues with the joystick in v15? I can use my joystick with v13.1 without much fuss, but in v15 the program recognized my joystick, but Win98 does not, yet it states that I have the maximum number of joysticks installed when I try to add my Thrustmaster joystick, which is actually compatible itself with WIn98.

v15 of PCem seems to run faster than v13.1 or v14. My DOS programs are running very well, and Jedi Knight seems to run very well using the higher end Pentium MMX CPUs. I thought that if I could get the joystick working in v15 then TIE Fighter might run faster than it did with v13.1 I can confirm that the best video card for TIE Fighter 95 is the S3 Virge/DX with the Voodoo disabled completely. This is a case where not activating the Voodoo is the key to running TIE FIghter with 3D accelerated graphics.

Agorima
Posts: 2
Joined: Mon 07 Oct, 2019 3:39 pm

Re: v15 compatibility & bug list (WIP)

Post by Agorima » Tue 19 Nov, 2019 10:30 pm

Hello all,

I do not know if this is properly a bug or not, because "Commander Keen episode IV" with VGA graphics it is working perfectly fine.
However, when the graphic card Trident TGUI9440 is selected, the screen flickers, as you can see from the screenshot

CPU: i386 25 Mhz
RAM: 8 MB
HDD: 349 MB
OS: MS-DOS 6.22 / Windows for Workgroups 3.11
Image
Attachments
imagekeen.png
imagekeen.png (25.97 KiB) Viewed 968 times

User avatar
leilei
Posts: 697
Joined: Fri 25 Apr, 2014 4:47 pm

Re: v15 compatibility & bug list (WIP)

Post by leilei » Wed 20 Nov, 2019 12:01 am

Are you sure you're looking at a bug? Keen4 (and derivative engine games) have a SVGA compatibility switch for issues like that in mind. Turning that on will make that corruption go away.

User avatar
Mroowski
Posts: 1
Joined: Sun 24 Nov, 2019 1:09 pm

Re: v15 compatibility & bug list (WIP)

Post by Mroowski » Sun 24 Nov, 2019 8:52 pm

Hi everyone, I'm new here!

I've noticed some weirdness while trying to run The Elders Scrolls Adventures: Redguard.

Game performs differently depending on the Voodoo2 drivers being used.
Game runs, albeit really slowly, using official 3dfx drivers dated 7-14-1998 provided with the game. The fps hangs around 8-12 fps, which is about a half of what you would get using the real hardware. This is not really a suprise, since this game is a buggy mess and even the GOG rerelease doesn't work perfectly. However - apart from the framerate- I've noticed no additional bugs, no polys or textures missing or anything of the sort.

When I upgraded my driver to the newer version , dated 27-01-2000, the game *seems* to run a bit smoother. However, I wasn't able to catch the exact framerate, because PCem crashes after only a brief moment, leaving me with the following error message:

Code: Select all

CMDFIFO packet 5 has byte disables set 3992c5dd
Using third party FastVoodoo2 4.0 Gold Edition drivers, emulator also crashes after couple of seconds and leaves a different message in the pcem.txt file:

Code: Select all

triangle_setup wrong order 1360 444 3058

From the games I've tested (Unreal Gold, FFVIII Demo, Croc), Redguard is the only one that produces such behaviour. Here's my question: are there some specific, preferable Voodoo2 drivers that are more suited for PCem?

Post Reply