Host machine survey

Support and general discussion.
User avatar
mforan89
Posts: 13
Joined: Sat 10 May, 2014 3:30 pm

Re: Host machine survey

Post by mforan89 »

ASUS Z87A Motherboard
Intel Core i7 4770 @ 3.50GHz
16 GB DDR3/800 RAM
2 TB Western Digital Hard Drive
256 GB Samsung 840 EVO SSD
PNY Nvidia Geforce 1050 2GB
Windows 10 Home x64
User avatar
Rikintosh
Posts: 8
Joined: Sat 06 Jun, 2020 5:10 pm
Location: São Paulo, Brazil

Re: Host machine survey

Post by Rikintosh »

Asus prime b250m-plus/br
Intel Pentium G4560 3.5Ghz
8GB DDR4 2400mhz
SSD120 + HD4TB
Radeon RX470 8GB
Windows 10 build 1909
PCEM v16 (using since v10)

(I can run 486 fluently, pentium 60 with a certain dignity, and from the pentium 75mhz, with sharp drops in performance)
alexmocanu
Posts: 17
Joined: Fri 05 May, 2017 6:54 pm

Re: Host machine survey

Post by alexmocanu »

Host machine:
Asus TUF A15 FA506IU with a Ryzen 7 4800H CPU

I was able to get a constant 99%-100% speed with this configuration - seems to be the fastest I can get without any drops in speed:
FIC VA-503+ / Pentium MMX 300 / 64 MB Ram / Diamond Stealth 3D 2000
Voodoo Graphics in SLI with 4Mb Frame-buffer memory, 4MB texture memory and all check-boxes enabled in it's settings page
Windows 98 SE

Last time I played Quake 2 at 800x600 with the 3dfx OpenGL driver enabled.

When I tried to use a faster CPU (like the K6-III+/500 for example), I noticed severe drops in emulation speed (down to 40%-50%) when accessing the disk (while loading Windows or starting up a game or loading a new map), then it jumps to 70%-80% (sometimes even 100% for short periods when the emulated machine was idle) until accessing the disk again.
User avatar
Rikintosh
Posts: 8
Joined: Sat 06 Jun, 2020 5:10 pm
Location: São Paulo, Brazil

Re: Host machine survey

Post by Rikintosh »

AMD Ryzen 3200G, 8GB DDR4 3000 mhz, 256GB SSD

Pentium 90 ~ 100mhz at 100%
User avatar
LordStarwalker
Posts: 3
Joined: Thu 03 Sep, 2020 11:17 am
Location: USA, FL

Re: Host machine survey

Post by LordStarwalker »

My machines are :

ORIGIN PC Desktop:
Intel Core i5-8400 (2.81 GHz)
16GB RAM
Windows 10

HP Envy Laptop:
Core i7-8550U (1.8 GHz)
12GB RAM
Windows 10
niltongaviao
Posts: 4
Joined: Sat 11 Jul, 2020 3:41 pm

Re: Host machine survey

Post by niltongaviao »

Ryzen 5 3600x
32GB RAM
Windows 10 LTSC.
RTX 2060
User avatar
WinWhat
Posts: 1
Joined: Wed 09 Dec, 2020 7:07 am
Location: Somewhere on Indonesia
Contact:

Re: Host machine survey

Post by WinWhat »

Old laptop from around 2012 (i guess)
Intel Core i3 2350m 2.3ghz
2gb RAM
Intel HD 3000 + Radeon HD 7450m
Windows 7 Ultimate SP1

Pentium 120mhz runs pretty well. Pentium II 233mhz is pretty slow (less than 50% when loading, copying files and hardware detection)
no u
User avatar
mijk
Posts: 15
Joined: Wed 24 Mar, 2021 11:49 pm

Re: Host machine survey

Post by mijk »

Laptop:
AMD Ryzen 7 3700U
12GB RAM
Radeon Vega 10.
512GB NVMe

I've been able to emulate up to Pentium Mobile 120MMX with a Voodoo3 3000. It sometimes dips to high 90's % but I still use it. Highest end Am5x86 and Cx5x86 run fantastic, also great to use.
wpeckham
Posts: 3
Joined: Tue 27 Apr, 2021 3:32 pm

Re: Host machine survey

Post by wpeckham »

I am running Manjaro on a Pinebook Pro and can get DOS and Win98 (floppy image only, not full gui) working in any of the major emulations that should support those. The performance does not even suck!

I have not gone to full installs. I can get the machine menus to come up, but cannot connect a CD-ROM image (iso file). Also the PCEM settings menu does not come up.

Since I had to compile PCEM 17 from source on this platform, I may have screwed up some steps or configuration of software or libraries. And I find PCEM seriously impressive despite this.
siljo1
Posts: 4
Joined: Sun 11 Apr, 2021 4:31 pm

Re: Host machine survey

Post by siljo1 »

Intel Core i7 8700 3.20 GHz
16GB RAM
Geforce GTX 1050Ti
User avatar
TheMechanist
Posts: 71
Joined: Mon 03 Apr, 2017 6:59 pm
Contact:

Re: Host machine survey

Post by TheMechanist »

Thinkpad Edge 13" (0217-2YG)
Core i3 U380 (4 Cores, 1,33 GHz)
Intel HD
4 GB RAM
Void Linux
Emulation up to 486DX40 runs at full speed ...
_pi
Posts: 1
Joined: Wed 12 May, 2021 8:19 pm

Re: Host machine survey

Post by _pi »

R7 5800X
AMD RX480 8GB
32GB RAM (3200)
Win 10

Guest:
Win98SE
GA-686BX
P2/350
256MB RAM
Voodoo3

Seems to run really well except some QuickTime Videos... they seem to put some serious strain on the machine (e.g. X-Files. Ingame movies work, CPU load is not neglectible but machine can keep 100%. But that FOX Interactive Intro Video (which is really small) slows the machine down).
matti157
Posts: 4
Joined: Sat 15 May, 2021 8:20 pm

Re: Host machine survey

Post by matti157 »

i7 7800X
512gb nvme ssd
32gb ram
Gtx 970
edilson
Posts: 4
Joined: Wed 19 May, 2021 1:11 pm

Re: Host machine survey

Post by edilson »

Intel Xeon 1650v4 3.6GHz
AMD RX480 8GB Sapphire Nitro OC
64GB RAM DDR4-2400
Win 10

I've using mostly Pentium MMX 233 with Voodoo 3
cl0ud
Posts: 1
Joined: Fri 21 May, 2021 11:11 pm

Re: Host machine survey

Post by cl0ud »

i7 8700
RTX 2070
64GB
Win 10 Home

Currently emulating Pentium 90, 64MB, S3 ViRGE+Voodoo 2, with Win 98 SE. Performance seems accurate and stays near 100%. My biggest issues is occasional graphical glitches, usually after closing a game, but also while using certain programs like WMP 7. Also, inconsistent CD audio (sometimes works, sometimes doesn't). Of course, it's hard to say for certain if it's the emulation or something configured incorrectly within the guest system. I might try some different drivers.

I initially tried a Pentium II but it was too demanding. I then tried MMX 233, then MMX 200, but still had occasional dips in performance causing sound clicks and pops. I tried a few others as well, going lower each time. The Pentium 90 was the first system without experiencing any performance drops in emulation. If anything I would go lower from here. It seems the i7 8700's single core performance is not good enough for emulating Pentiums in the triple digits.

It's worth mentioning, all those systems were usable, including the Pentium II, but performance dropped in demanding situations like games, startup sounds, loading, etc. It stays at or near 100% on the Pentium 90. No more clicks and pops and very smooth game cut scenes.
User avatar
xenaretos
Posts: 10
Joined: Sun 24 Nov, 2019 10:39 am

Re: Host machine survey

Post by xenaretos »

That's strange. It's a pretty beefy cpu that, judging by performance comparisons, should be able to at least do 233MMX. Maybe even a P2 233. You might be having some software issues.
win2k
Posts: 3
Joined: Wed 09 Jun, 2021 2:44 pm

Re: Host machine survey

Post by win2k »

Ryzen 5 5600X
16 GB RAM
Mainly use Linux and a bit of Windows 10.

Performance is really good overall. I've played some games at fullspeed or mostly so, that I didn't expect to even be playable. Currently emulating:

Gigabyte GA-686BX
Pentium II 450
Voodoo 3 3000
Sound Blaster PCI 128
Windows 2000
User avatar
CryptidWorks
Posts: 118
Joined: Fri 26 Apr, 2019 7:11 am

Re: Host machine survey

Post by CryptidWorks »

R5-5600X (PBO enabled, all-core turbo of 4.5Ghz, single-threaded 4.6Ghz)
DEEPCOOL GAMMAXX 400(With Coolermaster 120mm Sickleflow fans)
16GB 2400Mhz DDR4
MSI MPG B550 Gaming Plus Mobo
RTX-2070 Windforce
Full ATX Case with Dual Intake and Dual Exhaust
Windows 10 Professional (latest update)


Via getting extra performance by using a batch file that forces PCEM to start without SMT (affinity set to only even cores) and high in priority mode I have a Pentium II 233mhz with a Voodoo 3 3000 and SB16 running Windows 98 SE going full speed. Just very fleeting and not really noticeable drops in emulation speed that sometimes happen for like half a second when the OS accesses the virtual hard disk. I've tested Blood 2, Half-Life, and Mummy: Tomb the Pharaoh (quicktime game that loves to load the entire virtual CPU.

I also tested The War in Heaven on a Pentium II and a Banshee because it doesn't render correctly on a Voodoo 3.
Greblos
Posts: 1
Joined: Sun 23 Jan, 2022 4:10 pm

Re: Host machine survey

Post by Greblos »

I'm presently using PCem on my Google Pixel Slate Chrome OS tablet via the Linux environment.

Pixel Slate
Core m3-8100y @ 1.1GHz, 3.4GHz Turbo, 2 cores, 4 threads
8GiB RAM
64GiB eMMC
Chrome OS 97
Crostini Linux container (Debian Bullseye)
PCem 17 (compiled from source)

Intel Amber Lake-Y has relatively high single threaded IPC, so it works reasonably well in spite of the 1.1GHz base clock and only a 5w TDP, passive cooling. I can reliably emulate a 33MHz 486 system at 100% indefinitely. I think that higher clocked emulated systems require the host CPU to hit maximum frequencies, so they can only intermittently operate at 100% before the host CPU hits its thermal/power limits and slows down. The PCem GUI is a little bit tricky in Chrome OS- I suspect this is due to a lack of hi-DPI scaling. I was able to set an option in Chrome OS to manually scale the UI controls up, and I typically have the emulated display scaled to 200% since the tablet's native resolution is 3000x2000 on a 12" display.
sndwv
Posts: 8
Joined: Tue 01 Feb, 2022 6:46 pm

Re: Host machine survey

Post by sndwv »

Core i7 975 Extreme Edition @ 3.33 Ghz
12GB RAM
GTX 1080 Ti
Windows 7 and Windows 10 dual boot

PCEM v17 comfortably runs 100Mhz Pentium, depending on the game can be pushed to 166Mhz with 3d accelaration.
GeoffreyMcJefferson
Posts: 3
Joined: Wed 02 Feb, 2022 10:57 pm

Re: Host machine survey

Post by GeoffreyMcJefferson »

Ryzen 5900x
32GB RAM
RTX 3070
Windows 10
niltongaviao
Posts: 4
Joined: Sat 11 Jul, 2020 3:41 pm

Re: Host machine survey

Post by niltongaviao »

Ryzen R5 3600x
RTX 2060 6GB
32GB RAM
Windows 10 Pro X64
User avatar
gen_angry
Posts: 127
Joined: Sat 25 Feb, 2017 6:48 am

Re: Host machine survey

Post by gen_angry »

Upgraded to a 5900X with 32G RAM. Still using my 2060 for now, waiting for Lovelace.
User avatar
unreal9010
Posts: 80
Joined: Sat 14 Nov, 2020 8:20 pm

Re: Host machine survey

Post by unreal9010 »

CPU: Intel Core i9 12900KF
CPU cooler: Dark Rock Pro 4
Mainboard: ASUS Prime Z690-A
RAM: 32 GB Kingston Fury Beast DDR5 5200 Mhz
GPU: ASUS TUF Gaming RTX 3060 12GB
NVMe: Corsair MP600 Core 2TB
OS: Windows 11 Pro

Currently emulated configuration:
CPU: Pentium II 333 Mhz
RAM: 64 MB
Mainboard: Gigabyte GA-686BX
GPU: ViRGE/DX 4MB (using Diamond Stealth 3D 2000 Pro bios)
3D Card: Voodoo 2 12MB
Sound card: Creative SB AudioPCI 64V
CD-ROM drive: BTC 36X IDE
OS: Windows 95B
Renderer: OpenGL 3.0 with 6X xbrz shader

Using the latest (85e1ef3) experimental build, I get rock-solid performance when emulating my Pentium II 333 configuration. The emulated machine is at 100% the whole time during computer startup process, loading Windows, browsing start menu, navigating through Windows explorer, dragging and dropping files, copying/pasting between different drives, installing various games and applications and of course running 3D stuff.
The host CPU is A. I. overclocked (using the silent profile both for overclocking and the CPU cooler). When using PCem I can get the speeds of up to 5.3 Ghz (Windows power plan is set to "balanced"). PCem and all the virtual images of games and applications are running off the NVMe drive. I also did some Passmark ST testing and got the score of 4,340 which is in fact a tad above the current global average with 12900KF.
The only time when speed drops below 100% is when running certain games and apps that have issues with the new dynamic recompiler (e. g. Day of the Tentacle, Little Big Adventure 2, UltraHLE etc). For now, the workaround is to turn off the internal CPU cache in the BIOS). The 2D stuff then runs as 100%, whereas the dynarec bug-affected 3D stuff runs at 100% but suffers from low framerates.
For some reason, these dynarec regressions cause CPU to overheat heavily. CPUID HW Monitor shows that when these regressions happen the CPU may reach 90 degrees (otherwise the temperatures are between 40-50 degrees on idle Windows 95 desktop and 60-70 degrees when running more demanding 3D stuff).

The above configuration is a Spring 1998 dream machine that would decently run anything released up to the late 2000.
Dynarec regressions aside, the host configuration is ideal for emulating what I'm currently aiming at. I haven't tried CPU speeds greater than 333 Mhz yet.
navjack27
Posts: 1
Joined: Tue 08 Mar, 2022 4:23 pm

Re: Host machine survey

Post by navjack27 »

CPU: AMD Ryzen 5900X
CPU cooler: NH D15
Mainboard: ASRock X570 PG Velocita
RAM: 64GB Corsair Vengeance LPX 3600
GPU: RTX 2070 Super
Boot Drive: Samsung 970 Evo Plus 1TB NVME
Other Drive (where PCem is): ADATA XPG SX8200 Pro 1TB NVME
OS: Windows 11 Pro for Workstations Insider Release Preview
Passmark Single Thread: 3659

Emulated System #1
Platform: Socket 8
CPU: Pentium Pro 200
RAM: 256MB
GPU: V3 3000
Sound Card: AWE32 or SB Pro V2
Drive Image Format: Dynamic VHD
Drive 1: 50663MB
Drive 2: 65556MB
Drive 3: 65556MB
Drive 4: 65556MB
OS: Windows 98 SE
Renderer: OpenGL 3.0
PCem Version: V17
Notes: Mainly for playing 3D Windows games and occasionally swapping out one of the drives in it to manage disks for other machines. Contains a DOS gaming set on drives 2-4. Daemon tools for ISOs that are on the drives. Tons of different drivers for everything. Just all around a universal system that can almost run anything.

Emulated System #2, #3
Platform: Super 7
CPU: ANY
RAM: 256MB
GPU: ANY
... i'll stop myself here. This is basically the machine above but with more floating hardware on the same drives. I have another one that is on slot 1 also. Some drivers or Windows configurations and hardware combinations while keeping the same CPU sometimes totally changes the ability to maintain 100% realtime speed so i tend to change things often.

Emulated System #4
I have a dos 6.22 that floats around in hardware but usually stays around a lower clock rate pentium pro with the cache disabled in BIOS. Its got a number 9FX trio and a voodoo 1 and 32MB ram and four 2GB drives as IMG files for no reason other than i oops'd and didn't make them VHD.

Emulated system #5
Let's get exotic-ish!
OS: eComStation
Platform: Slot 1
CPU: Pentium 2 233
RAM: 512MB
GPU: Trio64
Sound: SB16
Drive 1: 8GB
Drives 2-4: The 64GB drives from the Win98 machine for DOS games
NETWORKING ENABLED
Notes: IO operations just cause this system to crawl down from realtime hard. well, all the systems have this behavior and i'm unsure why.

I have more systems, i have an NT 4 rig that i haven't really done anything with yet except set it up initially. I have two Windows 3.11 systems that use the same drive but have different platforms. I got an MS-DOS 5 running on an 8088 temporarily for messing around with seeing what software is happy with the 8088.

I have machines for everything and i'll just spin one up and install whatever i need at a moments notice. I use PCem all day long pretty much. its way more accurate than DOSBOX.

Back in March I was playing Skynet and noticed it was particularly good at stressing CPUs in certain locations so i did a bunch of testing to find out which CPUs in this singular spot in the game would not dip below realtime %.
pcemtesting1.png
pcemtesting1.png (5.46 KiB) Viewed 770 times
pcemtesting2.png
pcemtesting2.png (5.63 KiB) Viewed 770 times
(sorry i don't have more details then this, i was obsessed for a couple days and was doing this testing and at this point i don't remember anything other than what i noted down)

now obviously i can run faster CPUs at realtime % but you gotta remember how variable and odd some loads are on these old systems. some just constantly stress the recompiler with new blocks while seemingly doing nothing. Don't be totally afraid of switching out hardware or bios settings or drivers or using old utilities in your simulated environment. your system might be able to handle more than you think. Also, my go to CPU always seems to be the Pentium Pro or Winchip mattering on what i want to run. No need to get worked up about running a massive clock rate celeron or pentium 2 system except for laughs really. its fun benchmarking this simulated hardware and seeing what lines up with reviews of the time, most of the time its spot on which is nice.

sidenote: i've lurked the forums here for a while before posting and man its gotta be frustrating having people post things like "this bug in the emulation is breaking X" when its not the emulation or a bug its the user not fully grasping how to set up the old system to do the thing they want. these times WERE NOT plug and play and Plug-And-Play meant something totally different LOL
Post Reply