8088/8086 machine bug with PC-DOS 2.x/3.0

Discussion of development and patch submission.
Post Reply
Fenix77
Posts: 68
Joined: Fri 01 Sep, 2017 11:59 am

8088/8086 machine bug with PC-DOS 2.x/3.0

Post by Fenix77 » Thu 18 Jan, 2018 4:04 pm

Hello.

I recently tested the game called Pictionary in Toshiba T1000. I found the game locks up immediately after running PICTION.EXE.
Then I tested the same game with Tandy 1000 HX and SL/2. On SL/2 worked OK.
First I thought it was a problem with DOS 2.11 since both machines have the same version number (HX and T1000) and the game worked flawlessly in DOS 3.2 and higher in all machines.

Finally, I discovered it's an 8088/8086 bug because I booted PC-DOS 2.10 and run the same game with IBM AT 286, and worked without any issue.
I tested PC-DOS 3.00 too. It works on IBM AT 286, but says "Disk boot failure" in XT machines. (no problem with DOS 3.2+)

The bugs with programs that I reported in "Toshiba 1200 emulation" thread are the same with all XT machines with DOS 2.1.
Attachments
Screenshot from 2018-01-18 12-48-39.png
The error I get on 8086 and DOS 2.11
Screenshot from 2018-01-18 12-48-39.png (35 KiB) Viewed 784 times

User avatar
SarahWalker
Site Admin
Posts: 1581
Joined: Thu 24 Apr, 2014 4:18 pm

Re: 8088/8086 machine bug with PC-DOS 2.x/3.0

Post by SarahWalker » Wed 11 Apr, 2018 3:24 pm

Not a PCem bug. Pictionary tries to initialise the mouse via INT 33h. Your mouse driver would normally hook this, but you don't have one loaded. DOS 3+ will install a dummy handler, as will AT BIOSes. If you use DOS 1.x/2.x with an XT machine and no mouse driver then nothing will initialise it and Pictionary will jump to 0:0, which doesn't end well.

Post Reply