Paradise Bahamasw 64 (S3 Vision864)

Discussion of development and patch submission.
Post Reply
AnnaWu
Posts: 43
Joined: Mon 12 May, 2014 6:10 pm
Location: Germany
Contact:

Paradise Bahamasw 64 (S3 Vision864)

Post by AnnaWu » Fri 02 Mar, 2018 12:28 pm

Dear Sarah,

if I start PCem with the Paradise Bahamasw 64 (S3 Vision864) driver I get following message:
Attachments
AMI 386DX clone - Win3.11.cfg
(1.26 KiB) Downloaded 42 times
Message.png
Message.png (4.72 KiB) Viewed 913 times

AnnaWu
Posts: 43
Joined: Mon 12 May, 2014 6:10 pm
Location: Germany
Contact:

Re: Paradise Bahamasw 64 (S3 Vision864)

Post by AnnaWu » Fri 02 Mar, 2018 12:34 pm

After this message the Paradise Bahamasw 64 (S3 Vision864) driver seems to work.

Image

User avatar
leilei
Posts: 606
Joined: Fri 25 Apr, 2014 4:47 pm

Re: Paradise Bahamasw 64 (S3 Vision864)

Post by leilei » Fri 02 Mar, 2018 2:13 pm

What model are you trying to use? This should appear when you're using anything below SiS 496 and it can appear on some machines if you have both a SBPCI and an ethernet card going.


It got me when I tried to use Trio64 with the WinBIOS 486 (ISA/VLB only) since that's what I use on my real board (though to be fair mine's a certain infamous buggy vip board that would be fictionally too great if it were to be emulated)

User avatar
SarahWalker
Site Admin
Posts: 1598
Joined: Thu 24 Apr, 2014 4:18 pm

Re: Paradise Bahamasw 64 (S3 Vision864)

Post by SarahWalker » Fri 02 Mar, 2018 9:59 pm

Fixed in rev 1087.

AnnaWu
Posts: 43
Joined: Mon 12 May, 2014 6:10 pm
Location: Germany
Contact:

Re: Paradise Bahamasw 64 (S3 Vision864)

Post by AnnaWu » Fri 02 Mar, 2018 10:33 pm

SarahWalker wrote:
Fri 02 Mar, 2018 9:59 pm
Fixed in rev 1087.
Don't attempt to register PCI devices on systems that don't have PCI. Fixes warnings on startup.
Thanks a lot, Sarah!

Post Reply