bug: pb570 crash with cd image loaded at start.

Support and general discussion.
Post Reply
jznomoney
Posts: 90
Joined: Sat 06 Dec, 2014 9:11 pm

bug: pb570 crash with cd image loaded at start.

Post by jznomoney » Tue 14 May, 2019 8:16 pm

I am having issues with the pb570 board and a cdrom image loaded at boot. When It gets past the drive detection pcem closes if a cdrom image is loaded. If I leave it empty pcem will continue and boot normally and I can mount a cd image and use it during the session until I boot it again then it will crash at the bios. The only thing in the log is this:

Device failed to request command
Attachments
tester.cfg
(1.49 KiB) Downloaded 5 times

User avatar
leilei
Posts: 654
Joined: Fri 25 Apr, 2014 4:47 pm

Re: bug: pb570 crash with cd image loaded at start.

Post by leilei » Wed 15 May, 2019 8:15 am

can confirm this happening in the latest revision

Code: Select all

onesec
onesec
onesec
onesec
Set multiple mode - 16
onesec
onesec
onesec
onesec
atapi_reset
New CD command 00 4828015
Medium changed
New CD command 00 4828170
New CD command 00 4828223
New CD command 03 4828247
New CD command 03 4828287
New CD command 03 4828325
New CD command 03 4828325
onesec
onesec
onesec
onesec
onesec
New CD command 00 4828393
New CD command 1B 4828412
New CD command 1B 4828432
New CD command 42 4828451
Device failed to request command

User avatar
SarahWalker
Site Admin
Posts: 1692
Joined: Thu 24 Apr, 2014 4:18 pm

Re: bug: pb570 crash with cd image loaded at start.

Post by SarahWalker » Wed 15 May, 2019 6:52 pm

Fixed in rev 1457.

Post Reply