Pitfall: The Mayan Adventure and Earthworm Jim for windows 95 play way too fast!

Support and general discussion.
Post Reply
BluesElwoo
Posts: 5
Joined: Wed 30 Oct, 2019 4:42 am

Pitfall: The Mayan Adventure and Earthworm Jim for windows 95 play way too fast!

Post by BluesElwoo » Mon 04 Nov, 2019 4:10 am

First off, thanks to Sarah Walker for making this emulator in the first place! Its so awesome! Over the years, I have tried to get older games to work in modern windows with varying results. Pitfall and EWJ are two of my favorites from back in the day. I have PCEM with windows 95 installed on it. I have it emulating the pentium 75 and the s3 virge with voodoo graphics turned on. I have direct x 8.0 installed on it with the graphics drivers and everything. No exclamation points in device manager. The emulator runs at 100% speed as long as I don't use the original disc for the games in the cd rom drive, as while it is reading CD audio, it drops emulations speed to around 60%. Using a CD image gets rid of that problem.

Using this emulator to run these games makes it to where I don't have to download a new wail32.dll that makes it work in modern windows. The fade effects work like they did back in the day! And the CD audio loops! The main feature I was looking to gain was to be able to make the games go into dedicated fullscreen, as that is the only way to get vsync working for these games. The screen tearing is unbearable on modern windows.

Vsync works with PCEM! Well, kind of. There are two options when it comes to fullscreen, Fullscreen smooth, and fullscreen fast. Fullscreen fast runs the game at 75 fps for some reason, and while it is better than not having vsync turned on, it still has screen tearing. Just not as bad as when vsync is off. Fullscreen smooth runs at 60 fps as the game is intended to run at, and seems to have no screen tearing! Problem is, it runs the game way too fast! I would imagine running a pentium 75 in real life wouldn't be able to run the game that fast. I feel like I had a pentium 90 back in the day, and it didn't run this fast.

I am wondering if anybody would possibly know what might fix this from happening! Running the games in fullscreen smooth at normal speed is the goal. Otherwise, the games run better than I've seen them in a long time, and that is so exciting! Also, the reason I lump these two together is they run on the same engine, have the same problems with the same fixes in modern windows, with both the problem of running too fast in PCEM. One gets fixed, they both get fixed.

Thanks to anyone that might have some insight!

Cheez
Posts: 28
Joined: Tue 19 Dec, 2017 4:08 am

Re: Pitfall: The Mayan Adventure and Earthworm Jim for windows 95 play way too fast!

Post by Cheez » Mon 04 Nov, 2019 7:41 am

Fullscreen fast probably runs at 75 because most CRT monitors were capable of 75hz to begin with. I don't know why the lower framerate is called "smooth" and I don't know what refresh rate PCem pretends to have, but in my experimentation with the most popular PCem hardware settings, I can't seem to get screen tearing. In the end it still seemed to play just fine with fullscreen fast with sync to monitor checked. I don't think I tried to see what it would do with the box unchecked.

BluesElwoo
Posts: 5
Joined: Wed 30 Oct, 2019 4:42 am

Re: Pitfall: The Mayan Adventure and Earthworm Jim for windows 95 play way too fast!

Post by BluesElwoo » Mon 04 Nov, 2019 11:09 pm

So, for me, when these games are played without vsync enabled. they are super jerky looking. Its hard to look at for an extended period of time. For me, when I go into display settings in win95 for the video card, it has an option to change refresh rate, except I can't change it. It is stuck at 60hz. When I play the game in Fullscreen fast, it mostly looks good, except there is a constant tear an inch or two below the top of the screen. Im sure thats because PCEM is running its virtual display at 60hz, and the game is running at 75fps.

If anyone has some insight into why fullscreen smooth runs so fast, what it really is, and if there was a way to fix it, that would be awesome!

BluesElwoo
Posts: 5
Joined: Wed 30 Oct, 2019 4:42 am

Re: Pitfall: The Mayan Adventure and Earthworm Jim for windows 95 play way too fast!

Post by BluesElwoo » Sat 16 Nov, 2019 5:05 pm

I was mistaken when I said the fullscreen fast mode was at 75 fps, its actually 70 fps. If anyone knows how to change the refresh rate in the 3dfx display properties to 70 hz, that might be a somewhat side fix to my problem. Its stuck at 60 hz, and I can't move the slider. Nothing in the 3dfx display settings tab can be saved by clicking apply, because it stays greyed out, and hitting ok saves nothing. The 3dfx display properties appears to be non functional. Thanks to Sarah for the hard work! I wish I had the knowledge to contribute! When I am able to make a donation, I would be happy to, as this is such an awesome project!

BluesElwoo
Posts: 5
Joined: Wed 30 Oct, 2019 4:42 am

Re: Pitfall: The Mayan Adventure and Earthworm Jim for windows 95 play way too fast!

Post by BluesElwoo » Sat 16 Nov, 2019 5:05 pm

I have a 144hz monitor, so being able to run at 70hz in PCEM would probably be perfect!

User avatar
SarahWalker
Site Admin
Posts: 1726
Joined: Thu 24 Apr, 2014 4:18 pm

Re: Pitfall: The Mayan Adventure and Earthworm Jim for windows 95 play way too fast!

Post by SarahWalker » Sat 16 Nov, 2019 5:57 pm

The 3DFX display properties will do nothing for 2D platformers, it only affects 3D accelerated games. 2D refresh rates are in Display Properties -> Settings -> Advanced.

Post Reply