[PCem v16 Bug] Floppy format fails on 286-486 with AMI BIOS

Discussion of development and patch submission.
Post Reply
figment
Posts: 3
Joined: Wed 12 Feb, 2020 4:49 am

[PCem v16 Bug] Floppy format fails on 286-486 with AMI BIOS

Post by figment » Sun 17 May, 2020 6:42 am

What I am seeing is that on any 286, 386SX, 386DX, or 486 machine with AMI BIOS in PCem v16, any attempt to format a floppy from MS-DOS fails with "Drive not ready" error.

I've tried formatting with DOS 3.3 and 6.22, high- and low-density format, high- and low-density drive. Works perfectly on v15 with any emulated machine I try, and any machine with BIOS that is not AMI works as well. Problem seems to not affect Socket 5 and up nor XT machines. Reading floppies always works fine. Writing files to an already-formatted floppy also works.

Machines where disk format fails include AMI 286 clone, AMI 386SX clone, AMI 386DX clone, AMI 486 clone, and DELL System 200.

That's about all there is to it. Thanks for looking into it, and please let me know if you have any questions.

User avatar
te_lanus
Posts: 129
Joined: Tue 28 Jul, 2015 4:47 am

Re: [PCem v16 Bug] Floppy format fails on 286-486 with AMI BIOS

Post by te_lanus » Sun 17 May, 2020 12:04 pm

Already reported :D
http://pcem-emulator.co.uk/phpBB3/viewtopic.php?f=2&t=3469

figment
Posts: 3
Joined: Wed 12 Feb, 2020 4:49 am

Re: [PCem v16 Bug] Floppy format fails on 286-486 with AMI BIOS

Post by figment » Sun 17 May, 2020 10:50 pm

Ah, thanks. Sorry, I'm new here, still finding my way around. Cheers!

Post Reply