Page 1 of 1

Questions about IBM PS/1 Model 2011: the xtide driver and IBM soundcard

Posted: Tue 30 Mar, 2021 6:10 pm
by DoutorHouse
Hello everyone!
First of all, I wanna say i'm not a programmer and computers are just a hobby of mine that started when i got my first PC, back in late 1990, an IBM PS/1 Model 2011, complete with a VGA monitor and a 40Megs HDD. I kept it since then, mainly for sentimental reasons, and it has worked really well until last December when, after i asked a friend to solder a "regular" CR2032 to its dying Dallas DS1287 Real Time clock chip, the monitor suddenly stopped working...
I had discovered, some time before, that there was a specific emulator for this particular model (IBMulator) and it kinda led me to discover PCem and try it too. I was astounded, really, as i've been using it A LOT for trying old games and other software. It's so useful and easy to run, even for a noob like me, that i have decided to make some working roms for PCem from my own portuguese model and another custom one (from the UK model i bought recently, modifying it to make it work with my portuguese keyboard).
Anyway, the emulation works great and everything acts like it should! IBMulator doesn't need any external file to access the HDD on this 2011 model (the controller is ancient, i think) but i followed the instructions and easily found the required ide_at_1_1_5.bin to make it work.
Now i have a weird side problem, which can probably be fixed by someone here with the technical skills i don't have at all:
I installed PCem 1.7, created a 30megs HDD (921 cyl. / 2 heads / 33 sectors) and installed IBM-DOS 4.01. Everything works fine and the emulated machine restarts and acts normal.
When i use the CUSTOMIZ.EXE program to access the IBM PS/1 options for startup and make it boot from the C: drive instead of the internal ROM drive (D:), the xtide driver acts weird and can't access the disk. It states it has found a boot record on c: but refuses to boot from it. It can boot from a: but not c:
If i run CUSTOMIZ.EXE again and go back to the original settings, everything works ok again...
After some experiments, i eventually found out that if i do a hard reset (with the configuration made for the IBM to run from C:) and press enter a lot of times (not always the same number of times...) the xtide driver eventually boots from C:
This is technically not a major inconvenience, as i can just press enter until it works, but i'm kinda curious to know why this is happening and maybe if it is possible to change the ide_at_1_1_5.bin file to correct this behaviour...
My other question concerns the IBM PS/1 soundcard. Is it possible to run the emulation without being present by default?
Again, thank you so much for your time and help on this and congratulations on one of the most awesome (and useful) programs ever written!!!
Cheers from Portugal!