[Bug] Wolf3D total conversion black screens

Support and general discussion.
Post Reply
Posts: 793
Joined: Sun 06 Jul, 2014 7:05 pm

[Bug] Wolf3D total conversion black screens

Post by Battler » Wed 10 Aug, 2016 2:55 pm

Basically here is the link: http://citadel.rol.im/wolf3d_tc.rar . It's a Wolf3D total conversion I started but never finished years ago. Any version of this that I compiled prior to adding BrotherTank's light shading code, works fine in PCem and any other thing. Any version compiled after adding said code, behaves as such:
- Real hardware: Works perfectly;
- DOSBox: Black screens for unknown reasons;
- PCem (mainline) of some months ago: worked as long as mouse was PS/2, BLASTER= was absent, and EMM386 was not loaded, otherwise black screen as it would stall for some reason;
- PCem (mainlin) latest repo code: doesn't work at all, always black screens, and on the recompiler it even issues instruction FF 38 (which is part of the data segment of the executable, and not code!) and resultingly issues an illegal instruction exception (no illegal instruction exception, but who knows what happens there);
- Virtual PC 2007: Black screens for unknown reasons if hardware virtualization is turned off, but works perfectly when it's turned on.
I haven't tried it on Bochs, MAME, VMWare, or VirtualBox, so I wouldn't know.

The recompiler part of the problem is possible the same problem causing leilei's Windows ME woes: viewtopic.php?p=3602#p3602 . But the other half of the problem, I have no idea why it happens.

Edit: And I also have another unfinished Wolf3D total conversion of mine that behaves the same way (versions without the shading patch work, versions with it black screen), so I suspect any total conversion using the shading patch, and there's quite a few of them out there on the Internet, will have the same problem.

Edit #2: Before the illegal instruction, this appears in the log: Bad getpccache 000A443A .

Edit #3: I forgot to say, the black screen occurs after loading the level... the loading "Get psyched" screen appears fine, but then it black screens.

Post Reply