Search found 43 matches

by darksabre76
Wed 25 Apr, 2018 3:53 pm
Forum: Patches
Topic: [Patch] Cleanup
Replies: 2
Views: 278

Re: [Patch] Cleanup

If you look at my patch, I didn't remove any of those 4 because I didn't know the status.
by darksabre76
Tue 24 Apr, 2018 4:42 am
Forum: Patches
Topic: [Patch] Cleanup
Replies: 2
Views: 278

[Patch] Cleanup

This patch does the following: Normalizes directory markers to '/' in readme.txt (to be consistent with the code) Updates incorrect rom paths in readme.txt Renames some IBM PS/1 and PS/2 machines to better reflect other machine naming Puts all devices previously in the rom root directory into subfol...
by darksabre76
Fri 13 Apr, 2018 7:27 pm
Forum: Development
Topic: v14 compatibility & bug list (WIP)
Replies: 19
Views: 2208

Re: v14 compatibility & bug list (WIP)

Just going to link my Starfleet Academy crash here as well since it still seems to repro, unless I forgot to remove something: https://pcem-emulator.co.uk/phpBB3/view ... f=2&t=2967
by darksabre76
Mon 26 Mar, 2018 11:03 pm
Forum: General
Topic: Starfleet Academy Trailer crash
Replies: 2
Views: 371

Re: Starfleet Academy Trailer crash

As a slight update to this: I tried running the Starfleet Academy trailer directly from both the CD and from a directory on the HDD image, and both resulted in the exact same error. It seems infinitely reproducible with this particular executable.
by darksabre76
Sun 25 Mar, 2018 6:34 pm
Forum: General
Topic: v13.1 released!
Replies: 25
Views: 4095

Re: v13.1 released!

Regarding the linux menu, right click on the main window when your mouse is not captured.
by darksabre76
Sun 25 Mar, 2018 6:20 pm
Forum: General
Topic: Starfleet Academy Trailer crash
Replies: 2
Views: 371

Starfleet Academy Trailer crash

Hello all, I recently tried installing an old favorite of mine, Carmageddon, in a DOS 6.22 setup. After the install, it automatically plays the Starfleet Academy trailer using a player built into the disc. Unfortunately, the only thing that showed up when it tried to play was "STACK OVERFLOW" and PC...
by darksabre76
Fri 16 Mar, 2018 5:16 pm
Forum: Development
Topic: ide_atapi.c missing a brace?
Replies: 3
Views: 379

Re: ide_atapi.c missing a brace?

Looks like the brace got moved accidentally to the end of the first line under else.
by darksabre76
Mon 12 Feb, 2018 4:25 am
Forum: Merged patches
Topic: [Patch] MinGW Configure
Replies: 30
Views: 1792

Re: [Patch] MinGW Configure

Also, using the automake generated makefiles should in theory be able to detect modifications to source code, and only compile necessary changes. I haven't tested this yet however. I've tried this out and it seems to work by just doing the mingw32-make step each time. If there were issues, it seeme...
by darksabre76
Sun 11 Feb, 2018 1:04 am
Forum: Merged patches
Topic: [Patch] MinGW Configure
Replies: 30
Views: 1792

Re: [Patch] MinGW Configure

I see that in Makefile.am, the line: DEFAULT_INCLUDES = -iquote . was commented out. I don't think I submitted the patch with that commented, but if I did, then I messed up. That line ensures that MinGW/MSYS2 doesn't look in the local folder first for a few things like io.h. Otherwise, compilation f...
by darksabre76
Thu 08 Feb, 2018 2:20 am
Forum: Merged patches
Topic: [Patch] MinGW Configure
Replies: 30
Views: 1792

Re: [Patch] MinGW Configure

I call that a ringing endorsement for the other affected environments :)
by darksabre76
Tue 06 Feb, 2018 8:12 pm
Forum: Merged patches
Topic: [Patch] MinGW Configure
Replies: 30
Views: 1792

Re: [Patch] MinGW Configure

Okay, one last update that makes one of the conditionals a little cleaner. I think this will be the last one unless something broke.
by darksabre76
Tue 06 Feb, 2018 5:37 pm
Forum: Merged patches
Topic: [Patch] MinGW Configure
Replies: 30
Views: 1792

Re: [Patch] MinGW Configure

Based on other conversations I've seen, I think I remember that there were issues with 64-bit in general. Honestly, that'd be something cool to try to get working as well, but as it stands, if 32-bit MinGW is working, I call that a win. I just need to make sure that none of these changes affect MacO...
by darksabre76
Tue 06 Feb, 2018 5:26 am
Forum: Merged patches
Topic: [Patch] MinGW Configure
Replies: 30
Views: 1792

Re: [Patch] MinGW Configure

And one more update because I apparently didn't understand where the wx resource file really REALLY was included.
by darksabre76
Tue 06 Feb, 2018 4:55 am
Forum: Merged patches
Topic: [Patch] MinGW Configure
Replies: 30
Views: 1792

Re: [Patch] MinGW Configure

Busy IRL so I finally got around to posting my updated patch. It includes the MAKE redefine for Windows only (as recommended by shermanp) as well as more conditionals for wxWidgets includes.
by darksabre76
Fri 02 Feb, 2018 1:12 am
Forum: Merged patches
Topic: [Patch] MinGW Configure
Replies: 30
Views: 1792

Re: [Patch] MinGW Configure

I was able to find the missing parts for the wx issues and I'm on my way to getting that working properly. I don't actually think that redefining the "MAKE" variable will actually help or hurt here, but that could be just me.
by darksabre76
Wed 31 Jan, 2018 10:20 pm
Forum: Merged patches
Topic: [Patch] Toshiba T1200
Replies: 11
Views: 904

Re: [Patch] Toshiba T1200

When trying to compile the latest commit:

Code: Select all

pcem-mem.o: In function `loadbios':
C:\Users\darksabre76\Downloads\EmuBuild\home\user\pcem\src/mem.c:780: undefined reference to `romfread'
by darksabre76
Wed 31 Jan, 2018 6:17 pm
Forum: Merged patches
Topic: [Patch] MinGW Configure
Replies: 30
Views: 1792

Re: [Patch] MinGW Configure

Looks like just putting the ../pcem target behind conditionals for both Linux and MACOSX will do the trick. Everything compiles correctly and it doesn't complain about a target that technically exists but can't be done. Newest patch in the top post.
by darksabre76
Wed 31 Jan, 2018 6:27 am
Forum: Merged patches
Topic: [Patch] MinGW Configure
Replies: 30
Views: 1792

Re: [Patch] MinGW Configure

Hmm, interesting observations. I was sure that the regular "make" would do the right thing. Maybe it's matter of what "_WIN" or "_WIN32" variable is included. I may have to do a fresh clone and apply as well to see if my MSYS2 setup does the same. Thank you for testing this, I'd love to see if this ...
by darksabre76
Wed 31 Jan, 2018 1:34 am
Forum: Merged patches
Topic: [Patch] MinGW Configure
Replies: 30
Views: 1792

Re: [Patch] MinGW Configure

Okay, I finally figured out the things with the configure.ac and makefile.am files. I was able to do "./configure --enable-networking --enable-debug && ./make" in an MSYS2 environment and it produced a working executable. I have attached it to this post. I tried my best to make sure that this ONLY a...
by darksabre76
Sun 28 Jan, 2018 4:17 am
Forum: Merged patches
Topic: [Patch] MinGW Configure
Replies: 30
Views: 1792

Re: [Patch] MinGW Configure

That is something I didn't even think of. Okay then, let me take a look at that and then update the patch... at some point.
by darksabre76
Wed 24 Jan, 2018 2:12 am
Forum: Development
Topic: Wrong io.h
Replies: 4
Views: 428

Re: Wrong io.h

Again, yes and no. On Linux, the search path is identical (given that the actual location of the libraries and headers is different, blah, blah) in that "." is the first thing in the search path. Also on Linux, this does not seem to affect how well it can find the correct io.h. This only seems to ha...
by darksabre76
Tue 23 Jan, 2018 5:59 pm
Forum: Development
Topic: Wrong io.h
Replies: 4
Views: 428

Re: Wrong io.h

So, yes, that does seem to be the surface issue. But the actual issue is that these calls are in "src/io.h" and not the system "includes/io.h". I had actually looked into the unknown types first, but that came to a dead-end when I realized that those line numbers in "includes/io.h" didn't actually h...
by darksabre76
Tue 23 Jan, 2018 6:58 am
Forum: Development
Topic: Wrong io.h
Replies: 4
Views: 428

Wrong io.h

I'm currently trying to figure out how to "unify" the build process between Linux and Windows by making the MSYS2/MinGW steps much more akin to the Linux "configure-make-install" path. I just submitted a patch that allows MSYS2 (at least) users to get past the configure step. Now I'm stuck at make. ...
by darksabre76
Tue 23 Jan, 2018 6:48 am
Forum: Merged patches
Topic: [Patch] MinGW Configure
Replies: 30
Views: 1792

[Patch] MinGW Configure

Hello all, this is my first attempt at a patch for anything. This patch allows MSYS2 (and MinGW, though I have not been able to confirm this) to get past the './configure' step. This still does not allow a full "./configure && make && make install' on MSYS2/MinGW yet, but I am working toward that, b...
by darksabre76
Mon 18 Dec, 2017 10:01 pm
Forum: Development
Topic: Linux configure version update
Replies: 0
Views: 361

Linux configure version update

I just recompiled the most recent version on my Ubuntu laptop and I noticed as it was doing configure that it still had v12 in the output. Any chance that it can be updated to 13.1? This is as minor as it gets, but I figure it's worth it for consistency.
by darksabre76
Mon 18 Dec, 2017 8:24 am
Forum: General
Topic: v13 - Mouse Issues
Replies: 13
Views: 959

Re: v13 - Mouse Issues

I... think you misunderstood gen_angry. You can download the Linux source files for the most recent release and build it yourself on your machine using the standard ./configure && make && make install chain. You just need the right development libraries (SDL2, wxWidgets, probably some other stuff I'...
by darksabre76
Tue 12 Dec, 2017 8:37 am
Forum: General
Topic: Toolbar missing?
Replies: 2
Views: 255

Re: Toolbar missing?

...I didn't even think to do that. Thank you for the quick response.
by darksabre76
Tue 12 Dec, 2017 8:13 am
Forum: General
Topic: Toolbar missing?
Replies: 2
Views: 255

Toolbar missing?

Time for a game of "what did I break" again. Using the official Linux download for PCem v13, I was able to build on my Ubuntu laptop, but when I run a machine, there's no toolbar in the main window. This means I can't access a lot of functionality. The only lead I might have is that in the terminal ...
by darksabre76
Tue 12 Dec, 2017 6:23 am
Forum: General
Topic: Just a stupid Question
Replies: 2
Views: 347

Re: Just a stupid Question

You need to put your roms in the ~/.pcem/roms folder. That's where all of the data is found for the linux versions.
by darksabre76
Mon 11 Dec, 2017 9:40 pm
Forum: General
Topic: Hardware Donation?
Replies: 2
Views: 299

Hardware Donation?

Hey all. There's a guy I know who has an older Windows 98 computer with a dead PSU but otherwise working cards and he wanted to know if any developers would like this hardware to do either testing or implementation. Here is his full description: I have a Windows 98 PC that I rescued from the trash r...