Search found 100 matches

by Katakis
Sun 04 Jun, 2017 1:48 am
Forum: General
Topic: [Partially-Solved] PCem v12 and Sound Lag
Replies: 124
Views: 38051

Re: [Solved] PCem v12 and Sound Lag

James-F wrote:Indeed, I don't want to see two forks go different ways, this is indeed bad for the future of this great PC emulator.
Please make up, and know that fights also happen in the best of families. :)
Indeed.
by Katakis
Sun 28 May, 2017 1:50 pm
Forum: General
Topic: [Partially-Solved] PCem v12 and Sound Lag
Replies: 124
Views: 38051

Re: PCem v12 and Sound Lag

szadycbr wrote:@Katakis, The first number is not bit rate but Words divided by that second number
OK, I stand corrected.
by Katakis
Sun 28 May, 2017 12:14 pm
Forum: General
Topic: [Partially-Solved] PCem v12 and Sound Lag
Replies: 124
Views: 38051

Re: PCem v12 and Sound Lag

In src/ibm.h, there is a line that reads "#define SOUNDBUFLEN 48000/20". The first number indicates the bit rate, while the second is the number of milliseconds that pass before the sound is played.

Try reducing the second number down to 10 or 15, then compile again. See if this works.
by Katakis
Thu 25 May, 2017 3:08 am
Forum: General
Topic: [BUG] Windows 95 desktop corruption with S3 Trio64
Replies: 17
Views: 5542

Re: [BUG] Windows 95 desktop corruption with S3 Trio64

Were you planning on mentioning any of these bugs to me at any point? Well, if by "me" you are suggesting that I should report any future bugs by sending you a private message, then I am happy to do that. In any case, I can't reproduce the reported bug. It looks to me like the Trio64 memory mapping...
by Katakis
Wed 24 May, 2017 2:25 am
Forum: General
Topic: [Partially-Solved] PCem v12 and Sound Lag
Replies: 124
Views: 38051

Re: PCem v12 and Sound Lag

I face one hurdle after another when it comes to compiling pcem (a long story - spent 4 days without success but many errors - before coming here for help). Yes, compiling PCem is a bit scary for those who are new to the emulator, especially when there is a lot of files involved, you have no idea w...
by Katakis
Tue 23 May, 2017 1:46 pm
Forum: General
Topic: [BUG] Windows 95 desktop corruption with S3 Trio64
Replies: 17
Views: 5542

Re: [BUG] Windows 95 desktop corruption with S3 Trio64

Thanks!

Exactly what causes the problems that are shown in the video?
by Katakis
Mon 22 May, 2017 1:31 am
Forum: General
Topic: [BUG] Windows 95 desktop corruption with S3 Trio64
Replies: 17
Views: 5542

Re: [BUG] Windows 95 desktop corruption with S3 Trio64

Battler wrote:- Katakis: You can find the BIOS for the Phoenix S3 Trio64 easily by Googling. :p
And to use this BIOS, can I use the official version from the downloads page, or do I have to compile the source to get the development build?
by Katakis
Sun 21 May, 2017 3:08 am
Forum: General
Topic: [BUG] Windows 95 desktop corruption with S3 Trio64
Replies: 17
Views: 5542

Re: [BUG] Windows 95 desktop corruption with S3 Trio64

Ok then, why don't you use the Phoenix S3 Trio64 with 4MB of memory? Because I don't have the Phoenix ones. As can be seen from the video, the config panel shows that I am using the Number 9FX version. Which drivers? http://www.video-drivers.com/drivers/1594/1594343.htm As per screenshot, the exact...
by Katakis
Sat 20 May, 2017 1:43 pm
Forum: General
Topic: [BUG] Windows 95 desktop corruption with S3 Trio64
Replies: 17
Views: 5542

[BUG] Windows 95 desktop corruption with S3 Trio64

Sometimes when I boot up Windows 95 with the S3 Trio64 drivers installed, the mouse cursor is replaced by a large black square that can be moved around, the task bar is black except for the clock on the right, and no icons are visible at all. Restarting seems to have the same effect, but exiting PCe...
by Katakis
Thu 18 May, 2017 2:32 am
Forum: General
Topic: Feature request: revamping config files
Replies: 53
Views: 16566

Re: Feature request: revamping config files

If you start PCem right away you'll automatically start the last config which was the 430vx, but let's say you want to run SiS 486... what you can do is: have the .cfg extension (or *.pcm extension if you like) associated to PCem, so you double click the "sis486.cfg" file or any other extension and...
by Katakis
Wed 17 May, 2017 1:19 pm
Forum: General
Topic: Awards do not detect floppies
Replies: 4
Views: 1574

Re: Awards do not detect floppies

omarsis81 wrote:Try with only 1.44 MB
I described similar bug not long ago
viewtopic.php?p=4983#p4983
Both of them worked again, thanks!
by Katakis
Tue 16 May, 2017 1:10 pm
Forum: General
Topic: Awards do not detect floppies
Replies: 4
Views: 1574

Awards do not detect floppies

On the Award 430VX PCI and Award SiS 496/497 machines, the floppy drives are not detected. I have tested five other machines (WinBIOS 486, AMI 486 clone, Mr. 386DX, Acer 386SX25/N, and Amstrad MegaPC) so I assume that non-Award ones are fine. I have no idea what's cause this, but I think that it was...
by Katakis
Tue 16 May, 2017 12:25 pm
Forum: Development
Topic: [Patch] BIN/CUE-image support
Replies: 21
Views: 8787

Re: [Patch] BIN/CUE-image support

This patch just saved me from requesting this in the "Katakis's Christmas Wishlist" I plan to do at the end of the year.

Good thing, too, considering that neither A120% or DT are only available for Windows, Linux users were unable to play games using CD-Audio tracks.
by Katakis
Tue 16 May, 2017 6:13 am
Forum: General
Topic: Feature request: revamping config files
Replies: 53
Views: 16566

Re: Feature request: revamping config files

It's precisely that - smaller dialogs with tabs, and a more orderly design in general. I think PCem would greatly benefit from such a design. So, it's similar to what you'll see when you start up WinUAE? In any case, I am all for it. I get annoyed that I sometimes saved a custom config file without...
by Katakis
Fri 12 May, 2017 3:59 am
Forum: Development
Topic: PS/2 resources
Replies: 5
Views: 8588

Re: PS/2 resources

Those filename extensions look familiar. Can I use these files under WinUAE (Amiga emulator)?

*kidding*
by Katakis
Fri 10 Mar, 2017 6:03 am
Forum: General
Topic: Thank you for creating this emulator!
Replies: 4
Views: 3363

Re: Thank you for creating this emulator!

gen_angry wrote:This post is over 2 1/2 years old, lol.
Yeah, but I'll post in this anyway, BECAUSE I CAN...
by Katakis
Tue 28 Feb, 2017 12:58 am
Forum: General
Topic: Massive slowdown while using PC/AT/XT configurations (lasting 1 minute)
Replies: 4
Views: 2204

Re: Massive slowdown while using PC/AT/XT configurations (lasting 1 minute)

omarsis81 wrote:It doesn't happen in Windows version, I just tried
It is the Windows version, but I am using Wine to run it since OS X users still miss out on an official port.
by Katakis
Mon 27 Feb, 2017 12:17 pm
Forum: General
Topic: Massive slowdown while using PC/AT/XT configurations (lasting 1 minute)
Replies: 4
Views: 2204

Massive slowdown while using PC/AT/XT configurations (lasting 1 minute)

I have uploaded a video showing the problems encountered with the earlier models PCem supports, namely IBM PC/AT/XT. If you change to a configuration using a configuration for one of these models, PCem will do a hard reset, causing the CPU percentage to drop to single digits and stays there for abou...
by Katakis
Mon 27 Feb, 2017 2:22 am
Forum: General
Topic: Unable to start PCem
Replies: 5
Views: 4075

Re: Unable to start PCem

I had the same problem (PCem has stopped working), but I found out that the emulator won't work without at least one ROM present in the /roms directory.
by Katakis
Sat 25 Feb, 2017 6:14 am
Forum: General
Topic: v12 released!
Replies: 34
Views: 16343

Re: v12 released!

Awesome work!
by Katakis
Mon 06 Feb, 2017 10:36 am
Forum: General
Topic: Audio Lag with PCem 11 (was able to repro in latest source)
Replies: 51
Views: 19032

Re: Audio Lag with PCem 11 (was able to repro in latest source)

I completed Woodruff and the Schnibble of Azimuth using WinBIOS 486 + 8MB with PCem v11 and I had no trouble at all with sync most of the time, although there were some times I did something else while I was playing that cause the audio to become out of sync. All I had to do to fix it was shut down ...
by Katakis
Sun 27 Nov, 2016 2:39 am
Forum: Development
Topic: [PATCH] CD-ROM improvements
Replies: 38
Views: 19253

Re: [PATCH] CD-ROM improvements

Can we expect some more file formats like *.bin *.cue or others for loading images? Altough it would be great to have more common file formats, like CUE/BIN, CCD, MDS, CDI, NRG, etc, remember you can mount your files in the host OS with like, Demon tools, Alcohol and then select the virtual drive i...
by Katakis
Tue 15 Nov, 2016 2:56 am
Forum: General
Topic: Request - BIN/CUE CD Image support
Replies: 0
Views: 2292

Request - BIN/CUE CD Image support

Would it be possible to add BIN/CUE support rather than just have ISO? There are a ton of games from the Nineties that use CDDA tracks such as Quake 2 and Turok as background music in the game, but ISO just doesn't cut it. I only requested this as I am running PCem through Wine and it is impossible ...
by Katakis
Thu 16 Jun, 2016 11:07 am
Forum: General
Topic: Cannot access CD-ROM drive at all
Replies: 5
Views: 5482

Re: Cannot access CD-ROM drive at all

I don't remember having to do this while I was using v10, but... I created a configuration file, changed the "cdrom_drive", "cdrom_enabled", and "cdrom_channel" parameters to "1", and then it worked. BTW... why not trying to compile the sources instead of running it through wine? Because I find Wine...
by Katakis
Thu 16 Jun, 2016 7:25 am
Forum: General
Topic: Cannot access CD-ROM drive at all
Replies: 5
Views: 5482

Re: Cannot access CD-ROM drive at all

CD1.SYS, which seems to be from Oak Technologies as well.
Oakcdrom driver works fine.
Tried that, get "No drives found, aborting installation"
by Katakis
Thu 16 Jun, 2016 2:46 am
Forum: General
Topic: Cannot access CD-ROM drive at all
Replies: 5
Views: 5482

Cannot access CD-ROM drive at all

I am running PCem via Wine and I had no problems with it in the past when I used v10. This includes the CD-ROM support, but now it is broken in v11. I am using a MS-DOS 6.2 boot disk which includes a CD-ROM driver. Looking at the AUTOEXEC.BAT, one of the lines read: MSCDEX.EXE /D:banana /L:R And the...
by Katakis
Mon 13 Jun, 2016 11:13 am
Forum: General
Topic: v11 released!
Replies: 24
Views: 13299

Re: v11 released!

Thank you, Sarah.

Hopefully, I will not have to run Parallels for this reason as the sound lags a bit whenever I use it.
I am using the emulator via Wine, but I am sure that Wine will not handle it as more and more features get implemented.
by Katakis
Sun 31 Jan, 2016 5:30 am
Forum: General
Topic: Problem with Windows 3.1x and GUS
Replies: 3
Views: 3209

Re: Problem with Windows 3.1x and GUS

Use the 4.11 one that DOSbox uses ... check
MAKE SURE that the SB settings do NOT conflict with the GUS ones ... check

Nope, doesn't work. Maybe there is a setting in the BIOS that causes this problem?
by Katakis
Thu 21 Jan, 2016 1:44 am
Forum: General
Topic: Problem with Windows 3.1x and GUS
Replies: 3
Views: 3209

Problem with Windows 3.1x and GUS

I am trying to get the Gravis UltraSound working with Windows 3.1x, but the sound doesn't work properly regardless of whether I am using 3.1 or 3.11. The startup and shutdown sounds are cut off, but the other sounds are fine. Also, when you try exiting Windows, it locks up instead of returning you t...
by Katakis
Fri 01 Jan, 2016 6:36 am
Forum: General
Topic: Host machine survey
Replies: 152
Views: 112154

Re: Host machine survey

3.4Ghz Intel Core i7
16MB
1GB nVIDIA GeForce 675MX
OS X 10.10 (running PCem through Wine)