v10 released!

Support and general discussion.
User avatar
SarahWalker
Site Admin
Posts: 1718
Joined: Thu 24 Apr, 2014 4:18 pm

Re: v10 released!

Post by SarahWalker » Sun 01 Nov, 2015 4:12 pm

The other drive option should be '5.25" 360k / 3.5"', ie a drive that is both a 360k 5.25" drive and a 3.5" drive, as there isn't much need to distinguish between the two from the emulator's point of view.

ovctvct
Posts: 11
Joined: Wed 28 Oct, 2015 3:07 pm

Re: v10 released!

Post by ovctvct » Sun 01 Nov, 2015 4:58 pm

MMXbug.png
MMXbug.png (14.41 KiB) Viewed 3321 times
As you can see, selecting any Mobile Pentium CPU with the Award 430VX PCI will cause it to be reported as a random 486 CPU. But from windows it is recognized correctly.

User avatar
SarahWalker
Site Admin
Posts: 1718
Joined: Thu 24 Apr, 2014 4:18 pm

Re: v10 released!

Post by SarahWalker » Sun 01 Nov, 2015 6:14 pm

Your BIOS appears to be too old to be aware of the Mobile Pentium MMXs. Using a more recent one it's fine :
pcem_mobilemmx.png
pcem_mobilemmx.png (33.44 KiB) Viewed 3316 times

ecksemmess
Posts: 155
Joined: Wed 18 Mar, 2015 5:27 am

Re: v10 released!

Post by ecksemmess » Sun 01 Nov, 2015 6:36 pm

TomWalker wrote:Sorry, I must be missing something - in what way does this make the Advanced/EV unusable? The BIOS POSTs with no errors, and DOS mouse drivers and Windows correctly detect and use the serial mouse.
D'oh! There are actually two issues, one of which was entirely my fault, and I appear to have conflated them. Sorry about that. The Advanced/EV mouse was completely unusable on my build because of an experimental patch I forgot I still had applied, so please disregard that. It does work fine in both DOS and Windows, as you say. However, note that the BIOS still doesn't actually detect the serial mouse on the Advanced/EV. Here's what I'm seeing:
PCem Endeavor Mouse Detection 1.png
PCem Endeavor Mouse Detection 1.png (12.15 KiB) Viewed 3311 times
PCem Endeavor Mouse Detection 2.png
PCem Endeavor Mouse Detection 2.png (22.25 KiB) Viewed 3311 times
The Premiere/PCI, with its very similar BIOS but using the PS/2 mouse emulation, does not have this problem. (Yes, I realize it's cosmetic and inconsequential, but since we were on the subject figured I might as well point it out.) By the way, the memory display bug seen in the CMOS settings, which I'm pretty sure has been pointed out before, appears to manifest reliably and persistently, even when the POST memory test behaves properly; the second screenshot here was taken immediately after the first. Not sure if that sheds any additional light on what's going on there.

EluanCM
Posts: 70
Joined: Tue 27 Oct, 2015 2:07 pm
Location: Brazil
Contact:

Re: v10 released!

Post by EluanCM » Sun 01 Nov, 2015 7:43 pm

I'm guessing that BIOS label only shows that a PS/2 mouse was detected, not a serial one (I doubt the BIOS tries to detect serial mice, because the ports are not dedicated)

ecksemmess
Posts: 155
Joined: Wed 18 Mar, 2015 5:27 am

Re: v10 released!

Post by ecksemmess » Sun 01 Nov, 2015 7:46 pm

It's been years since I actually played with one of these boards, but I could have sworn that that particular BIOS managed to detect the presence of serial mice as well. I might be thinking of a different board, though.

neozeed
Posts: 176
Joined: Tue 08 Jul, 2014 4:41 am
Location: Hong Kong SAR
Contact:

Re: v10 released!

Post by neozeed » Mon 02 Nov, 2015 8:09 am

I'm in Shenzhen right now and just downloaded v10 in 10 seconds.

startmenu
Posts: 104
Joined: Sat 29 Nov, 2014 7:39 am

Re: v10 released!

Post by startmenu » Mon 02 Nov, 2015 8:36 am

Has anyone noticed the Voodoo memory dump file that still exists in the release build.

Battler
Posts: 793
Joined: Sun 06 Jul, 2014 7:05 pm

Re: v10 released!

Post by Battler » Mon 02 Nov, 2015 2:21 pm

The Advanced/EV BIOS only detects PS/2 mice, so maybe giving it a PS/2 mouse would be more correct.

And as far as CPU detection is concerned, TomWalker, you have a valid point there but... where do we find the more recent BIOS? :p

User avatar
SarahWalker
Site Admin
Posts: 1718
Joined: Thu 24 Apr, 2014 4:18 pm

Re: v10 released!

Post by SarahWalker » Mon 02 Nov, 2015 6:07 pm

Google? The version is given in the filename in the readme, it doesn't appear too hard to find online.

Post Reply