managed to compile and run PCem - some issues

Discussion of development and patch submission.
Post Reply
Posts: 100
Joined: Thu 05 Mar, 2015 6:42 am

managed to compile and run PCem - some issues

Post by Katakis »

I decided to post a new thread about this as I believe the "Mac OS X" thread is there for discussing problems with compiling.

So I was able to compile and run PCem v14 on macOS 10.12, but when I run ./pcem, I get the messages "Menu item not found: 1403" and "Menu item not found: 1404" and it cycles between these 2 messages during execution. The configuration manager appears and you are able to select a config and run. The emulation windows appears, but the text in the title bar is truncated (it reads "PCem v14 - 10" even though it is meant to say 100%.) I managed to fix this (temporarily) by changing the resolution of the window. When you close the window, the terminal says:

CoreAnimation: warning, deleted thread with uncommitted CATransaction; set CA_DEBUG_TRANSACTIONS=1 in environment to log backtraces, or set CA_ASSERT_MAIN_THREAD_TRANSACTIONS=1 to abort when an implicit transaction isn't created on a main thread.
Segmentation fault: 11

before the config manager eventually appears.

I tested 2 games out and I found out that the sound stutters a bit. This is quite noticeable in Hunter Hunted, 1 of the games I decided to test. This is not the result of my system being not up to scratch. I ran a copy of v14 on Windows 7 and the sound works perfectly fine.

Link to video
Posts: 7
Joined: Wed 31 Jan, 2018 9:49 pm

Re: managed to compile and run PCem - some issues

Post by jvernet »

I'm at the same point, with the same error, but i also have encountered this error during executiion (without closing anything.
Posts: 6
Joined: Wed 09 May, 2018 9:36 pm

Re: managed to compile and run PCem - some issues

Post by RetroAF »

This error 1403/1404 is normal. It is is described in the forum and said that it has no negative impact on anything.
Post Reply