Having trouble installing Windows 98 SE

Support and general discussion.
Post Reply
SuperWill99
Posts: 3
Joined: Sun 20 May, 2018 12:31 am

Having trouble installing Windows 98 SE

Post by SuperWill99 » Sat 02 Jun, 2018 11:08 pm

Hi, I'm kind of new here.
About a week ago, I managed to install Windows 98 SE correctly. But I did something wrong, and now I have to install it again. But for some reason, PCEm just won't let me...

When I try to use the Windows 98 boot disk, the installation goes fine until after the first reboot. It gets stuck at "Verifying DMA pool data..." and never gets to the second part of the installation.

I also have tried to use a bootable ISO with Plop Boot Manager to set it up, but I can't get it to work either. When I select "CD-ROM", a choppy animation of a window opening appears and then says something for a second, and then PCEm immediately closes without any trace of an error message. I think it says something like "PCEmHD" in the second line, but I can't tell. I even set drive D to CD-ROM, but it just won't work!

I even tried using 86box instead, but even that failed: it says "No fixed disks present." when I try to use FDisk as if there's no hard disk inserted even though there is.

Can someone please help me? I've been stuck at this for hours today, and I haven't been able to get far in installing Windows 98 SE. What is wrong?


EDIT: I checked the PCEm log file with the second method and it says "Device failed to request command". How do I fix it?

User avatar
leilei
Posts: 606
Joined: Fri 25 Apr, 2014 4:47 pm

Re: Having trouble installing Windows 98 SE

Post by leilei » Sun 03 Jun, 2018 12:25 am

Sounds like 430VX - Try going into the BIOS and enable "reset configuration data" in the PNP/PCI config screen. Sometimes that'll get around a freeze on post.

It's also important to have absolute paths to your hard drive images and CD-ROM image.

and finally, not all 98SE CDs are bootable - only the OEM ones are.

Post Reply