No CD Audio in v15

Discussion of development and patch submission.
Post Reply
ForBarterOnly
Posts: 4
Joined: Thu 28 Dec, 2017 8:44 pm

No CD Audio in v15

Post by ForBarterOnly » Sat 29 Jun, 2019 2:02 pm

Hello!
Have been testing the newest version and have found an CD audio issue.
Seems certain CD-ROMs are not fully suppported yet.

E.g. I have the CD-ROM version of Sam & Max - Hit the Road.
The startup menu shows an option to play CD audio tracks.
Four music tracks from the game.
When I try to do that in v15 the animation in the menu stops for a moment, as it should, but the music isn't playing.

Lemmimgs 3 is another game, which suffers from the same problem, no ingame music, also CD audio tracks.

It is related to these games requiring a CD audio cable connected to the sound card.
The disks are fine. It is working in DosBox, would be great, if it was working in PCem, too.

karr
Posts: 17
Joined: Thu 19 Jul, 2018 1:05 am

Re: No CD Audio in v15

Post by karr » Fri 12 Jul, 2019 9:11 pm

hi

i tested the german cd version of sam & max with pcem v15.
cd audio works for me.
with lemmings 3 i have to set normal music to minimum to be able to hear cd audio.

i tested both with ami 486 clone and with asus p55t2p4
with sb pro 2, sb16 and sb awe32.

may be cd audio output is set to low in your soundcard mixer.

User avatar
leilei
Posts: 685
Joined: Fri 25 Apr, 2014 4:47 pm

Re: No CD Audio in v15

Post by leilei » Sat 13 Jul, 2019 7:56 am

Sam & Max CD audio in that startup menu works for me too, in DOS w/ P75+SB16 at least...

seth
Posts: 30
Joined: Tue 14 Mar, 2017 12:13 pm

Re: No CD Audio in v15

Post by seth » Sun 14 Jul, 2019 9:41 pm

Same. AMI 486 clone, i486dx2/66, 16mb, sb16 (nuked opl)

https://streamable.com/y9agb

Try this, maybe?
aaa.png
aaa.png (23.95 KiB) Viewed 1581 times

ForBarterOnly
Posts: 4
Joined: Thu 28 Dec, 2017 8:44 pm

Re: No CD Audio in v15

Post by ForBarterOnly » Mon 30 Sep, 2019 10:01 pm

Thanks for the replies. Also for the video, was helpful. Now I know it can work fine.
That's how it should sound, and how it sounds, when I use DosBox.
I'd like to have the same volume in PCem, too.

I would've replied earlier, but, well... troubles.
Since this is an issue I'd like to fix, finally I had some time to check it out and play around with it.
So your replies have not been for nothing.

Indeed the sound is there... for now I have tested my configuration, which is:
Award 486 / SiS 496, 486 DX/50
I switched sound to a Sound Blaster Pro 2.0 (was a non-pro earlier, with standard settings and DBOPL emulation, SET BLASTER also added in AUTOEXEC.BAT). Correct settings there.

I know Windows has several controls, all are maxed out. I max out the volume and set it on the headphones, which I use, to my liking.
For now I always used the Normal level in PCem. At output level Normal I hear nothing at 4/10 volume on my headphones (which is a good volume level for everything else) and when I max the volume to 10, I can barely hear some music, between all the noise...
So I maxed out the output level to +18db.

Compared to the video my output is still very quiet, even at +18db.
When I start the game in DosBox it sounds good. Just as it should, loud at normal level, no background noise.
Really just as in the video posted earlier.

I can't record a video now, so I just grabbed my sound output through Audacity.
The mixer is all set at full volume, incl. the speaker output and PCem, only Windows sounds are at 20%.
It should be fine, the mixer's volume is good.

I recorded everything starting with the LucasArts logo, where volume is good, but that is a Midi sound. and then played the same CD-Audio tracks.
You will hear the difference in volume. Between the logo and the CD-audio tracks I didn't change anything, it really is that quiet.

Here is the .mp3 of the recording:
https://1drv.ms/u/s!AqNqr15txL3MgZw38Oe ... g?e=zSuGcY

I also played around a bit, and the CD-Audio level in Windows Sound settings (in Control Panel) doesn't change a thing. I can keep the level at 24 (which is standard) or max it out to 100, it should get louder, but doesn't, the level stays the same.

Actually I only hear the CD-Audio music with Microsoft's Loudness Equalization being enabled. (Speaker properties > Enhancements) If I disable it, the volume is much lower. But I can hear something, between the noise. Barely, though.
With the best settings I can barely get ~ 1/3 of the volume which it should be.

If I start the same games, using the same CD images in DosBox the volume is good. So the issue is not with the CD-Audio tracks.

If I go 'all out' and disable both, Loudness Equalization and return the output level in PCem to Normal... I get only noise... even if I max out the headphones/speakers... only noise. As if PCem's input level was too low. Normal sounds/midi music play fine. Luckily the sounds didn't damage my speakers. Only the CD-Audio is not there. I can play e.g. Wing Commander Academy fine, at volume output level Normal, it sounds just as in DosBox.
Why? Makes no sense.

Since I used the SB Pro 2.0 there is no digital mixer being set too low, as with a SB 16, no issue here.

All this I tried with Microsoft's HD Audio driver... Since my on-board sound is Realtek, I installed Realtek's driver and wanted to see if it makes a difference, it doesn't.

I know I can play all these games in DosBox, but I prefer PCem...

That's all information I can give, plus maybe: using WIndows 10 1903, latest patch level. But I had this issue also with earlier Windows builds. I really have an issue here, if more information is needed, let me know. Would be nice, if it would work fine here. I don't think a clean Windows installation would change anything, so I am saving that for later.

All 'volume knobs' are maxed out or make no difference.

If anybody has an idea, let me know and I will try/test it as soon as I can.

Looking forward to any replies!

JosepMa
Posts: 140
Joined: Tue 20 Jun, 2017 6:25 pm

Re: No CD Audio in v15

Post by JosepMa » Sun 06 Oct, 2019 6:14 pm

You need to change the mixer values on DOS or on the emulated Windows, not on your host Windows system.

When I implemented the new mixers for the soundblasters, I followed the programming guide that suggested that the default for the CD audio was silence (which in this context means -60dBs, so not completely silent)
When installing the DOS drivers or Windows drivers, the drivers themselves can setup other defaults and they can also restore the values saved previously.

Maybe It would be a good addition to the program to have a mixer that could be accessed from PCem menu, similar to the gain that was added recently.

Post Reply